Contents

Introduction ............................................................................................................................................... 13

Chapter 1  Getting Started

1.1  System Requirements .................................................................................................................... 15
1.2  Installing KaleidaGraph ................................................................................................................ 16
1.3  Uninstalling KaleidaGraph ............................................................................................................ 16
1.4  KaleidaGraph Basics ...................................................................................................................... 17
     Starting KaleidaGraph .................................................................................................................... 17
     Data Window Overview .................................................................................................................. 18
     Plot Window Overview ................................................................................................................... 18
     Using the Toolbar ........................................................................................................................... 20
     Using the Shortcut Menu ................................................................................................................ 20
     Opening KaleidaGraph Files .......................................................................................................... 20
     Sharing Files Across Platforms ..................................................................................................... 21
     Saving Files in a v3.5 Format .......................................................................................................... 21
     Getting Help ................................................................................................................................... 22
     Setting Preferences ....................................................................................................................... 23
     Quitting KaleidaGraph ................................................................................................................... 24

Chapter 2  Working with Data Windows

2.1  Hiding, Displaying, and Closing Data Windows ........................................................................... 25
    Creating a New Data Window ............................................................................................................ 25
    Changing the Active Window .......................................................................................................... 25
    Hiding Data Windows ...................................................................................................................... 25
    Displaying Data Windows .............................................................................................................. 25
    Closing Data Windows .................................................................................................................... 26

2.2  Moving Around the Data Window ................................................................................................. 26
    Using the Mouse ............................................................................................................................. 26
    Using the Keyboard ......................................................................................................................... 26
    Using the Go To Cell Command ..................................................................................................... 27

2.3  Switching Between Overwrite and Insert Mode .......................................................................... 27

2.4  Making Selections in the Data Window ........................................................................................ 27
    Selecting Rows ............................................................................................................................... 27
    Selecting Columns .......................................................................................................................... 28
    Selecting a Range of Cells .............................................................................................................. 28
    Selecting the Entire Window .......................................................................................................... 28

2.5  Adding and Deleting Rows and Columns ...................................................................................... 28
    Adding Rows and Columns ............................................................................................................. 28
    Inserting Rows and Columns .......................................................................................................... 29
    Deleting Rows and Columns .......................................................................................................... 29

2.6  Formatting Data Columns ............................................................................................................. 30
Chapter 3 Working with Data

3.1 Entering Data
   Entering Numeric Data
   Entering Date or Time Data
   Entering Text Data
   Missing Values

3.2 Generating a Data Series

3.3 Importing Microsoft Excel Files

3.4 Importing Text Files
   Text File Input Format Dialog
   Importing Missing Data Points
   Example - Reading Basic Formats
   Using the Special Format
   Example - Reading Special Formats
   Special Format Examples

3.5 Editing Column Titles

3.6 Changing the Number Type and Formatting

3.7 Cutting, Copying, Pasting, and Clearing Data
   Binary Mode/Text Mode Setting
   Cutting Data
   Copying Data
   Pasting Data
   Clearing Data
   Including Column Titles when Editing Data

3.8 Sorting Data

3.9 Transposing Data

3.10 Masking Data

3.11 Executing Macros

3.12 Exporting Data
   Saving Data
   Printing Data

Chapter 4 Analyzing Data

4.1 Viewing Column Statistics

4.2 Binning Data
   Binning the Data
   Pasting the Results from the Bin Data Dialog
Creating the Plot ................................................................. 56
4.3 Choosing a Statistical Test .................................................. 57
4.4 Parametric and Nonparametric Tests ..................................... 58
4.5 Analyzing One Sample ......................................................... 58
   Entering Data for One Sample Tests ........................................ 58
   Performing a Single Sample t-Test ......................................... 58
   Performing a Wilcoxon Signed Rank Test ................................ 60
4.6 Analyzing Two or More Groups ............................................ 61
   Entering Data for Group Comparison Tests ............................... 61
   Performing an Unpaired t-Test .............................................. 64
   Performing a Wilcoxon-Mann-Whitney Test ............................. 65
   Performing a One Way ANOVA ............................................ 65
   Performing a Two Way ANOVA .......................................... 67
   Performing a Kruskal-Wallis Test ........................................ 67
4.7 Analyzing Repeated Measurements ..................................... 69
   Entering Data for Repeated Measurements ............................... 69
   Performing a Paired t-Test .................................................. 71
   Performing a Wilcoxon Matched Pairs Test ............................. 72
   Performing a One Way Repeated Measures ANOVA .................... 72
   Performing a Two Way Repeated Measures ANOVA ................... 73
   Performing a Friedman Test ............................................... 74
4.8 Choosing a Post Hoc Test ................................................... 76
   Tukey HSD Test ............................................................... 76
   Student-Newman-Keuls Test .............................................. 77
   Bonferroni Test ................................................................ 77
   Holm Test ..................................................................... 77
   Scheffe Test ................................................................... 78
   Fisher’s LSD Test .............................................................. 78
   Dunnett Test .................................................................... 78

Chapter 5 Working with Formula Entry

5.1 Formula Entry Basics ........................................................ 79
   Formula Entry Menus .......................................................... 80
   Formula Structure ............................................................... 81
   Referencing Columns, Cells, and Memory Registers .................... 81
   Entering and Executing a Formula ........................................ 82
   Assigning Formulas to Function Buttons ................................. 82
5.2 Calculating Statistics with Formula Entry ............................ 83
   Individual Column Statistics .............................................. 83
   Statistics on a Specific Block of Data .................................... 83
   Calculating Statistics on a Row-by-Row Basis .......................... 84
5.3 Masking Data with Formula Entry ........................................ 84
5.4 Interpolating Data ............................................................. 85
5.5 Performing Date and Time Calculations ............................... 85
5.6 Multi-Line Formulas .......................................................... 86
   Adding Comments ............................................................. 87
   Saving Multi-Line Formulas ................................................ 87
5.7 Function Descriptions and Syntax .................................................. 87
  Operators Menu ........................................................................... 87
  Functions Menu ........................................................................... 89
  Statistics Menu ........................................................................... 90
  Curve Fits Menu ......................................................................... 91
  Special Menu ............................................................................... 92
  Library Menu ............................................................................... 92

Chapter 6 Creating Plots

6.1 Types of Plots ........................................................................... 93
  Line Plot .................................................................................... 93
  Scatter Plot ............................................................................... 94
  Double Y Plot ........................................................................... 94
  Double X Plot ........................................................................... 94
  Double XY Plot .......................................................................... 95
  High/Low Plot ........................................................................... 95
  Step Plot ................................................................................... 96
  Probability Plot .......................................................................... 96
  X-Y Probability Plot ................................................................... 96
  Histogram Plot ........................................................................... 97
  Box Plot .................................................................................... 97
  Percentile Plot ........................................................................... 98
  Dot Plot .................................................................................... 98
  Summary Column Plot ................................................................ 99
  Horizontal Bar Plot ................................................................... 99
  Stack Bar Plot ........................................................................... 100
  Double Y Bar Plot ..................................................................... 100
  Column Plot .............................................................................. 101
  Stack Column Plot ..................................................................... 101
  Double Y Column Plot ............................................................. 102
  Polar Plot .................................................................................. 102
  Pie Chart .................................................................................. 103
  Function Plot ............................................................................ 103
  Text Plot .................................................................................. 103
  Template Plot ............................................................................ 103

6.2 Creating a Plot ......................................................................... 104
  Plotting from Multiple Data Windows ..................................... 105
  Plotting Multiple X-Y Pairs from the Same Data Window .......... 106

6.3 Plotting a Function ................................................................... 107

6.4 Generating Similar Plots ............................................................ 108
  Using Style Files......................................................................... 108
  Using Template Plots ............................................................... 109
  Using Plot Scripts ...................................................................... 110
  Using Formula Scripts .............................................................. 110

Chapter 7 Working with Plots

7.1 Hiding, Displaying, and Closing Plots ......................................... 111
Contents

7 Changing the Active Window ................................................................. 111
7.1 Hiding Plot Windows ........................................................................ 111
7.2 Displaying Plot Windows ................................................................... 112
7.3 Closing Plot Windows ...................................................................... 112
7.4 Changing the View of the Plot Window ............................................. 112
7.5 Displaying Rulers and Grids in the Plot Window ................................ 112
7.6 Modifying the Legend ....................................................................... 113
7.7 Editing the Legend Frame and Color ................................................. 113
7.8 Editing Legend Text .......................................................................... 115
7.9 Modifying Axes .............................................................................. 116
7.10 Setting the Axis Limits .................................................................... 117
7.11 Selecting Linear or Log Scaling ...................................................... 117
7.12 Changing the Position of an Axis .................................................... 118
7.13 Inserting an Axis Break .................................................................... 119
7.14 Removing an Axis Break ................................................................... 119
7.15 Hiding an Axis ................................................................................. 119
7.16 Exchanging Axes ............................................................................. 120
7.17 Reversing the Variables on an Axis ................................................. 120
7.18 Linking a Second Axis ...................................................................... 120
7.19 Changing Axis Thickness ................................................................ 121
7.20 Modifying Tick Marks and Grid Lines ............................................. 122
7.21 Changing the Display of Tick Marks and Grid Lines ....................... 123
7.22 Changing the Number of Tick Marks .............................................. 123
7.23 Changing the Tick Mark Interval ..................................................... 124
7.24 Changing Tick Mark Length .......................................................... 124
7.25 Changing Tick Mark and Grid Line Thickness .................................. 124
7.26 Modifying Axis Labels ..................................................................... 125
7.27 Controlling the Frequency of Axis Labels ....................................... 126
7.28 Formatting Axis Labels .................................................................... 126
7.29 Modifying Lines, Markers, and Fill Patterns ................................... 127
7.30 Selecting Variables in the Variable Settings Dialog ....................... 127
7.31 Changing Marker Type, Size, or Number of Markers ..................... 128
7.32 Selecting Fill Patterns ..................................................................... 128
7.33 Changing Appearance of Variable and Curve Fit Lines .................. 128
7.34 Changing Line and Marker Thickness ............................................. 129
7.35 Changing Plot Color ....................................................................... 129
7.36 Resizing the Plot .............................................................................. 130
7.37 Set Plot Size Command .................................................................. 130
7.38 Using the Selection Arrow ............................................................... 131
7.39 Extracting Data from a Plot ............................................................. 131
7.40 Updating Plotted Data ..................................................................... 132
7.41 Plotting Additional Data .................................................................. 133
7.42 Customizing Bar Plots ..................................................................... 134
7.43 Changing Bar Attributes .................................................................. 134
7.44 Adding Value Labels ...................................................................... 135
7.45 Adding Lines to Bar and Column Plots .......................................... 136
7.46 Customizing Polar Plots .................................................................. 137
Chapter 8  Working with Plot Tools and Objects

8.1  The KaleidaGraph Toolbox ......................................................... 141
     Plot Tools ........................................................................ 141
     Toolbox Icons ................................................................ 143
8.2  Using the Table Tool ................................................................. 145
     Creating and Editing Tables ............................................ 145
     Setting Defaults for Tables .......................................... 146
8.3  Using the Identify Tool .............................................................. 147
8.4  Using the Data Selection Tool .................................................... 147
     Graphically Removing Outliers ...................................... 148
     Graphically Selecting a Subset of Data ......................... 149
8.5  Using the Zoom Selection Tool .................................................. 149
8.6  Working with Objects ............................................................... 151
     Selecting and Deselecting Objects .................................. 151
     Moving Objects ................................................................ 151
     Resizing Objects .......................................................... 152
     Duplicating Objects ....................................................... 152
     Copying Objects .......................................................... 152
     Pasting Objects ........................................................... 153
     Deleting Objects ........................................................... 153
     Grouping and Ungrouping Objects ................................. 153
     Aligning Objects .......................................................... 154
     Sending Objects Up or Down ........................................... 155
8.7  Creating and Editing Text Labels .................................................. 156
     Creating a Text Label ...................................................... 156
     Editing Plot Labels ........................................................ 157
     Adding Subscripts or Superscripts to a Text Label .......... 158
     Adding Special Characters to a Text Label .................... 158
     Setting Defaults for Text Labels ...................................... 158
8.8  Creating and Editing Shapes ....................................................... 160
     Lines and Arrows .......................................................... 160
     Rectangles, Rounded Rectangles, Ovals, and Arcs .......... 161
     Polygons ................................................................. 162
     Bezier Curves ............................................................. 163
8.9  Adding Colors and Patterns to Shapes ........................................ 164
     Setting Default Attributes for Shapes ........................... 164
     Changing Foreground and Background Colors ................. 165
     Changing Fill and Pen Patterns ..................................... 166
     Changing Line Styles and Widths ..................................... 166
Chapter 9 Working with Curve Fits and Error Bars

9.1 Purpose of Curve Fitting ........................................................... 167
9.2 Types of Curve Fits .................................................................. 168
  General ................................................................................. 168
  Linear .................................................................................. 168
  Polynomial ........................................................................ 168
  Exponential ....................................................................... 168
  Logarithmic ....................................................................... 168
  Power ............................................................................... 169
  Smooth ............................................................................. 169
  Weighted .......................................................................... 169
  Cubic Spline ...................................................................... 169
  Interpolate ........................................................................ 169
9.3 Choosing a Curve Fit Model ....................................................... 170
9.4 Applying a Least Squares Fit ..................................................... 171
9.5 Applying a Smoothing Fit .......................................................... 172
9.6 General Curve Fit Basics ........................................................... 174
  Curve Fit Definition............................................................. 174
  Initial Conditions ................................................................ 175
  Curve Fit Definition Dialog ................................................... 175
  Managing the Curve Fit List ................................................. 176
9.7 Using the General Curve Fit....................................................... 177
  Using the Predefined Curve Fit Definitions.............................. 178
  Entering a Custom Curve Fit Definition ................................. 180
  Applying a General Curve Fit............................................... 181
  Weighting Data .................................................................. 183
  Fitting Equations with Multiple Independent Variables .......... 183
  Setting Limits for Curve Fit Parameters ................................. 183
  The General Curve Fit and the Macro Calculator .................... 184
9.8 Working with Curve Fit Results .................................................. 184
  Viewing Curve Fit Results .................................................... 184
  Interpreting Curve Fit Results .............................................. 186
  Exporting Curve Fit Results.................................................. 186
  Using Formula Entry to Obtain Values from a Curve Fit............ 188
9.9 Removing a Curve Fit ............................................................... 192
9.10 Other Curve Fit Features........................................................... 193
  Changing the Appearance of the Curve Fit Line....................... 193
  Changing the Appearance of the Curve Fit Equation ............... 193
  Extrapolating to the Axis Limits ........................................... 194
  Forcing a Linear Fit Through the Origin ................................. 194
  Increasing the Number of Curve Fit Points ............................. 194
  Displaying Only the Curve Fit ............................................. 195
9.11 Working with Error Bars............................................................ 195
  Adding Error Bars ................................................................ 195
  Plotting Error Values from a Data Column ............................. 197
  Adding Text Error Bars ...................................................... 197
  Creating Single-Sided Error Bars ........................................ 199
## Contents

Using Pattern Recognition to Create New Groups .................... 227  
Pointing Groups to Different Data Windows ............................. 228  
Exporting Plots Automatically ........................................... 229  
Saving and Loading Scripts ............................................... 229  

### 12.2 Formula Scripting ..................................................230  
Creating a Formula Script ................................................ 230  
Formula Script Commands ............................................... 231  
Example Formula Scripts .............................................. 241  

## Chapter 13 Using the Library

### 13.1 Overview of the Library ............................................245  
### 13.2 Library Syntax .................................................... 246  
### 13.3 Defining Variables in the Library ...............................246  
### 13.4 Defining Constants in the Library ...............................247  
### 13.5 Defining Mathematical Functions in the Library ..........247  
### 13.6 Defining Curve Fit Functions in the Library ................249  
  - Creating a Basic General Curve Fit Definition ................. 249  
  - Creating a Complex General Curve Fit Definition ............ 250  
### 13.7 Loading a Saved Library File ....................................251  
### 13.8 Saving the Current Library .......................................251  
### 13.9 Creating a New Library .......................................... 251  

## Appendixes

### Appendix A KaleidaGraph’s Settings Files .........................253  
### Appendix B Toolbox Shortcuts .......................................255  
### Appendix C Reference Information ...................................263  
Glossary ........................................................................... 269  
Index .............................................................................. 275
Introduction

Thank you for purchasing KaleidaGraph®, our thoughtfully designed technical graphing and data analysis application for Windows and Macintosh. Please spend time with our documentation and maximize the power of KaleidaGraph to increase your productivity.

About this Manual
The manual assumes that you are familiar with basic operations, such as clicking, double-clicking, and dragging. It also assumes familiarity with the components of the user interface, such as menus, windows, dialogs, buttons, and check boxes. If you are not familiar with these terms, review the documentation that came with your computer.

Organization of the Manual
This manual contains examples and procedures for common tasks, such as entering data, creating plots, and applying curve fits. The following is a brief overview of the chapters and appendixes in the manual:

- Chapter 1, “Getting Started,” discusses system requirements, installation, and several basic concepts, including opening files, getting help, and quitting the program.
- Chapter 2, “Working with Data Windows,” discusses how to navigate, make selections, add and delete rows and columns, and format columns in the data window.
- Chapter 3, “Working with Data,” discusses how to enter, import, edit, sort, and export data in the data window.
- Chapter 4, “Analyzing Data,” discusses how to view column statistics, bin data, and analyze data using a number of parametric and nonparametric statistical tests.
- Chapter 5, “Working with Formula Entry,” discusses how to use the Formula Entry window to perform calculations in the active data window.
- Chapter 6, “Creating Plots,” discusses the different plot types, creating a plot, and generating similar plots.
- Chapter 7, “Working with Plots,” discusses how to modify the plot, including the axes, ticks, grids, markers, and plot color.
- Chapter 8, “Working with Plot Tools and Objects,” discusses the plot tools available in KaleidaGraph, in addition to creating and editing text labels and shapes.
- Chapter 9, “Working with Curve Fits and Error Bars,” discusses how to add curve fits and error bars to a plot.
- Chapter 10, “Importing and Exporting Graphics,” discusses how to import graphic objects into a plot and export the plots to a printer, file, or another program.
- Chapter 11, “Working with the Layout Window,” discusses how to use the layout window to place multiple plots on a single page.
• Chapter 12, “Working with Scripts,” discusses how to use plot scripts and formula scripts to automate the process of creating plots in KaleidaGraph.

• Chapter 13, “Using the Library,” discusses how to use the library to create shorthand references for variables, constants, math functions, and curve fit equations that you use on a regular basis.

• The Appendixes contain information on the settings files and toolbox shortcuts, as well as general reference information.

**Learning KaleidaGraph**

If you are new to KaleidaGraph, we recommended that you take the guided tour in the Quick Start Guide (located in the Manuals folder that was installed with KaleidaGraph). This tutorial guides you through the process of generating a data set, creating and editing two different plots, and placing the plots onto a single page. Some of the other topics in the tutorial include modifying the legend, using Formula Entry, applying a General curve fit, and modifying data in a saved plot.

Once you start using KaleidaGraph, you can refer to the manual and the online Help for step-by-step instructions to complete specific tasks. The online Help also includes detailed information on the commands and dialogs available in the program.

**Conventions**

This manual uses the following conventions:

- Instructions for choosing commands are displayed in bold type. Levels are separated with a greater than symbol (>). For example: Choose **Gallery > Linear > Line**.

- Dialog buttons and options are displayed in bold type. For example: Click **OK**.

- Keys that you should press appear in bold type. If joined with a plus sign (+), press and hold the first key while you press the remaining keys. For example: Press **⌘ + Period**.

**Contacting Synergy Software**

Please take the time to register your program during installation to receive free technical support and upgrade information. You can also register by accessing the registration page on our web site (www.synergy.com/register.htm).

If you have any questions concerning KaleidaGraph, please contact us at:

Synergy Software  
2457 Perkiomen Avenue  
Reading, PA 19606-2049 USA  
Internet addresses:  
Sales/Upgrades: sales@synergy.com  
Tech support: tech@synergy.com

Phone: (1) 610-779-0522  
Fax: (1) 610-370-0548  
Web sites: www.kaleidagraph.com  
www.synergy.com

Please feel free to check our web site periodically for:

- Product descriptions
- Technical notes
- Frequently asked questions
- New release information
- Downloadable upgrade patches
- Show schedules and press releases
- And other topics of interest
Getting Started

Chapter 1

This chapter lists the hardware and operating system requirements and explains how to install KaleidaGraph onto your computer. It also covers some basic concepts, including:

- Starting KaleidaGraph.
- Introducing the data and plot windows.
- Using the toolbars and shortcut menus.
- Opening saved files.
- Opening KaleidaGraph files on another platform.
- Saving files in a v3.5 format.
- Using the Help system.
- Setting preferences.
- Quitting the program.

1.1 System Requirements

To run KaleidaGraph on a Macintosh, you need the following:

- OS 10.3.9 or later.
- 45 MB free hard disk space.
1.2 Installing KaleidaGraph

The installer creates a new folder on your hard disk containing the KaleidaGraph software. If you are upgrading from an earlier version, your existing KaleidaGraph files are not affected.

To install KaleidaGraph on your hard disk:

1. Run the KaleidaGraph 4.1 Installer from either the CD or your hard drive.
2. Proceed through the ReadMe information, license agreement, and Destination screen to display the Installation Type screen.
3. Choose the installation method (easy or custom).
   The Easy Install option automatically installs the following items:
   - The KaleidaGraph application.
   - An Examples folder containing example plots, data files, and curve fits.
   - The KaleidaGraph Help and New Features documents.
   - A Manuals folder containing PDF versions of the KaleidaGraph documentation.
   To control which files get installed, choose Custom Install from the pop-up menu.
4. Click Install. A KaleidaGraph folder is created on your hard disk and the files are installed. A Status bar is displayed to keep you informed as the installation progresses.
5. The installer will ask if you want to submit your registration information. By registering the software, you will receive free technical support and upgrade information.
6. Once all of the program files have been installed, a message is displayed to let you know the installation of KaleidaGraph is complete.

Note: If you are updating from v3.5x or earlier, the default location for storing the settings files (KG Style, KG Macros, KG Layout, and KG Script) has changed. The settings files are now stored in the KaleidaGraph Preferences folder. The KaleidaGraph Preferences folder is located in the Preferences folder (in the user’s Library folder). The installer automatically moves a copy of the settings files into the new location.

1.3 Uninstalling KaleidaGraph

To remove the KaleidaGraph software from your hard disk:

1. Run the KaleidaGraph 4.1 Installer from either the CD or your hard drive.
2. Proceed through the various screens until you reach the Installation Type.
3. Choose Uninstall from the pop-up menu and click Uninstall.

Note: If you no longer have the KaleidaGraph Installer, you can drag the KaleidaGraph 4.1 folder to the Trash and choose the Empty Trash command to remove the application from your hard drive.
1.4 KaleidaGraph Basics

This section introduces some of KaleidaGraph’s basic concepts, such as starting the program, opening files, and quitting the program. An overview of the data and plot windows is also included.

1.4.1 Starting KaleidaGraph

To start KaleidaGraph, double-click the KaleidaGraph icon.

The first time the program is started, the dialog in Figure 1-1 is displayed to personalize your copy of KaleidaGraph and enter your serial number and authorization code.

![Figure 1-1 Personalization dialog](image)

The serial number and authorization code can be found on either the CD-ROM case or in the order confirmation that was sent via e-mail for electronic orders. If this is an update from an earlier version, use your original serial number.

**Note:** The **OK** button will not activate until a valid authorization code is entered. Some common issues that prevent the **OK** button from being active include:

- Typing the letter O instead of a zero. None of the codes use the letter O.
- Typing lower case letters.
- Typing the wrong character by accident (for example, K for X or A for 4).
- Trying to copy and paste the code from the order confirmation.
- Typing spaces instead of dashes.

After you click **OK**, two windows are displayed; a data window and the Formula Entry window. The next section contains an introduction to the data window. Refer to Chapter 5 for information on using the Formula Entry window to analyze and manipulate data in the active data window.
1.4.2 Data Window Overview

The data window, shown in Figure 1-2, contains a worksheet used to enter and store data for plotting and analysis. It consists of a number of cells organized in columns. A data window can contain a maximum of 1000 columns and 1 million rows, subject to memory limitations.

![Data window](Figure 1-2 Data window)

The various elements of the data window are described below:

- **Toolbar** - The buttons in the toolbar provide shortcuts to commonly used commands. See Section 1.4.4 for more information about the toolbar.
- **Home button** - Clicking this button returns the data window to its origin (row 0, column 0).
- **Vertical and Horizontal splits** - These controls are used to split the data window into multiple panes. This allows you to view two sections of the data window simultaneously.
- **Current position** - This area of the data window shows the position of the current cell.
- **Expand/Collapse button** - Clicking this button allows you to expand or collapse the column headers to display or hide the column numbers. To display the column numbers by default, select the **Show Column Numbers** check box in the Preferences dialog.
- **Column titles** - This area of the dialog contains the title of each data column. By default, the column titles are A, B, C, and so on for a new data window. The titles can be edited directly in the data window.

1.4.3 Plot Window Overview

Plots are created by entering data into the data window and choosing a plot type from the **Gallery** menu. After selecting the data columns to be plotted, the plot is generated and displayed in the plot window. Figure 1-3 shows the components of the plot window.
The various elements of the plot window are described below:

- **Legend** - The legend consists of a frame, the plot symbols, and the labels used to identify each variable in the plot. By default, the labels are taken from the names of the columns in the data window. The variables are listed in the order they are selected for plotting.

- **Toolbox** - The plot tools are located on a movable palette. The tools are used to create, modify, and enhance objects in the plot window.

- **Axis labels** - The axis labels display the values associated with each of the major tick marks on the plot.

- **Zoom setting** - This pop-up menu can be used to change the view of the active plot window.

- **Extract button** - Clicking this button displays any data windows referenced by the plot.

- **Plot title** - The plot title is the name of the graph. By default, the plot title is taken from the name of the data window.

- **Major ticks** - The major tick marks are used to identify the major divisions along the axis.

- **Minor ticks** - Minor ticks display the divisions between major tick marks.

- **Grid lines** - The grid lines allow you to display a horizontal or vertical line at each of the major and minor tick marks in the plot.

- **Axis title** - The axis titles are taken from the column names of the data being plotted. If more than one variable is plotted on the same axis, the title is taken from the first column being plotted on that axis.
1.4.4 Using the Toolbar

KaleidaGraph provides a data window toolbar, shown in Figure 1-4, for easy access to some commonly used commands. If the toolbar is not displayed for a particular data window, choose **Data > Show Data Tools**. The Preferences dialog contains an option that controls the default state of the toolbar for any new data windows.

![Data window toolbar](image)

1.4.5 Using the Shortcut Menu

KaleidaGraph displays a shortcut menu containing commonly used commands when you are working in the data, plot, or layout window. The commands in the shortcut menu vary depending on what object is selected and where the pointer is when the shortcut menu is displayed. To display the shortcut menu, hold down **Control** while pressing the mouse button.

1.4.6 Opening KaleidaGraph Files

The **Open** command (**File** menu) can be used to open files previously saved from KaleidaGraph. This command can also be used to open Excel files, text files, and any graphic images that you want to include in the plot or layout window. The **Import** command can be used to import Style, Macro, and Program Text files. Multiple files can be opened at once by pressing **Shift** or **Control** and clicking the file names.

The **File** menu contains a **Recent Files** command that lists the last eight data or plot files that have been opened or saved in KaleidaGraph. You can open one of the files in the list by choosing its file name from the submenu.

For information on opening KaleidaGraph files created on another platform, refer to Section 1.4.7.
### 1.4.7 Sharing Files Across Platforms

KaleidaGraph has the ability to share files between the Macintosh and Windows platforms. The table below lists the file name extensions and file types required to do this successfully.

<table>
<thead>
<tr>
<th>Kind of File</th>
<th>File Name Extension</th>
<th>Macintosh File Type</th>
</tr>
</thead>
<tbody>
<tr>
<td>Data file</td>
<td>.QDA</td>
<td>QDAT</td>
</tr>
<tr>
<td>Plot file</td>
<td>.QPC</td>
<td>QPCT</td>
</tr>
<tr>
<td>Macro file</td>
<td>.EQN</td>
<td>EQNS</td>
</tr>
<tr>
<td>Layout file</td>
<td>.QPL</td>
<td>QPLY</td>
</tr>
<tr>
<td>Script file</td>
<td>.QSC</td>
<td>QSCP</td>
</tr>
<tr>
<td>Style file</td>
<td>.QST</td>
<td>QSTY</td>
</tr>
</tbody>
</table>

**Mac to Windows**

To take a Macintosh file and open it on a Windows computer, the file name must include the proper file name extension. This is not an issue under OS X because the file name extension is added automatically when saving the file. If **Hide Extension** is selected in the Save dialog, the extension will not be visible, but it will be added.

**Windows to Mac**

In most instances, Windows files can be opened directly from within the Macintosh version of KaleidaGraph. If you run into any problems, it may be necessary to use one of the AppleScript converters from our web site.

**Note:** If you still have problems, check which version of KaleidaGraph is installed. Version 4.1 can open any KaleidaGraph file, but versions 3.5x and 3.6x can only open files created by v4.1 if they were exported in a v3.5 format using the **Save As** command (see Section 1.4.8). Version 3.0x cannot open any files created in v3.5 or later.

### 1.4.8 Saving Files in a v3.5 Format

KaleidaGraph allows you to save the data, plot, and layout windows in a v3.5 file format so that these files can be opened in either v3.5x or v3.6x of KaleidaGraph. It is not possible to save these files in a v3.0x format.

To save a file in the v3.5 format:

1. Choose **Save Data As**, **Save Graph As**, or **Save Layout As** from the **File** menu.
2. Select **KaleidaGraph 3.5 Data**, **KaleidaGraph 3.5 Plot**, or **KaleidaGraph 3.5 Layout** from the **Format** pop-up menu.
3. Specify the location and file name for the file and click **Save**.
1.4.9 Getting Help

To get online Help, do any of the following:

- Choose **Help > KaleidaGraph Help**.
- Press the **Help** key on the keyboard.
- Click **Help** in any dialog that contains a **Help** button.

The Help dialog, shown in Figure 1-5, contains a table of contents for the topics available in the KaleidaGraph program. Click the topic and the dialog displays the information available for the selected topic. If you are unable to locate the desired information from the table of contents page, you can use the Index or search the entire Help system for a particular term.

![Help dialog](image)

**Figure 1-5  Help dialog**

**Features Added in v4.1**

Version 4.1 includes the following changes:

- Added support for the Intel Macintosh.
- Bitmap file export such as BMP, GIF, JPEG, PNG, and TIFF now uses QuickTime to generate the export files. As a result, a number of new settings are available such as byte ordering, LZW compression, and variable JPEG export quality. The options available vary based on the type of file being exported.
- High Resolution TIFF images are now exported with a resolution of 576 dpi.
1.4.10 Setting Preferences

KaleidaGraph provides a Preferences command in the KaleidaGraph menu that can be used to control a number of settings, including what files are saved when you quit the program and the default settings used for new data windows. The following dialog is displayed when you choose this command.

![Preferences dialog](image)

The pop-up menus in the File Settings tab control what happens to each of the different file types when quitting the program. For data and plot files, you can choose to Always save changes or to display a Prompt if there are any unsaved windows. If a data or plot window has not been saved previously, a Save dialog is displayed.

For the remaining types of files (Layout, Macros, Script, and Style), you can choose whether to display the Prompt dialog if any changes have occurred, Always save, or Never save the changes. For details on the information stored in each of these files, see Appendix A.

Note: The settings for this dialog are saved as part of the Style file. If you choose Never for the Style in the File Settings tab, you must manually overwrite the default Style file by choosing File > Export > Style.
1.4.11 Quitting KaleidaGraph

To close the KaleidaGraph program and return to the desktop, choose KaleidaGraph > Quit KaleidaGraph. KaleidaGraph saves any changes to the default Style, Macros, Script, and Layout files, depending on what is specified in the File Settings tab of the Preferences dialog. See Section 1.4.10 for details on setting the program preferences.

If Prompt is selected for any of the items in the Preferences dialog and changes have occurred to those particular items, a dialog similar to the one in Figure 1-7 is displayed.

![Save Changes dialog](image)

Figure 1-7  Save Changes dialog
Working with Data Windows

Chapter 2

This chapter explains how to:

• Create a new data window.
• Use the keyboard to move through the data window.
• Select rows, columns, and a range of cells in the data window.
• Add, insert, and delete rows and columns.
• Change the column width and row height.
• Change the appearance of the data (including font, color, and size).
• Split the data window to compare two sections of the data simultaneously.
• Use the Posted Note feature to make notes about the data.

2.1 Hiding, Displaying, and Closing Data Windows

A maximum of 160 data windows can be open at any one time, subject to memory limitations. You can view a list of all open data windows by choosing Windows > Show Data. Data windows that are currently displayed on the screen have their names in normal text. Names of hidden data windows appear in italic.

2.1.1 Creating a New Data Window

A blank data window can be created by choosing File > New. Any defaults that have been set using the Preferences command are used to create the new window. By default, data windows are created 10 columns by 100 rows in size and named Data 1, Data 2, and so on.

2.1.2 Changing the Active Window

To make a data window active, click anywhere in the desired data window or choose Windows > Show Data and select its name.

2.1.3 Hiding Data Windows

A data window can be hidden by choosing Windows > Hide Window and selecting its name. The next window in the list becomes active.

2.1.4 Displaying Data Windows

A hidden data window can be displayed using the Show Data command (Windows menu). The names of hidden data windows appear in italic. Select the name of the desired data window and it is brought to the front.
2.1.5 Closing Data Windows

You can use the Close All Data command (Windows menu) to close all of the open data windows at once. Individual data windows can be closed by choosing File > Close or clicking the close box of each window. A dialog may be displayed, asking if you want to save the data window before closing.

**Note:** If you do not want to save the data, this dialog can be avoided by pressing Shift while either clicking the close box or choosing File > Close/NoSave.

2.2 Moving Around the Data Window

There are three methods available for moving around in the data window. You can use the mouse, the keyboard, or the Go To Cell command.

2.2.1 Using the Mouse

One of the easiest and most common methods to move around the data window is to use the mouse. With the mouse, you can move to any cell in the data window. To move to a different section of the data window, use the horizontal and vertical scroll bars.

You can also use the Home button in the data window to return the window to its origin (row 0, column 0). This is useful for quickly returning to the start of the data window.

2.2.2 Using the Keyboard

There are a number of keys on the keyboard that let you move from one cell to another. When the edge of the viewing area is reached, the data window scrolls to display the next row or column. The keys and their effects are listed in the following table.

<table>
<thead>
<tr>
<th>Key</th>
<th>Direction</th>
</tr>
</thead>
<tbody>
<tr>
<td>Left/Right Arrow</td>
<td>Move one cell left/right.</td>
</tr>
<tr>
<td>Up/Down Arrow</td>
<td>Move one cell up/down.</td>
</tr>
<tr>
<td>Tab</td>
<td>Move one cell to the right.</td>
</tr>
<tr>
<td>Shift+Tab</td>
<td>Move one cell to the left.</td>
</tr>
<tr>
<td>Return</td>
<td>Move down one cell.</td>
</tr>
<tr>
<td>Shift+Return</td>
<td>Move up one cell.</td>
</tr>
<tr>
<td>Enter</td>
<td>Move one cell in the same direction as the last move.</td>
</tr>
<tr>
<td>Page Up/Down</td>
<td>Move one window view up/down.</td>
</tr>
<tr>
<td>Home</td>
<td>Move to top of column.</td>
</tr>
<tr>
<td>End</td>
<td>Move to bottom of column.</td>
</tr>
</tbody>
</table>

**Note:** If you are editing the contents of a cell, the left and right arrow keys can be used to change the position of the insertion point.
2.2.3 Using the Go To Cell Command

The Go To Cell command (Data menu) can be used to view a specific cell in the data window. Choosing this command displays the dialog in Figure 2-1 to enter the row and column numbers of the desired cell. When you click OK, the data window automatically scrolls to make that cell position visible.

![Go To Cell dialog](image)

**Figure 2-1 Go To Cell dialog**

2.3 Switching Between Overwrite and Insert Mode

KaleidaGraph provides two commands, Overwrite Mode and Insert Mode, that control what happens when you select a cell and begin typing. The active mode is preceded by a check mark in the Data menu.

If Overwrite Mode is active, clicking a cell and typing replaces any existing data.

If Insert Mode is active, clicking a cell and typing appends the information to the current value.

2.4 Making Selections in the Data Window

This section explains how to select rows, columns, a range of cells, and all of the cells in the data window.

2.4.1 Selecting Rows

A single row can be selected by clicking its row number.

To select a range of rows, do one of the following:

- Click the number of the first or last row that you want and drag to complete the selection.
- Click the first row to be included, press Shift, and click the last row. You can use the scroll bars to move to the last row.
2.4.2 Selecting Columns
A single column can be selected by clicking the column title.

To select a range of columns, do one of the following:

- Click the column title of the first or last column and drag to complete the selection.
- Click the first column to be included, press **Shift**, and click the last column. You can use the scroll bars to move to the last column.

2.4.3 Selecting a Range of Cells
To select a range of cells, drag the mouse until all of the cells you want are selected. If some of the cells are not visible, keep dragging and the data window will scroll automatically.

To select a large block of data, click the first cell of the block, press **Shift**, and click the cell in the opposite corner of the block. You can use the scroll bars to move to the second cell.

2.4.4 Selecting the Entire Window
To select all of the cells in the data window, choose **Edit > Select All**.

2.5 Adding and Deleting Rows and Columns

By default, data windows are created with 10 columns and 100 rows. It is very easy to increase the number of rows and columns in the data window.

2.5.1 Adding Rows and Columns

Adding Rows
To add more rows to the data window, choose **Data > Add Rows** or click in the data window. This command displays the dialog in Figure 2-2 to enter the number of rows to be added to the data window. The number entered is rounded up to the next multiple of 100.

![Add Rows dialog](image)

**Figure 2-2 Add Rows dialog**

**Note:** If the active cell is in the last row of the data window, pressing the **Return** or **Down Arrow** key automatically adds 100 rows to the data window.

Adding Columns
To add more columns to the data window, do one of the following:

- Choose **Data > Append Columns** or click in the data window and enter the number of columns to be appended to the data window.
- Press the **Right Arrow** key (if the active cell is in the last column of the data window).
2.5.2 Inserting Rows and Columns

Inserting Rows
Rows can be inserted anywhere in the data window. A row can be inserted in a single column or in a range of columns.

To insert a row:
1. Make a selection in the data window. The row is inserted above the selection.
2. Choose Data > Insert Row or click \ in the data window. A row of blank cells is inserted into the data window.

Inserting Columns
To insert a column into the data window:
1. Select a column in the data window.
2. Choose Data > Insert Column or click \ in the data window. A blank column is inserted before the selected column in the data window.

Columns can also be inserted by pressing Option and clicking a column. A new column is inserted before the selected column.

2.5.3 Deleting Rows and Columns

Deleting Rows
Rows can be deleted from the data window by making a selection and choosing Data > Delete Row. The selection is deleted and the remaining data shifts up to take the place of the deleted data.

Deleting Columns
Columns can be deleted from the data window by making a selection and choosing Data > Delete Column. The selection is deleted and the remaining data shifts over to take the place of the deleted data.
2.6 Formatting Data Columns

2.6.1 Using the Column Formatting Palette

KaleidaGraph provides a Column Formatting palette, shown in Figure 2-3, that can be used to change many of the attributes associated with the data window, such as font, color, font size, column width, and format of the data.

![Column Formatting palette](image)

The Column Formatting palette can be displayed by either choosing Data > Column Formatting or clicking 📋 in the data window. The same methods used to display the Column Formatting palette can also be used to close it.

The palette is divided into three sections, each of which can be expanded or collapsed by clicking on the heading for that particular section. Any changes you make in the first two sections of the dialog (Font and Alignment, Color and Width) are applied immediately to any selected columns. Any changes to the Number Type and Formatting do not take effect until you click Apply.

As you move from one column to another, the palette updates to display the current settings for that column.
2.6.2 Changing the Column Width

KaleidaGraph allows you to control the width of each individual column in the data window. If multiple columns are selected, the new column width is applied to each column in the selection.

By default, you can only use the cells containing the column titles to adjust the column width. However, if the Allow cell resizing by dragging check box is selected in the Preferences dialog, you can use any cell in the data window to resize the columns.

You can use either of the following methods to change the width of the columns:

To change the width of a column by dragging:
1. If you want to change the width of multiple columns, make a selection in the data window.
2. Position the pointer on the line that separates the column titles.
3. When the pointer changes to a double-headed arrow , drag the boundary on the right side of the column until the column is the desired width.

To change the width of a column using the Column Formatting palette:
1. Select one or more columns in the data window.
2. Choose Data > Column Formatting or click in the data window to display the Column Formatting palette.
3. Click the up and down arrows to the right of the Column Width to increase or decrease the width (in pixels) of the selected columns.
4. If you want the column width to be based on the length of the strings in each column, click the Auto button.

2.6.3 Changing the Row Height

KaleidaGraph allows you to control the height of each individual row in the data window. If multiple rows are selected, the new row height is applied to each row in the selection.

By default, you can only use the cells containing the row numbers to adjust the row height. However, if the Allow cell resizing by dragging check box is selected in the Preferences dialog, you can use any cell in the data window to resize the rows.

To change the height of a row:
1. If you want to change the height of multiple rows, make a selection in the data window.
2. Position the pointer on the line that separates the row numbers.
3. When the pointer changes to a double-headed arrow , drag the lower boundary until the row is the desired height.
2.6.4 Changing the Font, Color, Size, and Style

The Column Formatting palette allows you to change the font, color, font size, and style used to display data in each column of the data window. If multiple columns are selected, the current settings are applied to all of the columns in the selection. The data window updates as soon as you make a change to any one of these settings.

To change the font, color, font size, or style of a column:

1. Select one or more columns in the data window.
2. Choose Data > Column Formatting or click in the data window to display the Column Formatting palette.
3. Use the settings in the Font portion of the palette to change the font, size, color, and style used for the data in the selected columns.
4. Use the Justification setting, shown to the right, in the Alignment, Color and Width portion of the palette to control whether the values are left, center, or right justified in the column.

2.6.5 Changing the Background Color

The Column Formatting palette can also be used to change the background color for each column in the data window. If multiple columns are selected, the current background color is applied to all of the columns in the selection.

To change the background color of a column:

1. Select one or more columns in the data window.
2. Choose Data > Column Formatting or click in the data window to display the Column Formatting palette.
3. Click the Color control in the Alignment, Color and Width portion of the palette.
4. Select a new background color and click OK.

2.6.6 Changing the Default Data Window Settings

The Preferences command can be used to select default settings for most of the attributes associated with a data window, including font, color, font size, column width and row height. You can also select the default data type and format for the data values.

To change the defaults for the data window:

1. Choose KaleidaGraph > Preferences to display the Preferences dialog.
2. Click the Column tab.
3. Select your new defaults for the various options and pop-up menus.
4. Click OK. Any changes take effect the next time you display a new data window.
5. To make these settings permanent, make sure you save changes to the Style when quitting KaleidaGraph.

Note: If you want to reset these settings to KaleidaGraph's default settings, click the Defaults button.
2.7 Displaying the Column Numbers

Each column in the data window is assigned a column number. The column numbers range from 0 to 999 and are used to identify columns within Formula Entry functions.

To display the column numbers, click the Expand/Collapse button in the data window. To make this the default, select the Show Column Numbers check box in the Preferences dialog.

Please note that when a selection is made in the data window, the first column in the selection becomes column 0.

2.8 Splitting the Data Window

KaleidaGraph provides two controls in the data window that can be used to split the data window into multiple panes. This allows you to view two sections of the data window simultaneously.

To split the data window into multiple panes:

1. Move the pointer over one of the split boxes in the data window. The split boxes are located above the vertical scroll bar and to the left of the horizontal scroll bar.
2. Drag one of the split boxes towards the center of the scroll bar. The data window will get divided into two panes. Each pane will have its own set of scroll bars.

To remove a split from the data window, either double-click the split box or drag the split box back to its original position.

2.9 Making Notes about the Data

Each data window in KaleidaGraph provides a text editor where you can make notes about the data set. The text editor is displayed by either choosing Data > Posted Note or clicking the Posted Note button in the data window. This information is unique for each data window and is saved as part of the data file.
This chapter explains how to:

- Enter data.
- Generate a data series.
- Open Microsoft Excel and text files.
- Edit the column titles.
- Change the format of the data.
- Cut, copy, paste, and clear data.
- Sort data.
- Exchange rows and columns.
- Execute macros.
- Save and print data.

### 3.1 Entering Data

You can enter numeric, date, time, or text data into the data window. Before you enter data, make sure you know how to move around the data window and how to change the format of a column. Moving around the data window is covered in Section 2.2; changing the data format is covered in Section 3.6.

#### 3.1.1 Entering Numeric Data

The Column Formatting palette provides three data types for displaying numeric data. They are:

- **Float** - Accurate for numbers containing up to seven digits.
- **Double** - Accurate for numbers containing up to 16 digits.
- **Integer** - Displays the numbers as integers.
To enter numeric data:

1. Click a cell in the data window.
2. Choose **Data** > **Column Formatting** or click  in the data window to display the Column Formatting palette.
3. Verify that the correct data type (Float, Double, or Integer) and format are selected for the column.
4. Type the data value. If you make a mistake, press **Delete** to remove incorrect characters.
   
   **Note:** To enter numbers in scientific notation, enter the number, followed by an e and the power (for example, 1.23e–4).
5. Press the **Return** or **Down Arrow** key to move down one row.
6. Repeat steps 4 and 5 until all of the data is entered.

   **Note:** If KaleidaGraph detects any characters that are not associated with the selected data type, a beep sounds when you move to the next cell. Examples of incorrect characters for numeric data include: text, multiple decimal points, and separators for date and time numbers.

### 3.1.2 Entering Date or Time Data

To enter date or time data:

1. Click a cell in the data window.
2. Choose **Data** > **Column Formatting** or click  in the data window to display the Column Formatting palette.
3. Choose either **Date** or **Time** from the **Type** pop-up menu.
4. Choose the desired format from the **Format** pop-up menu and click **Apply**.
5. Type the date or time data. If you make a mistake, press **Delete** to remove incorrect characters.

   **Note:** When entering two digit years less than 40, the **Promote 2 digit dates less than 40** option in the **General** tab of the Preferences dialog determines whether the dates are interpreted as 19xx or 20xx.
6. Press the **Return** or **Down Arrow** key to move down one row.
7. Repeat steps 5 and 6 until all of the data is entered.

If you import date or time data from a file, the format must closely match the actual format shown to enable KaleidaGraph to recognize the column properly. However, if you are typing the data or pasting the data from the Clipboard (to a column that has been set to a date or time format), variations from the exact format are allowed. Valid separators for the date and time formats include: slashes (/), colons (:), commas, and spaces.

When importing dates from another program, the **Default Date Format** setting in the **General** tab of the Preferences dialog determines how the dates are interpreted by KaleidaGraph.
### 3.1.3 Entering Text Data

To enter text data:

1. Click a cell in the data window.
2. Choose **Data > Column Formatting** or click 🔄 in the data window to display the Column Formatting palette.
3. Choose **Text** from the **Type** pop-up menu and click **Apply**.
4. Enter the text data. A maximum of 50 characters can be entered for each text label. If you make a mistake, press **Delete** to remove incorrect characters.
5. Press the **Return** or **Down Arrow** key to move down one row.
6. Repeat steps 4 and 5 until all of the data is entered.

### 3.1.4 Missing Values

There may be times when data values are missing in a series of data. In the data window, KaleidaGraph represents a missing data value with an empty cell, regardless of the data type.

When plotting, if the independent variable (X) contains missing values, KaleidaGraph searches for the first and last cells that contain data and plots all values in between, ignoring any empty cells. If the dependent variable (Y) contains missing values, the empty cells are ignored when plotting.

There is an option in the **General** portion of the Plot Options dialog (**Plot** menu) that controls how missing values are treated in Line, Double Y, Double X, Double XY, High/Low, Step, X-Y Probability, and Polar plots. When **Missing Data Breaks** is selected, a missing data point in an X or Y variable causes a break in the line being plotted. Otherwise, the line is continuous and the missing data points are ignored.

### 3.2 Generating a Data Series

There are several methods that can be used to generate a series of data. Some of the default macros that come with KaleidaGraph can be used to create a data series. The Formula Entry window contains commands which can also be used to place a series into a column. The only problem is these methods do not give you very much control over the type of series that is generated.

The one method that does give you complete control is the **Create Series** command from the **Functions** menu. This command allows you to specify an initial value, an increment, a multiplier, and a final value for the series.

You can create a numeric series in any column that contains a Float, Double, or Integer data format. A date or time series can be created in any column that contains a Date or Time format.

**Note:** It is not possible to generate a series in a Text column.
To create a series:

1. Select a column or a range of columns in the data window.
2. Choose **Functions > Create Series**. A dialog similar to one of the following appears, based on the format of the column.

3. Enter values into the appropriate fields of the dialog and click **OK** to generate the series.

### 3.3 Importing Microsoft Excel Files

KaleidaGraph can directly import files created in Microsoft Excel. KaleidaGraph will examine the first two rows of data to determine whether or not to use the first row as column titles. If the Excel file contains extraneous information or if the file does not import as desired, you can either copy the data and paste it into KaleidaGraph or export the data in a text format and import the text file into KaleidaGraph.

To import a Microsoft Excel file:

1. Choose **File > Open**.
2. Change the drive and directory as needed, select the file to be opened, and either click **Open** or double-click the file name.

### 3.4 Importing Text Files

KaleidaGraph can open text files that are formatted in a number of different ways. This allows you to read data created in another program and use that data in KaleidaGraph. The only requirements are that the data must be saved as a text file and the information must be arranged in a repeating pattern.


### 3.4.1 Text File Input Format Dialog

Whenever you select a text file to be read into KaleidaGraph, the dialog in Figure 3-3 is displayed. This dialog allows you to:

- Preview the file.
- Select the delimiter.
- Indicate the number of delimiters between columns.
- Specify the number of lines to skip at the beginning of a file.
- Select whether or not to read titles into the data window.

**Note:** This dialog is not displayed when opening text files saved from KaleidaGraph. To display the dialog, press **Option** when opening these text files.

![Text File Input Format dialog](image)

**Figure 3-3** Text File Input Format dialog

For more information on the settings in the Text File Input Format dialog, refer to the online Help.

### 3.4.2 Importing Missing Data Points

Missing data points can be entered from text files. If \( =1 \) is selected for the **Number** setting in the Text File Input Format dialog, whenever KaleidaGraph detects two consecutive delimiters, an empty cell is placed in the data window.

A period can also be used to represent an empty data cell. There is a mainframe program called SAS that uses the period as a default character for empty data cells.

### 3.4.3 Example - Reading Basic Formats

This section shows how to import a simple tab-delimited text file. One of the text files that comes with KaleidaGraph is used as an example.

To import this example data set:

1. Choose **File > Open**.
2. Locate and open the **Data** folder, which is located in the **Examples** folder.
3. Double-click the file **Text Example**. When KaleidaGraph determines that the file is a text file, the dialog in Figure 3-4 appears.
Looking at the preview window of this dialog, you can see that:

- This particular file is tab-separated.
- A single tab is present between the values.
- None of the lines need to be skipped.
- The first line of the file should be used for the column titles.

4. Make the settings shown in the previous dialog and click OK. The text file is opened into a new data window. Figure 3-5 shows the data window that results from importing the example data set.

Figure 3-5 Resulting data window
3.4.4 Using the Special Format

If the delimiter is set to **Special**, the dialog expands, as shown in Figure 3-6. The Special format requires that you define the format of the text file by specifying which fields to read and which fields to skip.

![Text File Input Format dialog](image)

**Figure 3-6 Expanded Text File Input Format dialog**

3.4.5 Example - Reading Special Formats

This section shows an example of importing a text file that contains unwanted data values. One of the text files that comes with KaleidaGraph is used as an example.

To import this example data set:

1. Choose **File > Open**.
2. Locate and open the **Data** folder, which is located in the **Examples** folder.
3. Double-click the **Measurements** file. When KaleidaGraph determines that the file is a text file, the Text File Input Format dialog appears.
4. Click **Special**. The dialog expands so you can enter the title and data formats. The dialog should look like Figure 3-7 at this point.
Looking at the preview window of this dialog, you can see that:

- The file begins with an unusable line which must be skipped.
- There is a title line containing three labels.
- The data is spread across six columns. Three of the columns contain labels and should be skipped. The other three contain values which should be read as one fixed width field (Time values) and two variable width fields (Temperature and Volume values).

5. Using the above information, you can now specify the format of the titles and the data. Figure 3-8 shows how the dialog should appear after making the following selections.

- **Lines Skipped** should be 1 to skip the first line.
- **Read Titles** should be selected to read in the column titles.
- The **Title Format** should be either \( a\ a\ a \) or \( 3(a) \). Either one of these formats reads in three labels, separated by white space.
- The **Data Format** should be either \( A\ f3\ A\ v\ A\ v \) or \( A\ f3\ 2(A\ v) \). Using either one of these formats, the three columns of labels are skipped and only the three columns of data are read into the data window.
6. Click **OK** to import the text file. The resulting data window is shown in Figure 3-9.

![Figure 3-8 Finished Text File Input Format dialog](image1)

**Figure 3-8** Finished Text File Input Format dialog

![Figure 3-9 Resulting data window](image2)

**Figure 3-9** Resulting data window
3.4.6 Special Format Examples

The following table contains some sample data format strings that may be used for the Special format.

<table>
<thead>
<tr>
<th>Data Format</th>
<th>Effect</th>
</tr>
</thead>
<tbody>
<tr>
<td>w v v v v</td>
<td>Skips any white space at the beginning of each row before reading three variable width numbers.</td>
</tr>
<tr>
<td>v v v c</td>
<td>Reads the first three columns of variable width numbers and skips everything else.</td>
</tr>
<tr>
<td>v V v c</td>
<td>Reads the first and third columns of variable width numbers and skips everything else.</td>
</tr>
<tr>
<td>4(v) c 4(v)</td>
<td>Takes a data set with four columns and places it into eight columns in the data window.</td>
</tr>
<tr>
<td>v v v \</td>
<td>Takes a data set with any number of columns containing variable width numbers and places it into three columns in the data window.</td>
</tr>
<tr>
<td>3 (y f6 b b)</td>
<td>Repeats the pattern in the parentheses three times. After executing this format, the data window would contain 12 columns.</td>
</tr>
<tr>
<td>u, 8(v)</td>
<td>Reads eight comma-separated columns containing variable width numbers.</td>
</tr>
</tbody>
</table>

3.5 Editing Column Titles

The column titles are used to identify each of the data columns in the data window. These titles are used when selecting data columns for plotting or curve fitting. They are also used to label the plot legend and axes.

If the title is too long to fit inside the cell, KaleidaGraph will show ... in the middle of the title. You can mouse-over the column title to display the full name in a tool tip.

To change the title of a column:
1. Double-click the title of the column. The name of the current column will be selected.
2. Type a new column title.
3. Press Tab to edit the next column title or Return to move to the first row in the current column.

Superscripts, subscripts, and an alternate font can be used in the column titles by preceding the characters to be altered with \u (up), \d (down), and \f (alternate font), respectively. To return to the default attributes, use \n (normal).

Multi-line titles can be created by placing \r where the line break should occur. Any characters following \r will be placed on a separate line.

Note: The column titles in the data window do not display the superscripts, subscripts, alternate fonts, or line breaks. The \n, \f, \u, \d, and \r characters are mixed in with the normal text. However, when you create a plot, these characters are converted to obtain the desired results.
3.6 Changing the Number Type and Formatting

Each column in the data window can contain numeric, date, time, or text data. KaleidaGraph supports six different data types: Float, Double, Integer, Date, Time, and Text. Most of these data types also have several formats available for displaying the data.

**Note:** Caution should be used when changing data types. Significant digits may be lost when applying a data type with less precision.

To change the format of the data in a column:

1. Select one or more columns in the data window.
2. Choose **Data > Column Formatting** or click ![Column Formatting](image) in the data window to display the Column Formatting palette.
3. Use the settings in the **Number Type and Formatting** portion of the palette to change the data type, format, and the number of significant digits. You can also select whether or not to display the thousands separator and any trailing zeros.
4. Click **Apply** to update the selected columns.

3.7 Cutting, Copying, Pasting, and Clearing Data

There are several commands in the **Edit** menu that can be used to edit the contents of the data window. Using these commands, you can cut, copy, paste, and clear data selections.

3.7.1 Binary Mode/Text Mode Setting

This command controls whether the **Cut** and **Copy** commands use binary or text format to copy large amounts of data to the Clipboard. When copying 10,000 cells or less, a binary and text representation of the data are copied to the Clipboard. This occurs regardless of which mode is currently active.

Binary editing is much faster than text editing and allows you to quickly move large amounts of data. Use Text mode if you need to copy more than 10,000 cells and paste them into the plot window or another program.

To view the active mode, click the **Edit** menu. The active mode is displayed in the menu and has a check mark in front of it. To switch between modes, choose the active mode.

3.7.2 Cutting Data

Choose **Edit > Cut** to remove the data selection from the window and place it on the Clipboard, replacing the previous contents, if any.

3.7.3 Copying Data

Choose **Edit > Copy** to place a copy of the data selection on the Clipboard, replacing the previous contents, if any.
3.7.4 Pasting Data
Choose Edit > Paste to place the Clipboard’s contents into the data window. You can also paste data into the plot window, layout window, or another program.

3.7.5 Clearing Data
Choose Edit > Clear to delete all of the cells in the selection without disturbing the contents of the Clipboard. To clear a cell’s contents without deleting the cell, use the Clear Data command or the Delete key.

3.7.6 Including Column Titles when Editing Data
To include the column titles when editing, press Shift while choosing the Cut, Copy, Paste, or Clear command from the Edit menu.

3.8 Sorting Data
KaleidaGraph can perform ascending and descending sorts on a column, a range of columns, or any data selection. Sorts can be applied to selections that contain any data format.

The sort commands are located in the Functions menu. The Ascending Sort command sorts the data from low value to high value. The Descending Sort command sorts from high value to low value. Both of these commands use the same dialog, shown in Figure 3-10. This dialog allows you to select which columns to reorder during the sort. Any columns you select before entering this dialog are preselected for you.

![Sort dialog](image)

Figure 3-10  Sort dialog
To sort a range of data:

1. Select the data to be sorted. The selection can contain a few cells, columns, or the entire data window.
2. Choose Ascending Sort or Descending Sort from the Functions menu or click $\text{Asc}$ or $\text{Desc}$ in the data window. The Sort dialog appears, with the names of any selected columns already highlighted. The first column in the selection is automatically assigned as the 1st Key.
3. To perform a multi-level sort, click the name of the column to be used as the second sort key and click the 2nd Key button. Repeat this step for the 3rd Key, if necessary.
4. Select all of the columns to be sorted.
   - To select individual columns, press Shift or $\text{Ctrl}$ and click the column name.
   - To select a range of columns, drag with the mouse.
   - To select every column in the data window, click All.
   - To deselect a column, press $\text{Shift}$ and click the column name.
5. Click OK to perform the sort.

### 3.9 Transposing Data

You can exchange rows and columns in the data window. When you use the Transpose command, the columns are converted to rows and the rows to columns. For example, if a selection contains four columns and 128 rows, it contains 128 columns and four rows after transposing the data.

To switch rows and columns:

1. Make a selection in the data window.
2. Choose Functions > Transpose. The selected data is transposed and displayed in the data window.

Figure 3-11 shows a sample data window. Figure 3-12 shows the same data window after selecting all of the columns and using the Transpose command. Notice that the data originally in column 0 is now in row 0 after being transposed.
### Figure 3-11 Before choosing Transpose

<table>
<thead>
<tr>
<th></th>
<th>A</th>
<th>B</th>
<th>C</th>
<th>D</th>
<th>E</th>
</tr>
</thead>
<tbody>
<tr>
<td>0</td>
<td>1.000</td>
<td>1.100</td>
<td>1.2900</td>
<td>10.120</td>
<td></td>
</tr>
<tr>
<td>1</td>
<td>2.000</td>
<td>2.250</td>
<td>3.1000</td>
<td>11.340</td>
<td></td>
</tr>
<tr>
<td>2</td>
<td>3.000</td>
<td>3.390</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>3</td>
<td>4.000</td>
<td>4.450</td>
<td>6.2400</td>
<td></td>
<td></td>
</tr>
<tr>
<td>4</td>
<td>5.000</td>
<td>5.580</td>
<td>8.2400</td>
<td>15.660</td>
<td></td>
</tr>
</tbody>
</table>

### Figure 3-12 After choosing Transpose

<table>
<thead>
<tr>
<th></th>
<th>A</th>
<th>B</th>
<th>C</th>
<th>D</th>
<th>E</th>
</tr>
</thead>
<tbody>
<tr>
<td>0</td>
<td>1.000</td>
<td>1.100</td>
<td></td>
<td>4.0000</td>
<td>5.0000</td>
</tr>
<tr>
<td>1</td>
<td>1.100</td>
<td>2.250</td>
<td>3.3900</td>
<td>4.4500</td>
<td>5.5800</td>
</tr>
<tr>
<td>2</td>
<td>1.290</td>
<td>3.100</td>
<td></td>
<td>6.2400</td>
<td>8.2400</td>
</tr>
<tr>
<td>3</td>
<td>10.12</td>
<td>11.340</td>
<td>13.450</td>
<td></td>
<td>15.660</td>
</tr>
</tbody>
</table>

**Note:** An error message is displayed if either of the following occurs:

- You attempt to transpose a selection containing text data.
- Your selection contains more than 1000 rows, because the data window is limited to a maximum of 1000 columns.
3.10 Masking Data

Masking data provides a way to leave data in the data window but not have it used in any calculations, curve fits, or plots. Any cells that are masked have a red frame in the data window. Figure 3-13 shows a data window containing masked data cells.

![Data window containing masked data](image)

Figure 3-13  Data window containing masked data

Data can be masked using any of the following: the **Mask** command (**Functions** menu), the Data Selection tool from the toolbox, macros, and Formula Entry. Using Formula Entry to mask data is covered in Section 5.3. The other methods are discussed below.

The **Unmask** command (**Functions** menu) can be used to unmask selected data cells. The **Invert Mask** command (**Functions** menu) can be used to mask unmasked cells and unmasked masked cells.

The ** Mask**, ** Unmask**, and **Invert Mask** buttons in the data window can be used to perform the mask, unmask, and invert mask functions, respectively.

**Mask Command**

To mask data with the **Mask** command:

1. Select the cells to be masked.
2. Choose **Functions > Mask**. A red frame is drawn around each of the masked cells.


Data Selection Tool
You can use the Data Selection tool to select a portion of the plotted data for further plotting and analysis. The data that is removed from the plot becomes masked in the data window. The use of this tool is discussed in Section 8.4.

Note: Double-clicking this tool unmask the data and returns the plot to its original state.

Macros
KaleidaGraph contains three default macros in the Macros menu that mask data upon execution. These macros are Filter, Simplify, and Invert Mask. Refer to the online Help for information on these macros.

3.11 Executing Macros

Macros can be used to perform a wide variety of data operations, including those required for data analysis. KaleidaGraph contains several default macros in the Macros menu. Some of these macros are used to create data series and others are used to manipulate and analyze data. For more information about a particular macro or the Macro Calculator, refer to the online Help. There is also a PDF file in the Manuals folder that explains how to write macros and provides some example macros.

To execute a macro:

1. Open the data window to be operated on by the macro. A sample data set is shown in Figure 3-14.

   Figure 3-14 Sample data window

2. Choose a macro from the Macros menu. The Integrate - Area macro is used for this example. Choosing a macro from the menu automatically causes it to be executed. Some macros may prompt for specific information during execution. The following dialogs are displayed during execution of the Integrate - Area macro.
3. Type the appropriate values into any dialogs that appear. Click OK to continue execution or click Cancel to stop the macro. Figure 3-17 shows the results of executing this macro.

3.12 Exporting Data

KaleidaGraph provides two methods for exporting data files. You can save the data file to disk (in either binary or text format) or you can print the data file.

3.12.1 Saving Data

To save the data to disk, choose Save Data or Save Data As from the File menu when the data window is active. If the Save Data command is used on a window that has not been saved before, a Save dialog appears, allowing you to specify the location and file name.

To export the data in a text format:

1. Choose File > Save Data As.
2. Select Tab Delimited Text from the Format pop-up menu.
3. Specify the location and file name for the text file and click Save.

3.12.2 Printing Data

To print the data set, choose File > Print Data. To print a subset of the data, make a selection in the data window before printing or edit the page range in the Print dialog.

The options available in the Print dialog depend on the printer and operating system.
This chapter explains how to:

- View column statistics.
- Place data into bins and export the results to create a Histogram, Step, or Spike plot.
- Perform tests to analyze single data samples.
- Perform tests to analyze two or more groups.
- Perform tests to analyze repeated measurements.
- Use a post hoc test after running a one way or one way repeated measures ANOVA.

### 4.1 Viewing Column Statistics

KaleidaGraph provides 12 different statistics to help analyze data. These statistics are automatically calculated for each column in the data window. If you need to calculate statistics across multiple columns of data, see Section 5.2 for details on using Formula Entry to do this. The equations used to calculate the statistics are listed in Section C.2.

To view statistics on a data set:

1. Select the data for which you want the statistics calculated. If you do not make a selection, the statistics are calculated for each column in the data window.
2. Choose **Functions > Statistics** or click in the data window. The Statistics dialog, shown in Figure 4-1, is displayed. This dialog has a split-screen display so that any two columns can be compared.
3. Click **Copy to Clipboard** if you want to paste this information into a data, plot, or layout window. You can also select the **Transposed** check box so that when the data is copied, each statistic becomes a column and the different variables become rows.
4. When you are finished, click **OK**.
4.2 Binning Data

Binning data involves counting the number of data points that fall within a certain range. The binned data distribution can be exported in any one of three formats for plotting or for annotating a plot.

4.2.1 Binning the Data

To bin the data:

1. Select the columns containing the variables to be binned.
2. Choose Functions > Bin Data. A dialog similar to Figure 4-2 appears.
3. Bin the variables by specifying the minimum and maximum values, number of bins, Y units, and where to show the counts. If you make any changes to the minimum, maximum, or number of bins, click **Recalculate** to update the count.

4. Select the appropriate **Export Format** for the type of plot to be created.

5. Click **Copy to Clipboard**.

6. Click **OK**.
4.2.2 Pasting the Results from the Bin Data Dialog

Once the data is binned, it can be pasted into a new data window.

1. Choose File > New to create a blank data window.
2. Choose Edit > Paste. The results obtained from binning the data are placed into the data window. Figure 4-3 shows binning results which were exported with a Histogram format.

![Figure 4-3 Results of binning the data](image)

4.2.3 Creating the Plot

1. Choose the proper plot type from the Gallery menu.
   - **Histogram** - For a single variable, choose Gallery > Bar > Column. For multiple variables, choose Gallery > Bar > Stack Column.
   - **Step Plot** - Choose Gallery > Linear > Line.
   - **Spike Plot** - Choose Gallery > Linear > High/Low.
2. Select the variables to be plotted.
   - **Histogram** - Select Histogram X for the X variable and one or more binned columns for the Y variables.
   - **Step Plot** - Select Step X for the X variable and one or more binned columns for the Y variables.
   - **Spike Plot** - Select Spike X for the X variable, plus a binned column and Zero for the Y variables.
3. Click **New Plot**. The following three figures show the different plot types that can be created. All three were generated from the same original data set, using the same settings in the Bin Data dialog. The only difference was the Export Format.

**Figure 4-4** Histogram  **Figure 4-5** Step plot  **Figure 4-6** Spike plot

### 4.3 Choosing a Statistical Test

KaleidaGraph can be used to perform a variety of statistical tests. The type of test to use depends on the number of samples and the nature of the data.

- Use a **single sample test** to analyze one sample to a known or hypothesized value.
- Use a **group comparison test** to analyze two or more different samples for statistically significant differences.
- Use a **repeated measures test** to analyze the differences in two or more matched samples (such as the same individuals before and after one or more treatments).

The table below shows the proper test to use for each experiment and the type of data collected.

<table>
<thead>
<tr>
<th>Type of Experiment</th>
<th>Type of Data</th>
</tr>
</thead>
<tbody>
<tr>
<td>Compare one sample to a hypothetical value</td>
<td>Numeric (normally distributed with equal variances)</td>
</tr>
<tr>
<td>Compare two paired samples</td>
<td>One sample t-test</td>
</tr>
<tr>
<td>Compare two unpaired samples</td>
<td>Paired t-test</td>
</tr>
<tr>
<td>Compare three or more matched samples</td>
<td>Unpaired t-test</td>
</tr>
<tr>
<td>Compare three or more unmatched samples</td>
<td>One way or Two way repeated measures ANOVA</td>
</tr>
<tr>
<td>Compare three or more unmatched samples</td>
<td>One way or Two way ANOVA</td>
</tr>
</tbody>
</table>
4.4 Parametric and Nonparametric Tests

The statistical tests in KaleidaGraph can be divided into two categories: parametric and nonparametric. Parametric tests assume the samples are drawn from a population that is normally distributed with equal variances. Examples of parametric tests include the t-test and analysis of variance (ANOVA). In general, you should use a parametric test if you are confident that the samples are drawn from a normally distributed population.

Nonparametric tests (or distribution-free tests) do not make any assumptions about the distribution of the data. These tests rank the data from low to high and analyze the rank. Examples of nonparametric tests include the Wilcoxon, Kruskal-Wallis, and Friedman tests. In general, you should use a nonparametric test if the data represents a rank or score, or if the measurements are drawn from a population that is not normally distributed.

4.5 Analyzing One Sample

KaleidaGraph provides two tests that can be used to determine whether the mean or median of a single sample differs significantly from a hypothetical value. The two tests are listed below:

- Use a single sample t-test if the sample was taken from a normally distributed population. This is a parametric test that compares the mean of a single sample to a known or hypothesized value.
- Use a Wilcoxon signed rank test if the sample was taken from a non-normally distributed population or if the data consists of ranks or scores. This is a nonparametric test that compares the median of a single sample to a known or hypothesized value.

4.5.1 Entering Data for One Sample Tests

The single sample t-test and the Wilcoxon signed rank test both require that the observations for the sample be entered into a single data column. If the data includes a grouping variable, it can be included. However, the grouping variable will not be used in either of these analyses.

4.5.2 Performing a Single Sample t-Test

Use this test when you want to compare the mean of a sample to a known or hypothesized value.

As part of the results, KaleidaGraph calculates a t probability (P) value. This value determines if there is a statistically significant difference between the mean of the sample and the hypothetical mean. If this value is below a certain level (usually 0.05), the conclusion is that there is a difference between the two. For more information on the results of a single sample t-test, refer to the online Help.
To perform a single sample t-test:

1. Choose **Functions > Student t** to display a dialog similar to Figure 4-7.

![Figure 4-7 Student t-Test dialog]

2. Click the **single group** button.

3. Select the column to be tested by either clicking the column name and pressing **Group 1** or double-clicking the column name.

4. Enter the known or hypothesized value in the **Test Value** field.

5. Click **Calculate**. The results of the test are displayed on the right side of the dialog.

6. To export the results, click **Copy Results to Clipboard**. You can then paste the results into a data, plot, or layout window.

7. To print the results, click the **Print Results** button.

8. Click **OK** to return to the data window.
4.5.3 Performing a Wilcoxon Signed Rank Test

Use this test to compare the median of a single sample to a known or hypothesized value.

This is a nonparametric test that does not require that the samples be drawn from a normally distributed population. If you know that the sample is normally distributed, use a single sample t-test instead.

As part of the results, KaleidaGraph calculates a P value. This value determines if there is a statistically significant difference between the median of the sample and the hypothetical median. If this value is below a certain level (usually 0.05), the conclusion is that there is a difference between the two. For more information on the results of a Wilcoxon signed rank test, refer to the online Help.

To perform a Wilcoxon signed rank test:

1. Choose **Functions > Wilcoxon** to display a dialog similar to Figure 4-8.

   ![Wilcoxon Test dialog](image)
   
   **Figure 4-8  Wilcoxon Test dialog**

2. Click the **single group** button.
3. Select the column to be tested by either clicking the column name and pressing **Group 1** or double-clicking the column name.
4. Enter the known or hypothesized value in the **Test Value** field.
5. Click **Calculate**. The results of the test are displayed on the right side of the dialog.
6. To export the results, click **Copy Results to Clipboard**. You can then paste the results into a data, plot, or layout window.
7. To print the results, click the **Print Results** button.
8. Click **OK** to return to the data window.
4.6 Analyzing Two or More Groups

KaleidaGraph provides five tests that can be used to analyze two or more different samples for a significant difference in the mean or median values. The proper test to use depends on the number of samples and the distribution of the data.

Comparing Two Groups
If data was collected from two different groups of subjects (for example, male and female manatees), use one of the following group comparison tests:

- Use the **unpaired t-test** if the samples were taken from normally distributed populations with equal variances. This is a parametric test that compares the sample data directly.

- Use the **Wilcoxon-Mann-Whitney test** if the samples were taken from non-normally distributed populations or if the data consists of ranks or scores. This is a nonparametric test that ranks the data, and analyzes the ranks instead of the raw data.

Comparing Three or More Groups
If the samples were taken from normally distributed populations with equal variances, use one of the following group comparison tests:

- Use a **one way ANOVA** to compare the effect of a single factor on the mean of three or more groups (for example, the effect of three drugs on a group of test animals).

- Use a **two way ANOVA** to compare the effect of two different factors on the mean of three or more groups (for example, the effect of three drugs given at different times during the day to a group of test animals).

If the samples were taken from non-normally distributed populations or if the data consists of ranks or scores, use the **Kruskal-Wallis test**.

**Note:** If you find a statistically significant difference using the one way ANOVA, you can use one of the post hoc tests to determine which groups are different.

4.6.1 Entering Data for Group Comparison Tests
The group comparison tests in KaleidaGraph require that the data be entered in one of two ways:

- as raw data, where the data for each group is entered into a separate column.

- as indexed data, where one of the columns is a factor column or grouping variable, with the corresponding data points in one or more columns.

You can use raw data for all of the tests except the two way ANOVA. The two way ANOVA requires one or two factor columns and one or more data columns.

**Note:** The groups do not have to be the same size, unless you are using the two way ANOVA.

The following examples show how raw and indexed data should be entered for the various group comparison tests.
### Raw Data Examples - Group Comparisons

#### Unpaired t-test and Wilcoxon-Mann-Whitney test

#### One way ANOVA and Kruskal-Wallis test
### Indexed Data Examples - Group Comparisons

#### Unpaired t-test and Wilcoxon-Mann-Whitney test

<table>
<thead>
<tr>
<th>Sex</th>
<th>Height</th>
</tr>
</thead>
<tbody>
<tr>
<td>male</td>
<td>75.50</td>
</tr>
<tr>
<td>female</td>
<td>68.75</td>
</tr>
<tr>
<td>male</td>
<td>74.00</td>
</tr>
<tr>
<td>female</td>
<td>68.25</td>
</tr>
<tr>
<td>male</td>
<td>72.75</td>
</tr>
<tr>
<td>female</td>
<td>66.50</td>
</tr>
<tr>
<td>male</td>
<td>72.25</td>
</tr>
<tr>
<td>female</td>
<td>64.00</td>
</tr>
<tr>
<td>male</td>
<td>70.00</td>
</tr>
<tr>
<td>female</td>
<td>64.50</td>
</tr>
<tr>
<td>male</td>
<td>70.50</td>
</tr>
<tr>
<td>female</td>
<td>68.75</td>
</tr>
</tbody>
</table>

#### One way ANOVA and Kruskal-Wallis test

<table>
<thead>
<tr>
<th>Ponds</th>
<th>PH</th>
</tr>
</thead>
<tbody>
<tr>
<td>Pond A</td>
<td>7.53</td>
</tr>
<tr>
<td>Pond B</td>
<td>7.61</td>
</tr>
<tr>
<td>Pond C</td>
<td>7.54</td>
</tr>
<tr>
<td>Pond D</td>
<td>7.71</td>
</tr>
<tr>
<td>Pond A</td>
<td>7.54</td>
</tr>
<tr>
<td>Pond B</td>
<td>7.63</td>
</tr>
<tr>
<td>Pond C</td>
<td>7.55</td>
</tr>
<tr>
<td>Pond D</td>
<td>7.71</td>
</tr>
<tr>
<td>Pond A</td>
<td>7.71</td>
</tr>
<tr>
<td>Pond B</td>
<td>7.73</td>
</tr>
<tr>
<td>Pond C</td>
<td>7.74</td>
</tr>
<tr>
<td>Pond D</td>
<td>7.74</td>
</tr>
</tbody>
</table>

#### Two way ANOVA

<table>
<thead>
<tr>
<th>Promotion</th>
<th>1st Qtr</th>
<th>2nd Qtr</th>
<th>3rd Qtr</th>
<th>4th Qtr</th>
</tr>
</thead>
<tbody>
<tr>
<td>0</td>
<td>958</td>
<td>1047</td>
<td>933</td>
<td>947</td>
</tr>
<tr>
<td>1</td>
<td>1005</td>
<td>1122</td>
<td>986</td>
<td>1022</td>
</tr>
<tr>
<td>2</td>
<td>351</td>
<td>436</td>
<td>339</td>
<td>356</td>
</tr>
<tr>
<td>3</td>
<td>549</td>
<td>632</td>
<td>512</td>
<td>545</td>
</tr>
<tr>
<td>4</td>
<td>730</td>
<td>784</td>
<td>707</td>
<td>722</td>
</tr>
<tr>
<td>5</td>
<td>780</td>
<td>897</td>
<td>718</td>
<td>803</td>
</tr>
<tr>
<td>6</td>
<td>229</td>
<td>275</td>
<td>202</td>
<td>256</td>
</tr>
<tr>
<td>7</td>
<td>883</td>
<td>964</td>
<td>817</td>
<td>845</td>
</tr>
<tr>
<td>8</td>
<td>624</td>
<td>695</td>
<td>599</td>
<td>650</td>
</tr>
<tr>
<td>9</td>
<td>375</td>
<td>436</td>
<td>351</td>
<td>388</td>
</tr>
</tbody>
</table>

*Two way ANOVA (one factor column and four columns containing the data values)*

---

4.6 Analyzing Two or More Groups 63
4.6.2 Performing an Unpaired t-Test

Use this test to compare the means of two independent samples. This test can be performed on columns of different length, since no relationship is assumed between the samples. As a special case, if Group 1 is assigned a Text column, it is used as a grouping variable (for example, gender) to separate the data in the second column into two groups.

As part of the results, KaleidaGraph calculates a t probability (P) value. This value determines if there is a statistically significant difference between the two means. If this value is below a certain level (usually 0.05), the conclusion is that there is a difference between the two group means. For more information on the results of an unpaired t-test, refer to the online Help.

To perform an unpaired t-test:

1. Choose **Functions > Student t** to display the Student t-Test dialog.
2. Click the **unpaired data with equal variance** or **unpaired data with unequal variance** button.
3. Select the columns to be tested by either clicking the column name and pressing a Group button or double-clicking the column names. If you are using a Text column as a grouping variable, it must be assigned to Group 1.
4. Click the **F Test** check box if you want KaleidaGraph to calculate the F and F probability values. The F probability determines if the two groups have different variances. A small F probability value (usually less than 0.05) indicates that the two groups have significantly different variances.
5. Click **Calculate**. The results of the test are displayed on the right side of the dialog.
6. To export the results, click **Copy Results to Clipboard**. You can then paste the results into a data, plot, or layout window.

7. To print the results, click the **Print Results** button.

8. Click **OK** to return to the data window.

### 4.6.3 Performing a Wilcoxon-Mann-Whitney Test

Use this test to see if two different samples have been drawn from the same population. This test can be performed on columns of different length, since no relationship is assumed between the samples. As a special case, if Group 1 is assigned a Text column, it is used as a grouping variable (for example, gender) to separate the data in the second column into two groups.

This test assumes the samples are not normally distributed with the same variances. If you know that the samples are normally distributed, use an unpaired t-test instead. If there are more than two samples to compare, use the Kruskal-Wallis test.

As part of the results, KaleidaGraph calculates a P value. This value determines if there is a statistically significant difference between the medians of the two groups. If this value is below a certain level (usually 0.05), the conclusion is that there is a difference between the two. For more information on the results of a Wilcoxon-Mann-Whitney test, refer to the online Help.

To perform a Wilcoxon-Mann-Whitney test:

1. Choose **Functions** > **Wilcoxon** to display the Wilcoxon Test dialog.
2. Click the **unpaired data** button.
3. Select the columns to be tested by either clicking the column name and pressing a Group button or double-clicking the column names. If you are using a Text column as a grouping variable, it must be assigned to Group 1.
4. Click **Calculate**. The results of the test are displayed on the right side of the dialog.
5. To export the results, click **Copy Results to Clipboard**. You can then paste the results into a data, plot, or layout window.
6. To print the results, click the **Print Results** button.
7. Click **OK** to return to the data window.

### 4.6.4 Performing a One Way ANOVA

Use this test when you want to see if the means of three or more different groups are affected by a single factor. This test is the same as the unpaired t-test, except that more than two groups can be compared.

This is a parametric test that assumes the samples are drawn from normally distributed populations with equal variances. If you know that the samples are not normally distributed, use the Kruskal-Wallis test. If there are only two samples to compare, use an unpaired t-test.

As part of the results, KaleidaGraph calculates F and P values. For more information on the results of a one way ANOVA, refer to the online Help.

- **F value** - This value is the ratio of the groups’ mean square over the error mean square. If this value is close to 1.0, you can conclude that there are no significant differences between the groups. If this value is large, you can conclude that one or more of the samples was drawn from a different population. To determine which groups are different, use one of the post hoc tests.

- **P value** - This value determines if there is a statistically significant difference between the groups. If this value is below a certain level (usually 0.05), the conclusion is that there is a difference between the groups.
To perform a one way ANOVA:

1. Choose **Functions > ANOVA** to display a dialog similar to Figure 4-9.

![ANOVA dialog](image)

**Figure 4-9** ANOVA dialog

2. Assign the data columns containing the measured values to the Dependent(s) list.

3. If you are using indexed data, assign the factor column to the Factor(s) list. In this case, only one dependent column should be used. If you assign multiple columns to the Dependent(s) list, a two way ANOVA will be performed.

4. Click **Calculate**. The results of the test are displayed in the bottom half of the dialog.

5. If you find a statistically significant difference, you can use one of the post hoc tests to determine which groups are different and the size of the difference. For more information on the post hoc tests, refer to Section 4.8.

6. To export the results, click **Copy Results to Clipboard**. You can then paste the results into a data, plot, or layout window.

7. To print the results, click the **Print Results** button.

8. Click **OK** to return to the data window.
### 4.6.5 Performing a Two Way ANOVA

Use this test when you want to see if the means of three or more different groups are affected by two factors. A two way ANOVA tests three hypotheses:

- There is no difference among the levels of the first factor.
- There is no difference among the levels of the second factor.
- There is no interaction between the factors.

This is a parametric test that assumes the samples are drawn from normally distributed populations with equal variances. If you want to see the effect of only one factor on your data, use a one way ANOVA. KaleidaGraph does not have a nonparametric equivalent to the two way ANOVA.

As part of the results, KaleidaGraph calculates F and P values. For more information on the results of a two way ANOVA, refer to the online Help.

- **F value** - The F value is calculated for each of the factors and the interaction. For each factor, this value is the ratio of the mean square of the factor over the error mean square. For the interaction, it is the ratio of the interaction mean square over the error mean square.
  
  If the F value is close to 1.0, you can conclude that there are no significant differences between the factor levels or that there is no interaction between the factors. If this value is large, you can conclude that one or more of the samples for that factor or combination of factors was drawn from a different population.

- **P value** - This value determines if there is a statistically significant difference between the groups. If this value is below a certain level (usually 0.05), the conclusion is that there is a difference between the groups.

**Note:** The two way ANOVA ignores any rows that contain masked or empty cells. Each of the factors must have an equal number of observations.

To perform a two way ANOVA:

1. Choose **Functions > ANOVA** to display the ANOVA dialog.
2. Assign the data columns containing the measured values to the Dependent(s) list.
3. Assign one or two factor columns to the Factor(s) list. If two factor columns are assigned, only one dependent column may be used.
4. Click **Calculate**. The results of the test are displayed in the bottom half of the dialog.
5. To export the results, click **Copy Results to Clipboard**. You can then paste the results into a data, plot, or layout window.
6. To print the results, click the **Print Results** button.
7. Click **OK** to return to the data window.

### 4.6.6 Performing a Kruskal-Wallis Test

Use this test when you want to see if three or more groups are affected by a single factor.

This is a nonparametric test that does not require that the samples be drawn from a normally distributed population. If you know that the samples are normally distributed, use the one way ANOVA. If there are only two samples to compare, use the Wilcoxon-Mann-Whitney test.

As part of the results, KaleidaGraph calculates a P value. This value determines if there is a statistically significant difference between the medians of the groups. If this value is below a certain level (usually 0.05), the conclusion is that there is a difference between the groups. For more information on the results of a Kruskal-Wallis test, refer to the online Help.
To perform a Kruskal-Wallis test:

1. Choose **Functions > Kruskal-Wallis** to display a dialog similar to Figure 4-10.

![Kruskal-Wallis dialog](image)

2. Assign the data columns containing the measured values to the Dependent(s) list.
3. If you are using indexed data, assign the factor column to the Factor(s) list. In this case, only one dependent column may be used.
4. Click **Calculate**. The results of the test are displayed in the bottom half of the dialog.
5. To export the results, click **Copy Results to Clipboard**. You can then paste the results into a data, plot, or layout window.
6. To print the results, click the **Print Results** button.
7. Click **OK** to return to the data window.
4.7 Analyzing Repeated Measurements

KaleidaGraph provides five tests that can be used to analyze two or more matched samples for a significant difference in the mean or median values. The proper test to use depends on the number of samples and the distribution of the data.

Comparing Two Groups
If data was collected from the same group of subjects (for example, the gas mileage for a number of cars before and after receiving a tune-up), use one of the following repeated measures tests:

- Use the **paired t-test** if the samples were taken from normally distributed populations with equal variances. This is a parametric test that compares the sample data directly.
- Use the **Wilcoxon matched pairs test** if the samples were taken from non-normally distributed populations or if the data consists of ranks or scores. This is a nonparametric test that ranks the data, and analyzes the ranks instead of the raw data.

Comparing Three or More Groups
If the samples were taken from normally distributed populations with equal variances, use one of the following repeated measures tests:

- Use a **one way repeated measures ANOVA** to compare the effect of a single factor on the mean of three or more matched groups (for example, comparing the effects of a drug on a group of subjects before, during, and after the treatment).
- Use a **two way repeated measures ANOVA** to compare the effect of two different factors on the mean of three or more matched groups (for example, comparing the effects of a drug on males and females before, during, and after the treatment).

If the samples were taken from non-normally distributed populations or if the data consists of ranks or scores, use the **Friedman test**.

**Note:** If you find a statistically significant difference using the one way repeated measures ANOVA, you can use one of the post hoc tests to determine which groups are different.

4.7.1 Entering Data for Repeated Measurements
The repeated measurement tests in KaleidaGraph require that the data be entered as raw data, where the data for each treatment is entered into a separate column.

The only exception is the two way repeated measures ANOVA, which requires indexed data. In this case, one of the columns is a factor column or grouping variable, with the corresponding data points in two or more columns.

**Note:** Each group being analyzed must have the same number of observations.

The following examples show how the data should be entered for the various repeated measurement tests.
Data Examples - Repeated Measurements

Paired t-test and Wilcoxon matched pairs test

One way repeated measures ANOVA and Friedman test
4.7.2 Performing a Paired t-Test

Use this test to compare means on the same or related subjects over time or under different conditions. This test requires columns of equal length. Any missing or extra values are skipped when running this test.

As part of the results, KaleidaGraph calculates a t probability (P) value. This value determines if there is a statistically significant difference between the two means. If this value is below a certain level (usually 0.05), the conclusion is that there is a difference between the two group means. For more information on the results of a paired t-test, refer to the online Help.

To perform a paired t-test:

1. Choose Functions > Student t to display the Student t-Test dialog.
2. Click the paired data button.
3. Select the columns to be tested by either clicking the column name and pressing a Group button or double-clicking the column names.
4. Click the Correlation check box if you want KaleidaGraph to calculate the correlation and correlation probability values. The correlation probability determines if there is a correlation between the two groups. A small correlation probability (usually less than 0.05) indicates that the two groups are significantly correlated.
5. Click Calculate. The results of the test are displayed on the right side of the dialog.
6. To export the results, click Copy Results to Clipboard. You can then paste the results into a data, plot, or layout window.
7. To print the results, click the Print Results button.
8. Click OK to return to the data window.
4.7.3 Performing a Wilcoxon Matched Pairs Test

Use this test to compare the median values on the same or related subjects over time or under different conditions. This test requires columns of equal length. Any missing or extra values are skipped when running this test.

This test assumes the samples are not normally distributed with the same variances. If you know that the samples are normally distributed, use a paired t-test instead. If there are more than two samples to compare, use the Friedman test.

As part of the results, KaleidaGraph calculates a P value. This value determines if there is a statistically significant difference between the medians of the two groups. If this value is below a certain level (usually 0.05), the conclusion is that there is a difference between the two. For more information on the results of a Wilcoxon matched pairs test, refer to the online Help.

To perform a Wilcoxon matched pairs test:
1. Choose Functions > Wilcoxon to display the Wilcoxon Test dialog.
2. Click the paired data button.
3. Select the columns to be tested by either clicking the column name and pressing a Group button or double-clicking the column names.
4. Click Calculate. The results of the test are displayed on the right side of the dialog.
5. To export the results, click Copy Results to Clipboard. You can then paste the results into a data, plot, or layout window.
6. To print the results, click the Print Results button.
7. Click OK to return to the data window.

4.7.4 Performing a One Way Repeated Measures ANOVA

Use this test when you want to see if the same group of individuals is affected by a single factor. This test is the same as the paired t-test, except that more than two treatments can be compared.

This is a parametric test that assumes the samples are drawn from normally distributed populations with equal variances. If you know that the samples are not normally distributed, use the Friedman test. If there are only two samples to compare, use a paired t-test.

Note: This test requires columns of equal length. If any missing or extra values are found, a one way ANOVA is performed on the data.

As part of the results, KaleidaGraph calculates F and P values. For more information on the results of a one way repeated measures ANOVA, refer to the online Help.

- **F value** - The F value is calculated for both the treatment and the subject. For the treatment, this value is the ratio of the treatment mean square over the error mean square. For the subject, it is the ratio of the subject mean square over the error mean square.
  
  If this value is close to 1.0, you can conclude that there are no significant differences among treatments. If this value is large, you can conclude that the treatments have different effects.
  
  To determine which treatments are different, use one of the post hoc tests.

- **P value** - This value determines if there is a statistically significant difference between the treatments. If this value is below a certain level (usually 0.05), the conclusion is that there is a difference between the treatments.
To perform a one way repeated measures ANOVA:

1. Choose **Functions > ANOVA** to display the ANOVA dialog.
2. Assign the data columns containing the measured values to the Dependent(s) list.
3. Click the **Repeated Measures** check box.
4. Enter a label in the **Repeating Factor Name** field. This label will appear in the ANOVA results.
5. Click **Calculate**. The results of the test are displayed in the bottom half of the dialog.
6. If you find a statistically significant difference, you can use one of the post hoc tests to determine which groups are different and the size of the difference. For more information on the post hoc tests, refer to Section 4.8.
7. To export the results, click **Copy Results to Clipboard**. You can then paste the results into a data, plot, or layout window.
8. To print the results, click the **Print Results** button.
9. Click **OK** to return to the data window.

### 4.7.5 Performing a Two Way Repeated Measures ANOVA

Use this test when you want to see if the same group of individuals is affected by two factors. At least one of these factors is a repeated treatment on the same group of individuals. A two way repeated measures ANOVA tests three hypotheses:

- There is no difference among the levels or treatments of the first factor.
- There is no difference among the levels or treatments of the second factor.
- There is no interaction between the factors.

This is a parametric test that assumes the samples are drawn from normally distributed populations with equal variances. If you want to see the effect of only one factor on your groups, use a one way repeated measures ANOVA. KaleidaGraph does not have a nonparametric equivalent to the two way repeated measures ANOVA.

**Note:** Each group must have the same number of observations for this test.

As part of the results, KaleidaGraph calculates F and P values. For more information on the results of a two way repeated measures ANOVA, refer to the online Help.

- **F value** - The F value is calculated for each of the factors, the interaction, and the subjects. If this value is close to 1.0, you can conclude that there are no significant differences among treatments. If this value is large, you can conclude that the treatments have different effects.
  - For the first factor, this value is the ratio of the factor mean square over the subject mean square.
  - For the second factor, it is the ratio of the factor mean square over the error mean square.
  - For the interaction, it is the ratio of the interaction mean square over the error mean square.
  - For the subjects, it is the ratio of the subject mean square over the error mean square.
- **P value** - This value determines if there is a statistically significant difference between the treatments. If this value is below a certain level (usually 0.05), the conclusion is that there is a difference between the treatments.
To perform a two way repeated measures ANOVA:

1. Choose Functions > ANOVA to display the ANOVA dialog.
2. Assign the data columns containing the measured values to the Dependent(s) list.
3. Assign a factor column to the Factor(s) list.
4. Click the Repeated Measures check box.
5. Enter a label in the Repeating Factor Name field. This label will appear in the ANOVA results.
6. Click Calculate. The results of the test are displayed in the bottom half of the dialog.
7. To export the results, click Copy Results to Clipboard. You can then paste the results into a data, plot, or layout window.
8. To print the results, click the Print Results button.
9. Click OK to return to the data window.

### 4.7.6 Performing a Friedman Test

Use this test when you want to see if a single group of individuals is affected by a series of three or more treatments.

This is a nonparametric test that does not require that the samples be drawn from a normally distributed population. If you know that the samples are normally distributed, use the one way repeated measures ANOVA. If there are only two samples to compare, use the Wilcoxon matched pairs test.

**Note:** This test requires columns of equal length.

As part of the results, KaleidaGraph calculates two different P values. These values determine if there is a statistically significant difference between the groups. If the P values are below a certain level (usually 0.05), the conclusion is that there is a difference between the groups. For more information on the results of a Friedman test, refer to the online Help.

To perform a Friedman test:

1. Choose Functions > Friedman to display a dialog similar to Figure 4-11.
2. Assign the data columns containing the measured values to the Variable(s) list.
3. Click **Calculate**. The results of the test are displayed in the bottom half of the dialog.
4. To export the results, click **Copy Results to Clipboard**. You can then paste the results into a data, plot, or layout window.
5. To print the results, click the **Print Results** button.
6. Click **OK** to return to the data window.
Once you have performed a one way or one way repeated measures ANOVA and found a statistically significant difference, you can use one of the following post hoc tests to determine which groups are different:

- Use the Tukey HSD, Student-Newman-Keuls, Bonferroni, Holm, Scheffe, or Fisher’s LSD test to compare all possible combinations of group pairs.
- Use the Dunnett test if one column represents control data, and you want to compare all other columns to the control column (but not to each other).

As you can see, there are a number of different post hoc tests available. However, there is no consensus as to which test is the best.

The Tukey HSD and Student-Newman-Keuls tests are widely accepted and more commonly used than some of the other tests. Some favor Fisher’s LSD test because it is one of the least conservative tests. If you do not know which test to use, you may want to experiment with two or three tests to get different viewpoints.

To perform a post hoc test:

1. Verify that One Way ANOVA or One Way ANOVA – Repeated Measures is listed on the first line in the ANOVA results. The post hoc tests cannot be used with the two way or two way repeated measures ANOVA.
2. Select the desired test from the Post Hoc Test pop-up menu.
3. If necessary, select a different significance level using the Alpha pop-up menu.
4. Click Calculate. The post hoc test results will appear below the ANOVA results.

4.8.1 Tukey HSD Test

The Tukey HSD (honestly significant difference) test is a pairwise comparison of every combination of group pairs. This test is more conservative than the Student-Newman-Keuls test because the Tukey HSD test controls the errors of all comparisons simultaneously.

The Tukey HSD test calculates the mean difference for each treatment or group pair, calculates a q test statistic for each pair, and displays the P value that corresponds to the q test statistic. The P value determines if there is a statistically significant difference between the treatments or groups being compared. If this value is below a certain level (usually 0.05), the conclusion is that there is a difference between the groups.

For more information on the results of a Tukey HSD test, refer to the online Help.
4.8.2 Student-Newman-Keuls Test

The Student-Newman-Keuls test is a pairwise comparison of every combination of group pairs. This test is calculated in the same manner as the Tukey HSD test, except in the calculation of the q test statistic. This test is less conservative than the Tukey HSD test and is more likely to determine that a given difference is statistically significant.

The Student-Newman-Keuls test calculates the mean difference for each treatment or group pair, calculates a q test statistic for each pair, and displays the P value that corresponds to the q test statistic. The P value determines if there is a statistically significant difference between the treatments or groups being compared. If this value is below a certain level (usually 0.05), the conclusion is that there is a difference between the groups.

For more information on the results of a Student-Newman-Keuls test, refer to the online Help.

4.8.3 Bonferroni Test

The Bonferroni test is a pairwise comparison of every combination of group pairs. This test is more conservative than the Tukey HSD and Student-Newman-Keuls tests.

The Bonferroni test calculates the mean difference for each treatment or group pair, calculates a t test statistic for each pair, and displays the P value that corresponds to the t test statistic. The P value determines if there is a statistically significant difference between the treatments or groups being compared. If this value is below a certain level (usually 0.05), the conclusion is that there is a difference between the groups.

For more information on the results of a Bonferroni test, refer to the online Help.

4.8.4 Holm Test

The Holm test is a pairwise comparison of every combination of group pairs. This test is a refinement of the Bonferroni test. The Holm test may find a statistically significant difference when the Bonferroni test does not. One disadvantage of this test is that, unlike the Bonferroni test, the Holm test does not report any confidence intervals.

The Holm test calculates the mean difference for each treatment or group pair, calculates a t test statistic for each pair, and displays the two-sided P value that corresponds to the t test statistic.

The smallest P value is compared to the adjusted Alpha value. If the P value is greater than or equal to the adjusted Alpha, you can conclude that there is no significant difference for this test and any remaining comparisons. If the P value is less than the adjusted Alpha, there is a statistically significant difference for this test. A new adjusted Alpha value is calculated, and the tests continue with the next smallest P value.

For more information on the results of a Holm test, refer to the online Help.
4.8.5 Scheffe Test

The Scheffe test is a pairwise comparison of every combination of group pairs. Scheffe’s test is more conservative than the other post hoc tests, meaning that a larger difference between means is required for significance. Because it is more conservative, this test has less statistical power than the Tukey HSD or Student-Newman-Keuls tests.

The Scheffe test calculates the mean difference for each treatment or group pair, calculates an S test statistic for each pair, and displays the P value that corresponds to the S test statistic. The P value determines if there is a statistically significant difference between the treatments or groups being compared. If this value is below a certain level (usually 0.05), the conclusion is that there is a difference between the groups.

For more information on the results of a Scheffe test, refer to the online Help.

4.8.6 Fisher’s LSD Test

Fisher’s LSD (least significant difference) test is a pairwise comparison of every combination of group pairs. This test is equivalent to multiple t-tests between all treatments or groups. This is the least conservative post hoc test because no adjustment is made based on the number of tests performed.

Fisher’s LSD test calculates the mean difference for each treatment or group pair, calculates a t test statistic for each pair, and displays the P value that corresponds to the t test statistic. The P value determines if there is a statistically significant difference between the treatments or groups being compared. If this value is below a certain level (usually 0.05), the conclusion is that there is a difference between the groups.

For more information on the results of Fisher’s LSD test, refer to the online Help.

4.8.7 Dunnett Test

The Dunnett test is used to determine if the mean of one group, designated as a control, differs significantly from each of the means of the other groups. This test calculates the mean difference between the control and each treatment or group, calculates a q test statistic for each pair, and displays the P value that corresponds to the q test statistic. The P value determines if there is a statistically significant difference between the control and the group being compared. If this value is below a certain level (usually 0.05), the conclusion is that there is a difference between the groups.

For more information on the results of a Dunnett test, refer to the online Help.
The Formula Entry window is a very powerful tool for data analysis. Using this window, you can apply a wide range of algebraic functions to your data. It also provides a formula script feature to help automate certain functions in the program.

This chapter explains how to:
- Enter and execute formulas.
- Reference columns, cells, and memory locations in a formula.
- Calculate statistics.
- Linearly interpolate data.
- Create multi-line formulas.

5.1 Formula Entry Basics

This section provides the basic information you need to start working with the Formula Entry window. In addition to this section, you may also want to refer to the Tutorial file (Help menu), which contains an example that guides you through the process of executing several formulas.

To display the Formula Entry window, choose Windows > Formula Entry. Use the Formula Entry window, shown in Figure 5-1, to enter formulas that generate and manipulate data in the active data window.

![Figure 5-1 Formula Entry window]
5.1.1 Formula Entry Menus

The menus in Formula Entry contain all of the commands and operators that are available for use. You have the option of choosing the commands from the menu or typing them into the window. Each of the commands is discussed in detail in Section 5.7.

Operators Menu

The operators available within Formula Entry are listed below. Grouped items have the same precedence.

<table>
<thead>
<tr>
<th>Operator</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>!</td>
<td>factorial</td>
</tr>
<tr>
<td>^</td>
<td>power</td>
</tr>
<tr>
<td>*</td>
<td>multiply</td>
</tr>
<tr>
<td>/</td>
<td>divide</td>
</tr>
<tr>
<td>%</td>
<td>modulo</td>
</tr>
<tr>
<td>+</td>
<td>add</td>
</tr>
<tr>
<td>-</td>
<td>subtract</td>
</tr>
<tr>
<td>&lt;</td>
<td>less than</td>
</tr>
<tr>
<td>&lt;=</td>
<td>less than or equal to</td>
</tr>
<tr>
<td>&gt;</td>
<td>greater than</td>
</tr>
<tr>
<td>&gt;=</td>
<td>greater than or equal to</td>
</tr>
<tr>
<td>==</td>
<td>equal to (used for comparisons)</td>
</tr>
<tr>
<td>!=</td>
<td>not equal to</td>
</tr>
<tr>
<td>&amp;&amp;</td>
<td>logical AND</td>
</tr>
<tr>
<td></td>
<td></td>
</tr>
<tr>
<td>?:</td>
<td>conditional</td>
</tr>
<tr>
<td>( )</td>
<td>left and right parentheses</td>
</tr>
<tr>
<td>=</td>
<td>equal (used to store results)</td>
</tr>
<tr>
<td>[ ]</td>
<td>matrix operator</td>
</tr>
</tbody>
</table>

Functions Menu

The Functions menu contains general math functions. Examples of these commands include trigonometric functions (sine, cosine, and tangent), square root, and absolute value.

Statistics Menu

The Statistics menu contains the commands that are used to calculate statistics on data. Section 5.2 explains how to calculate statistics using these commands. The equations used to calculate these statistics are located in Section C.2.

Curve Fits Menu

The Curve Fits menu contains commands that can be used to place curve fit values into the data window. This allows you to find curve fit values at specific points that were not originally plotted. The procedure for doing this is discussed in Section 9.8.4.
Special Menu
The Special menu contains commands that use either a Boolean expression or a text string as part of their definition.

Library Menu
The Library menu displays all of the definitions in the current library. If the library is empty, this menu is also empty. For more information on the library, see Chapter 13.

5.1.2 Formula Structure
A formula calculates new values from existing data in the data window. A formula can be a simple mathematical operation, such as multiplying a column by a constant, or a more complex operation, such as calculating the root mean square of a specific group of data.

Formulas are created using a combination of column references, operators, and functions. Memory locations and constants can also be used in a formula. Formulas are usually constructed with the destination to the left of the equal sign (=) and the calculation to the right of the equal sign. One exception is the name function, which specifies the output column as one of the parameters.

The results of a formula can be stored in another column, a cell, or a memory register. If a destination is not specified, the results are displayed in a dialog similar to Figure 5-2. This is useful for formulas that result in a single value, such as the commands located in the Statistics menu.

![Figure 5-2 Result dialog](image)

5.1.3 Referencing Columns, Cells, and Memory Registers
Column numbers range from 0 to 999 and need to be preceded by a c when used in a formula (c0, c1, and so on). To display the column numbers, click the Expand/Collapse button in the data window. Please note that when a selection is made in the data window, the first column in the selection becomes column 0.

Calculations involving columns are performed on a row-by-row basis. If two or more columns are used in a calculation, corresponding cells in the same row are used to determine the results. If empty or masked cells are encountered during the calculation, the corresponding cell in the destination column is empty.

Individual cells can be referenced in a formula using the cell function. The syntax of this function is cell(row#, col#). Using this function, it is possible to store and retrieve data anywhere in the data window.

Memory registers range from 0 to 99 and need to be preceded by an m when used in a formula (m0, m1, and so on). Memory registers are useful in calculations that result in a single value. The value can be stored in a memory register and used at a later time in other calculations.
Some example formulas are shown below:

<table>
<thead>
<tr>
<th>Example Formulas</th>
</tr>
</thead>
<tbody>
<tr>
<td>c1 = c0/1000</td>
</tr>
<tr>
<td>c5 = (c1+c2) * (c3–c4)</td>
</tr>
<tr>
<td>cell(0,2) = mean(c1)</td>
</tr>
</tbody>
</table>

5.1.4 Entering and Executing a Formula

This section provides the general instructions for entering and executing a formula in the Formula Entry window.

To enter and execute a formula:

1. Open the data window to be operated on by the formula.
2. Choose **Windows > Formula Entry**.
3. Enter the formula into the text field of Formula Entry. You can either type the operators and functions or choose them from the appropriate menus in the Formula Entry window.
4. Multiple formulas can be entered by separating each formula with a semicolon. The Posted Note can also be used to enter multiple formulas. This topic is covered in Section 5.6.
5. Click **Run** to execute the formula.

**Note:** The results of a formula are based on the data at the time the formula is executed. Changing the data does not cause the results to automatically recalculate. To update the results, the formula must be executed again.

5.1.5 Assigning Formulas to Function Buttons

You can store formulas in any of the eight function buttons in Formula Entry. Any formulas that are assigned to these buttons are saved in the Macros file. It is recommended that you store frequently-used formulas in F2–F8 and leave F1 for entering general formulas that do not need to be saved.

To assign a formula to a particular function button:

1. Select the appropriate function button in Formula Entry using one of the following methods:
   - Click the button in the Formula Entry window.
   - Press the corresponding function key on the keyboard.
   - Hold down ⌘ and press the number of the function button you want to select.
2. Enter the formula into the text field of Formula Entry.
5.2 Calculating Statistics with Formula Entry

KaleidaGraph provides 12 commands in the **Statistics** menu to help you analyze data. The statistics can be calculated on individual columns or a specific range of data. The equations used to calculate the statistics are listed in Section C.2.

### 5.2.1 Individual Column Statistics

Statistics are calculated on individual columns by entering the column number within the statistics function. This function results in a single data value, which can be displayed in a dialog or stored in a column, cell, or memory register. The following table shows some example formulas that calculate statistics on individual columns.

<table>
<thead>
<tr>
<th>Formula</th>
<th>Result</th>
</tr>
</thead>
<tbody>
<tr>
<td>mean(c12)</td>
<td>Finds the mean of column 12 and displays the result in a dialog.</td>
</tr>
<tr>
<td>c4 = stderr(c3)</td>
<td>Determines the standard error for column 3 and places the result in column 4.</td>
</tr>
<tr>
<td>cell(0,5) = std(c15)</td>
<td>Finds the standard deviation of column 15 and stores the result in row 0 of column 5.</td>
</tr>
<tr>
<td>m2 = cmin(c11)</td>
<td>Determines the minimum value in column 11 and stores the result in memory register 2.</td>
</tr>
</tbody>
</table>

### 5.2.2 Statistics on a Specific Block of Data

Statistics can also be calculated on a range of data. This is accomplished using the statistics commands and the matrix operator, [ ]. This operator enables you to define a range of rows and columns (around the current row or column index) to use in the calculation. The syntax for the matrix operator is:

```
[starting row:ending row, starting column:ending column]
```

It is not necessary to enter starting and ending values if you want to use all of the rows or columns in the calculation. If the starting and ending values are missing, the entire range of rows or columns is used to determine the result.

For example:

- `[,]` Operate on the entire data window.
- `[ , 1:3]` Operate on all rows in columns 1 through 3.
- `[0:25, ]` Operate on rows 0 through 25 in all columns.
The following table shows some examples of statistics commands using the matrix operator. Each of these formulas display the results in a dialog.

<table>
<thead>
<tr>
<th>Formula</th>
<th>Result</th>
</tr>
</thead>
<tbody>
<tr>
<td>stderr([ , ])</td>
<td>Calculates the standard error for the entire data window.</td>
</tr>
<tr>
<td>mean([ , 1:1])</td>
<td>Finds the mean for all rows in column 1.</td>
</tr>
<tr>
<td>std([0:10, ])</td>
<td>Calculates the standard deviation for rows 0 through 10 in all columns.</td>
</tr>
<tr>
<td>median([0:100, 3:5])</td>
<td>Calculates the median for the data in rows 0 through 100 in columns 3 through 5.</td>
</tr>
<tr>
<td>std([-10:10, 0:0])</td>
<td>Finds the standard deviation for a window of data from -10 rows to +10 rows from the highlighted row in column 0.</td>
</tr>
<tr>
<td>npts([0:1000, -3:3])</td>
<td>Finds the number of points in rows 0 through 1000 in a window of data from -3 columns to +3 columns from the highlighted column.</td>
</tr>
</tbody>
</table>

### 5.2.3 Calculating Statistics on a Row-by-Row Basis

The statistics commands support two formats for calculating statistics on a row-by-row basis. It is valid to either specify a range of columns or to use the matrix operator and enter zero for both the starting and ending row.

For example, both of the following formulas calculate the mean for each individual row in columns 1 through 4 and store the results in column 5:

\[
c_5 = \text{mean}(1:4) \\
c_5 = \text{mean}([0:0, 1:4])
\]

### 5.3 Masking Data with Formula Entry

KaleidaGraph supports two functions (`mask` and `filter`) that can be used to mask data via a formula. An `unmask` function is also provided to return the data to normal. These commands are defined in Section 5.7. Some example uses of these commands are listed below.

**Note:** For more information on masking and unmasking data, refer to Section 3.10.

<table>
<thead>
<tr>
<th>Formula</th>
<th>Result</th>
</tr>
</thead>
<tbody>
<tr>
<td>mask(c0 &lt; 0, c0)</td>
<td>Masks any negative values in c0.</td>
</tr>
<tr>
<td>mask(c1 &lt; c2, c2)</td>
<td>Masks any cells in c2 whose value is greater than the corresponding cell in c1.</td>
</tr>
<tr>
<td>filter(–1, 1, c0)</td>
<td>Masks all cells in c0 that are less than –1 or greater than 1.</td>
</tr>
<tr>
<td>unmask(c0 &gt; 0, c3)</td>
<td>Unmasks any cells in c3 if the corresponding value in c0 is positive.</td>
</tr>
</tbody>
</table>
5.4 Interpolating Data

KaleidaGraph is able to perform linear interpolation through the use of the **table** function in Formula Entry. The table command performs a linear approximation of a number (x) based on the data in two columns. The syntax for this command is `table(x, x col#, y col#)`, such that for a given x value, this function returns an estimate for y.

Figure 5-3 shows an example use of the table function. The first two columns contain X-Y data points. Column 2 contains a new set of X values for which you want to find the corresponding Y values. The Y values in column 3 were found by executing the formula `c3=table(c2, c0, c1)` in Formula Entry.

![Figure 5-3 Sample data window](image)

5.5 Performing Date and Time Calculations

It is possible to perform calculations on columns containing dates and times. Internally, dates are stored as the total number of seconds since Jan. 1, 1904 and times are stored as a relative number of seconds. This allows you to perform calculations on date and time data just as you would with any other kind of data. The easiest way to illustrate this is to use the **Column Formatting** command (Data menu) to change the format of a column containing dates or times to the **Double** format. The column now shows the total number of seconds.

**Note:** You do not have to change the format of the column before using it in a calculation. This is because KaleidaGraph automatically stores the values as a total number of seconds.
5.6 Multi-Line Formulas

With the use of the Posted Note in Formula Entry, you can string formulas together and have them executed sequentially. Each formula should be entered on a separate line and end with a semicolon. This section provides the general instructions for entering and executing a multi-line formula.

To enter and execute a multi-line formula:

1. Open the data window to be operated on by the formula.
2. Choose **Windows > Formula Entry**.
3. Click the Posted Note button ( ) to display the text editor.
4. Enter the individual formulas into the Posted Note. Figure 5-4 shows a multi-line formula entered in the text editor. Notice that each formula is entered on a separate line and is terminated by a semicolon.

   ![Figure 5-4](image)

   Figure 5-4  Posted Note with formula entered

5. When you are finished entering the formulas, choose **File > Close** to leave the editor. The Formula Entry window appears, displaying the message shown in Figure 5-5.

   ![Figure 5-5](image)

   Figure 5-5  Formula Entry after exiting the Posted Note

6. Click **Run** to execute the formulas in the Posted Note.
5.6.1 Adding Comments

Comments can be added to a multi-line formula. Comments are used to make the formula more readable by describing the purpose of the program and the use of each individual formula.

Comments can be added anywhere in the Posted Note with the use of a semicolon. Anything after the semicolon to the first occurrence of a carriage return is treated as a comment. The following lines from the multi-line formula in Figure 5-4 have had comments added.

\[
\begin{align*}
\text{c0} &= (-0.5 + \text{ran}()) \times 10; \quad \text{Fill c0 with random numbers between } -5 \text{ and } 5. \\
\text{macro("Invert Mask")}; \quad \text{Execute the Invert Mask macro from the Macros menu.} \\
\text{name("Values", c0); \quad \text{Change the title of c0 to "Values."}}
\end{align*}
\]

5.6.2 Saving Multi-Line Formulas

Multi-line formulas can be saved as a text file by choosing File > Save As in the Posted Note window. This text file can be reopened at a later time by clicking the Posted Note button in Formula Entry and choosing File > Open.

5.7 Function Descriptions and Syntax

This section describes each of the operators and functions available in the Formula Entry menus. Examples are provided for each of the items.

5.7.1 Operators Menu

( ) - The parentheses are used with almost every formula to enclose the variable being used in the calculation. They are also used to set the priority order for calculations.

Example: \( c3 = (\cos(c2) \times \sin(c1)) + ((2 \times \tan(c0)) / \sqrt{\pi}) \)

\(^\) - This operator raises the preceding value to the specified power.

Examples: \( 5^{2}, c3 = c1^{(1/c0)} \)

\(*\) - This operator multiplies two values together.

Examples: \( 23 \times m0, c3 = .9087 \times c5 \)

\(/\) - This operator is used for division.

Examples: \( c4 = c0 / 12.234, c12 = (c8 + c5) / c2 \)

\(+\) - This operator is used for addition.

Examples: \( c3 = (c2 + c1 + c0) / 3, c12 = 198 + c10 \)

\(-\) - This operator is used for subtraction.

Examples: \( c9 = c8 - c6, c19 = (c12 - c3) / c5 \)

\(\%\) - This operator performs the mod function.

Examples: \( c9 = c8 \% 4, c13 = c12 \% c3 \)

\(!\) - This operator calculates the factorial of a number.

Examples: \( 7!, c13 = c10! \)

\(<\) - This operator compares two values to see if one is less than the other.

Examples: \( \text{mask}(c1 < 3, c1), \text{unmask}(c2 < -12, c3) \)
<= - This operator compares two values to see if one is less than or equal to the other.
   Examples: mask(c4 <= c5, c6), unmask(c2 <= 23, c12)
>
- This operator compares two values to see if one is greater than the other.
   Examples: mask(c1>1, c0), unmask(c4 > c3), c5)
>= - This operator compares two values to see if one is greater than or equal to the other.
   Examples: mask(c12 >= 12.34, c12), unmask(c11 >= -5, c11)
== - This operator compares two values to see if they are equal to each other.
   Examples: mask(c1 == 4, c1), unmask(c3 == c2, c1)
!= - This operator compares two values to see if they are unequal.
   Examples: mask(c2 != c4, c2), unmask(c3 != 2, c3)

&& - This operator performs a logical and on two Boolean expressions. The result of both expressions must be true (non-zero) for the logical and to be true.
   Examples: c3 = (c0>1 && c0<15) ? c0 : 0.5, c1 = (c2>3 && c2<11) ? c2 : 0

|| - This operator performs a logical or on two Boolean expressions. The result of one expression must be true (non-zero) for the logical or to be true.
   Examples: c1 = (c2>1 || c3>1) ? c4, c2 = (c1<0 || c1 == 0.5) ? 0 : c1

?: - This operator performs a conditional test on a Boolean expression. This operator can be expressed in one of two ways:
   • if (Boolean) expression 1 else expression 2
   • (Boolean) ? expression 1 : expression 2

If the result of the Boolean is true (non-zero), return expression 1; if it is false, return expression 2.
   Examples: c9 = (c2>.5 || c3>.1) ? c11 : c4, c1 = (c2>1 && c2<10) ? c2 : 0.1

= - This operator is used to place the result of a calculation into a column, cell, or memory location.
   Examples: m0 = 12 * m1, c1 = sqrt(c0), c2 = cos(c0), cell(0,5) = cmin(c0)

[ ] - The matrix operator is used to specify a range of data for use in a statistical calculation. The syntax of the operator is: [starting row:ending row, starting column:ending column].

It is not necessary to enter starting and ending values to use all of the rows or columns in the calculation. If the starting and ending values are missing, the entire range of rows or columns is used to determine the result.
   Examples: cmax([ 0:23, 3:10]), c18 = median([ , 12:14])
### 5.7.2 Functions Menu

- **abs(x)** - Determines the absolute value of a number.
  
  Examples: abs(–5), abs(m3), c3 = abs(c2)

- **cell(row#, col#)** - Gets or sets the value of a specific cell.
  
  Example: cell(0, 2) = 5.5 * cell(1, 3), cell(10, 13) = sqrt(cell(15, 11))

- **corr(col#, col#)** - Determines the linear correlation between two columns of numbers. To use this function, the two columns being compared must have the same number of data points.
  
  Example: corr(c5, c7), m1 = corr(c9, c12), cell(10, 13) = corr(c2, c3)

- **cos(x)** - Determines the cosine of a number. The number is in radians or degrees, based on the setting in the Formula Entry window.
  
  Examples: cos(30), cos(m8), c4 = cos(c2)

- **diff(x)** - Calculates the difference between each value and the one that follows it.
  
  Examples: c5 = diff(c2), c11 = diff(c10)

- **erf(x)** - Calculates the error function of a value. This function has the following limiting values: erf(0) = 0, erf(∞) = 1, and erf(–x) = –erf(x).
  
  Examples: erf(2), c10 = erf(c9)

- **erfc(x)** - Calculates the complementary error function of a value. This function has the following limiting values: erfc(0) = 1, erfc(∞) = 0, and erfc(–x) = 2–erfc(x).
  
  Examples: erfc(.5), c20 = erfc(c19)

- **exp(x)** - Calculates the value of e (2.7182...) raised to a power.
  
  Examples: exp(3), exp(m1), c10 = exp(c2)

- **fract(x)** - Returns the fractional portion of a number.
  
  Examples: fract(2.83), c12 = fract(c9)

- **index()** - Returns the current row number (starting at 0).
  
  Example: c5 = index() * .5, c11 = index() – 64

- **inorm(x)** - Determines the inverse of the normal distribution for a number between zero and 100%.
  
  Examples: inorm(25), inorm(m2), c10 = inorm(c9)

- **int(x)** - Returns the integer portion of a number.
  
  Examples: int(2.83), c12 = int(c9)

- **invcos(x)** - Determines the inverse cosine of a number. The number is in radians or degrees, based on the setting in the Formula Entry window.
  
  Examples: invcos(.5), invcos(m3), c6 = invcos(c5)

- **invsin(x)** - Determines the inverse sine of a number. The number is in radians or degrees, based on the setting in the Formula Entry window.
  
  Examples: invsin(.219), invsin(m0), c15 = invsin(c10)

- **invtan(x)** - Determines the inverse tangent of a number. The number is in radians or degrees, based on the setting in the Formula Entry window.
  
  Examples: invtan(1), invtan(m2), c9 = invtan(c8)
**ln(x)** - Calculates the natural logarithm (base e) of a number.
Examples: ln(8), ln(m5), c12 = ln(c9)

**log(x)** - Calculates the common logarithm (base 10) of a number.
Examples: log(20), log(m10), c18 = log(c15)

**norm(x)** - Determines the normal distribution of a number between zero and 100%.
Examples: norm(23), norm(m5), c7 = norm(c5)

**pi** - Represents the value of π (3.1415926...).
Example: c10 = pi * c9, c11 = 3 * pi * c9

**ran()** - Generates a random number between zero and one.
Examples: c15 = ran(), c9 = c8 * ran()

**rsum(col#)** - Computes the running sum of a column.
Example: c3 = rsum(c2), c10 = rsum(c9)

**sin(x)** - Determines the sine of a number. The number is in radians or degrees, based on the setting in the Formula Entry window.
Examples: sin(45), sin(m6), c11 = sin(c10)

**sqrt(x)** - Calculates the square root of a number.
Examples: sqrt(192), sqrt(m9), c6 = sqrt(c5)

**table(x, x col#, y col#)** - The table command performs a linear approximation of a number (x) based on the data in two columns. The result is that for a given x, this function returns an estimate for y. The order of the columns determines what value is returned. This function has the following constraints:
- You cannot have masked or empty cells in either the x col# or y col#.
- y col# = f(x col#) may only describe a single value function.
- It does not operate on a subset of rows within a column.
Examples: table(2.5, c0, c1), c4 = table(c3, c0, c1)

**tan(x)** - Determines the tangent of a number. The number is in radians or degrees, based on the setting in the Formula Entry window.
Examples: tan(68), tan(m10), c5 = tan(c4)

### 5.7.3 Statistics Menu

**cmin(x)** - Determines the minimum value within the specified data.
Examples: cmin(c5), cmin([ , 0:10]), c12 = cmin(5:10)

**cmax(x)** - Determines the maximum value within the specified data.
Examples: cmax(c15), cmax([ 0:23, 3:10]), c13 = cmax(1:12)

**csum(x)** - Calculates the sum of the data values.
Examples: csum(c9), csum([ , 0:3]), c12 = csum(3:8)

**kurtosis(x)** - Calculates the kurtosis of the specified data.
Examples: kurtosis(c12), kurtosis([0:5, ]), c5 = kurtosis(1:4)
mean(x) - Calculates the mean of the data.
   Examples: mean(c0), mean([ , 2:3]), c11 = mean(2:8)

median(x) - Calculates the median of the data range.
   Examples: median(c3), median([2:10, 0:1]), c17 = median(12:14)

npts(x) - Determines the number of points within the specified data range.
   Examples: npts(c1), npts([ , 0:5]), c10 = npts(2:6)
rms(x) - Calculates the RMS (root mean square) of the data range.
   Examples: rms(c3), rms([ , 1:1]), c25 = rms(12:21)

skew(x) - Calculates the skewness of the data range.
   Examples: skew(c15), skew([ , 3:10]), c13 = skew(3:10)

std(x) - Calculates the standard deviation of the data range.
   Examples: std(c10), std([12:120, ]), c13 = std(4:10)

stderr(x) - Calculates the standard error of the data.
   Examples: stderr(c4), stderr([-5:5, 15:19]), c3 = stderr(5:15)

var(x) - Calculates the variance of the specified data range.
   Examples: var(c6), var([0:25, ]), c13 = var(4:12)

5.7.4 Curve Fits Menu

expr(x, col#) - Given an x value and a column that has an Exponential curve fit applied, this function determines the value from the fit at the x point.
   Examples: expr(105, c10), c11 = expr(c8,c9)

gen(" ", x, col#) - Given the name of a General curve fit, an x value, and a column that has the fit applied, this function determines the value at the x point. If no name is given, the first General fit that is found in the column is used.
   Examples: gen("fit1", 22, c1), c5 = gen(c0, c1), c11 = ("gaussian", c8, c9)

interp(x, col#) - Given an x value and a column that has an Interpolate curve fit applied, this function determines the value from the fit at the x point.
   Examples: interp(11.95, c2), c19 = interp(c15, c18)

lin(x, col#) - Given an x value and a column that has a Linear curve fit applied, this function determines the value from the fit at the x point.
   Examples: lin(-12.5, c1), c10 = lin(c9, c5)

logr(x, col#) - Given an x value and a column that has a Logarithmic curve fit applied, this function determines the value from the fit at the x point.

poly(x, col#) - Given an x value and a column that has a Polynomial curve fit applied, this function determines the value from the fit at the x point.
   Examples: poly(.0034, c15), c14 = poly(c12, c1)

pow(x, col#) - Given an x value and a column that has a Power curve fit applied, this function determines the value from the fit at the x point.
   Examples: pow(119, c10), c3 = pow(c0, c2)
smooth(x, col#) - Given an x value and a column that has a Smooth curve fit applied, this function determines the value from the fit at the x point.

Examples: smooth(11.15, c2), c4 = smooth(c2, c3)

spline(x, col#) - Given an x value and a column that has a Cubic Spline curve fit applied, this function determines the value from the fit at the x point.

Examples: spline(-23.098, c17), c4 = spline(c3, c8)

wgt(x, col#) - Given an x value and a column that has a Weighted curve fit applied, this function determines the value from the fit at the x point.

Examples: wgt(15.657, c2), c9 = wgt(c10, c11)

5.7.5 Special Menu

execute("filename") - This function loads a formula or formula script into the Posted Note and executes it. This function can only be used in the Formula Entry window; it cannot be used in the Posted Note window.

Examples: execute("Macintosh HD:Scripts:script1"),
execute("C:\KaleidaGraph\Scripts\script1.txt")

macro(" ") - This function executes a macro by name.

Examples: macro("Simplify"), macro("Invert Mask")

mask(logical expression, col#) - Masks the cells in the specified column if the expression is true.

Examples: mask(c4 > 1.25, c6), mask(c9 != c11, c14)

name(" ", col#) - This command uses the text string given to name the specified column.

Examples: name("Y-Error", c2), name("Residuals", c11)

script("filename") - This function loads and runs the specified plot script. If no name is given, the current script is executed.

Examples: script("Scatter Plot Script"), script("Temperature"), script()

unmask(logical expression, col#) - Unmasks the cells in the specified column if the expression is true.

Examples: unmask(c2 == c4, c5), unmask(c2 < 4, c3)

5.7.6 Library Menu

The Library menu lists all of the definitions that are present in the current library. If the library is empty, this menu is also empty.
Creating Plots

KaleidaGraph provides 23 different plot types for representing your data. All of the plot types are listed in the Gallery menu. This chapter covers:

- The different types of plots that are available in KaleidaGraph.
- Creating a plot.
- Plotting multiple X-Y pairs on a single graph.
- Plotting a function.
- Generating similar plots.

### 6.1 Types of Plots

#### 6.1.1 Line Plot

Use a Line plot to represent trends in different data sets over a period of time. Each line in the plot represents a separate data column. The data is displayed as a series of X-Y pairs, connected to the next point by a line. The data does not have to be sorted, but it is important to note that the points are connected in the order they appear in the data window.

Line plots give you a great deal of flexibility in how the data is displayed. You can specify the number of markers, line style, and line thickness for each variable. You can also hide the line and display only the markers. All of these characteristics are controlled in the Variable Settings dialog.
6.1.2 Scatter Plot

Use a Scatter plot to compare large sets of data. Scatter plots are similar to Line plots, except the points are not connected by lines. Each X-Y pair is represented by a unique marker on the plot. Each column of data is represented by a different marker.

Scatter plots display a marker for each point in the plot. It is not possible to display a partial set of markers or a line between the points. If you want this kind of flexibility, plot the data as a Line plot.

Figure 6-2  Sample Scatter plots

6.1.3 Double Y Plot

Use a Double Y plot to display two groups of data, each with its own vertical scale. Each line in the plot represents a separate data column. The data is displayed as a series of X-Y pairs, connected to the next point by a line. The data does not have to be sorted, but it is important to note that the points are connected in the order they appear in the data window.

The Double Y plot gives you the same amount of control over the display of the data as the Line plot, but with the added capability of having separate scales on the vertical axes. This plot is useful when you are plotting two dependent (Y) groups which share a common independent (X) variable.

6.1.4 Double X Plot

Use a Double X plot to display two groups of data, each with its own horizontal scale. Each line in the plot represents a separate data column. The data is displayed as a series of X-Y pairs, connected to the next point by a line. The data does not have to be sorted, but it is important to note that the points are connected in the order they appear in the data window.

The Double X plot gives you the same amount of control over the display of the data as the Line plot, but with the added capability of having separate scales on the horizontal axes. This plot is useful when you are plotting two groups of data that need to have separate independent (X) axes and share the same dependent (Y) axis.
6.1.5 Double XY Plot

Use a Double XY plot to display two groups of data, each with its own horizontal and vertical scale. Each line in the plot represents a separate data column. The data is displayed as a series of X-Y pairs, connected to the next point by a line. The data does not have to be sorted, but it is important to note that the points are connected in the order they appear in the data window.

The Double XY plot gives you the same amount of control over the display of the data as the Line plot, but with the added capability of having two separate scales on the horizontal and vertical axes. This plot is useful when you are plotting two groups of data that need to have separate independent (X) and dependent (Y) axes.

6.1.6 High/Low Plot

This plot type is designed for many uses. The most common is to create High/Low/Close plots for the financial industry. This plot normally contains a vertical bar, representing the range of values from low to high, and a marker, representing the ending or closing value.

The order of the columns in the data window does not matter. However, this plot appears differently depending on how many Y variables are plotted for a given X.

- One Y variable (Line plot) - A standard Line plot is generated. This is often useful when overlaying a High/Low plot with some additional X-Y data.
- Two Y variables (Spike plot) - A vertical line is drawn between the two data points. The first plotted variable controls the color, line style, width, and marker style.
- Three or more Y variables (High/Low/Close plot) - A vertical line is drawn between the minimum and maximum data points. The first plotted variable controls the color, line style, width, and marker style. All of the data points between the minimum and maximum are drawn as ticks to the right of the vertical line. The size of the tick is controlled by the marker size of the first plotted variable.
6.1.7 Step Plot

A Step plot is a variation of a Line plot. It can be used to compare data that does not show a trend. Each line in the plot represents a separate data column. The data is plotted as a series of steps. The data does not have to be sorted, but it is important to note that the points are connected in the order they appear in the data window.

**Note:** It is not possible to display markers on a Step plot. The placement of the steps is controlled using the **Step** portion of the Plot Options dialog (Plot menu).

![Sample Step plots](image)

6.1.8 Probability Plot

Use a Probability plot to display the graph of a variable normalized to either a linear or normal probability distribution. The X axis is scaled in probability (between 0 and 100%) and shows the percentage of the Y variable whose value is less than the data point. The Y axis displays the range of the data variables.

The Probability plot gives rough information about the local density of the data and symmetry. The plotted data points do not coincide, even if there are exact duplicates in the data. It is easy to read information from the plot and it can accommodate a large number of observations. The Probability plot is not a summary but a display of all the data.

**Note:** The **Probability** portion of the Plot Options dialog (Plot menu) controls whether a linear or normal distribution is used.

6.1.9 X-Y Probability Plot

The X-Y Probability plot is similar to the Probability plot. The only difference is that in an X-Y Probability plot, you enter the probability associated with each Y value. The data is entered as X-Y pairs, where X is the probability (between 0 and 100%) and Y is the data value.

![Sample Probability and X-Y Probability plots](image)
6.1.10 Histogram Plot

A Histogram calculates the number of data points that fall within a specified bin size. The resulting plot displays the range of the data on the X axis and the number of data points in each bin on the Y axis. If more than one variable is plotted, the Y axis displays the total number of points in each bin.

KaleidaGraph supports two different methods for creating Histograms. You can either specify the bin size or specify the number of bins. The Histogram portion of the Plot Options dialog (Plot menu) determines which method is used.

If you choose to create the Histogram by specifying the bin size, the Limits portion of the Axis Options dialog contains the fields for the bin size, reference value, and number of bins that get added or removed. This is the method that was used in versions 3.5x and 3.6x of KaleidaGraph.

If you choose to create the Histogram by specifying the number of bins, the Histogram portion of the Plot Options dialog contains a setting to control the number of bins. This is the method that was used prior to v3.5 of KaleidaGraph.

![Figure 6-7 Sample Histogram plots](image)

6.1.11 Box Plot

A Box plot enables you to quickly examine a number of variables and extract their major characteristics. While this does not provide detailed information about the data, it does give you a look at its global behavior. A Box plot represents each variable as a separate box. The X axis displays the names of each variable and the Y axis displays the range of the data. See Section C.1 for details on what the boxes represent and how they are calculated.

Up to 20 additional variables may (optionally) be overlaid as markers on each plot. The markers are matched one to one with the plotted variables. The first value in a marker column is matched with the first box, the second value in a marker column is matched with the second box, and so on. When using markers, the boxes do not have a fill pattern so that the markers can be clearly identified.

Note: You may not select more than a total of 20 variables and markers from a single data window. If your needs exceed this limit, place the variables and markers in separate data windows.

![Figure 6-8 Sample Box plots](image)
6.1.12 Percentile Plot

A Percentile plot represents each variable as a separate box. The X axis displays the names of each variable and the Y axis displays the range of the data. Each box encloses 90% of the data.

The bottom and top of each box represent 5% and 95% of the data. Three lines are drawn inside each box. The middle line represents the median value of the data (50%), while the lower and upper dashed lines represent 25% and 75% of the data, respectively. Due to the importance of these lines, the boxes do not have fill patterns.

Up to 20 additional variables may (optionally) be overlaid as markers on each plot. The markers are matched one to one with the plotted variables. The first value in a marker column is matched with the first box, the second value in a marker column is matched with the second box, and so on.

Note: It is not possible to display a fill pattern in the boxes. You may not select more than a total of 20 variables and markers from a single data window. If your needs exceed this limit, place the variables and markers in separate data windows.

6.1.13 Dot Plot

A Dot plot enables you to quickly examine a number of variables and extract their major characteristics. Dot plots are often used to illustrate the major features of the distribution of the data in a convenient form. A Dot plot can also help detect any unusual observations (outliers), or any gaps in the data set.

The X axis displays the names of each variable and the Y axis displays the range of the data. You can use the Dot portion of the Plot Options dialog (Plot menu) to control the options associated with this type of plot.

Note: Up to 20 dependent (Y) variables can be plotted at one time.
6.1.14 Summary Column Plot

A Summary Column plot is similar to a Column plot. The biggest difference is that this plot does not require an independent (X) variable. This plot is particularly useful when you have individual data values that you want to display with different fill patterns or colors, or when comparing statistical attributes of variable data. You can place each value in a separate column and create a Summary Column plot.

The X axis displays the names of each variable and the Y axis displays the range of the data. To change the statistical attribute displayed in the Summary Column plot, select a different attribute from the Display pop-up menu in the Bar portion of the Plot Options dialog (Plot menu).

The Display pop-up menu is also used when supplying error values in a data column. If you plot the mean of the data and add error bars from a data column, the error bar will represent the mean of the error values.

Note: Up to 20 dependent (Y) variables can be plotted at one time.

![Sample Summary Column plots](image)

6.1.15 Horizontal Bar Plot

A Horizontal Bar plot is a graph of data selected from one window. The data is displayed as a series of horizontal bars. The length of each bar represents the value of a variable. Multiple values for the same category (row) are displayed as side-by-side bars. The horizontal axis displays the range of the dependent values and the vertical axis displays the categories.

Note: A maximum of one independent (X) variable and 20 dependent (Y) variables may be plotted at once. Customizing Horizontal Bar plots is covered in Section 7.14.

![Sample Horizontal Bar plots](image)
### 6.1.16 Stack Bar Plot

A Stack Bar plot is a graph of data selected from one window. As in a Horizontal Bar plot, the data is displayed as a series of horizontal bars. The difference between a Stack Bar plot and a Horizontal Bar plot is that variables belonging to the same category (row) are displayed as bars stacked one on top of another. The length of each bar represents the sum of the data points for a category. The horizontal axis displays the range of sums for a category and the vertical axis displays the categories.

**Note:** A maximum of one independent (X) variable and 20 dependent (Y) variables may be plotted at once. Customizing Stack Bar plots is covered in Section 7.14.

![Sample Stack Bar plots](image)

### 6.1.17 Double Y Bar Plot

A Double Y Bar plot is a graph of data selected from one window. As in a Horizontal Bar plot, the data is displayed as a series of horizontal bars. The Double Y Bar plot differs from the Horizontal Bar plot in that it provides you with two independent Y axes.

The length of each bar represents the value of a variable. Multiple values for the same category (row) are displayed as side-by-side bars. The horizontal axes display the range of the dependent values and the vertical axis displays the categories.

**Note:** A maximum of one independent (X) variable and 20 dependent (Y) variables may be plotted at once. Customizing Double Y Bar plots is covered in Section 7.14.

![Sample Double Y Bar plots](image)
6.1.18 Column Plot

A Column plot is a graph of data selected from one window. The data is displayed as a series of vertical bars. The height of each bar represents the value of a variable. Multiple values for the same category (row) are displayed as side-by-side columns. The horizontal axis displays the categories and the vertical axis displays the range of the variables.

Note: A maximum of one independent (X) variable and 20 dependent (Y) variables may be plotted at once. Customizing Column plots is covered in Section 7.14.

![Sample Column plots](image)

6.1.19 Stack Column Plot

A Stack Column plot is a graph of data selected from one window. As in a Column plot, the data is displayed as a series of vertical bars. The difference between a Stack Column plot and a Column plot is that variables belonging to the same category (row) are displayed as columns stacked one on top of another. The height of each bar represents the sum of the data points for a category. The horizontal axis displays the categories and the vertical axis displays the range of sums for all variables in that category.

Note: A maximum of one independent (X) variable and 20 dependent (Y) variables may be plotted at once. Customizing Stack Column plots is covered in Section 7.14.

![Sample Stack Column plots](image)
### 6.1.20 Double Y Column Plot

A Double Y Column plot is a graph of data selected from one window. As in a Column plot, the data is displayed as a series of vertical bars. The Double Y Column plot differs from the Column plot in that it provides you with two independent Y axes.

The height of each bar represents the value of a variable. Multiple values for the same category (row) are displayed as side-by-side columns. The horizontal axis displays the categories and the vertical axes display the range of the dependent values.

**Note:** A maximum of one independent (X) variable and 20 dependent (Y) variables may be plotted at once. Customizing Double Y Column plots is covered in Section 7.14.

![Sample Double Y Column plots](image)

### 6.1.21 Polar Plot

In a Polar plot, the data is plotted on the polar coordinate system. Each point in this system is specified by an angle ($\theta$) in degrees and a radius ($R$). As an option, an alternate data format can be used, where the data is specified in X-Y format and then transformed to the polar coordinate system. In either case, an independent variable ($\theta$ or X) and one or more dependent variables ($R$ or Y) are selected for plotting.

Using the **Polar** portion of the Plot Options dialog (**Plot** menu), you can specify the grid type, data format, reference angle, and direction for Polar plots. Customizing Polar plots is covered in Section 7.15.

![Sample Polar plots](image)
6.1.22 Pie Chart

A Pie chart displays the value of up to 20 categories as a percentage of the total area of a circle. Each of the categories is represented as a segment of the circle (or a wedge of the pie). Only two variables may be plotted at one time in a Pie chart. The first is the independent (X) variable or category. This variable contains the name of each category. The second variable (Y) contains the category values, which must be numeric.

Note: If more than 20 categories are selected for plotting, only the first 20 appear on the plot. Customizing Pie charts is covered in Section 7.16. Negative values cannot be plotted in a Pie chart. If the data contains negative values, a dialog gives you the option of plotting the absolute value of the data or canceling the plot.

![Sample Pie charts](image)

6.1.23 Function Plot

The Function plot can be used to display a mathematical function as a plot. Choosing this plot type displays a dialog where you can enter the function, the minimum and maximum X values, and the number of points to plot.

Once the plot is created, it behaves like a Line plot. You have full control over the line style, markers, and all other components of the plot. Section 6.3 provides instructions for creating a Function plot.

![Sample Function plots](image)

6.1.24 Text Plot

This plot type allows you to create a plot window whose intended use is text. Text plots are particularly useful when you want to generate a plot that only contains text, lines, boxes, tables, or pictures.

Note: Certain tools in this window are unavailable, because they can only be used when data is plotted.

6.1.25 Template Plot

The Template plot is used to generate the same type of plot, using different data. It allows you to take any plot and use it as a base for plotting new data. This works for both new plots and plots that have been saved. The use of this plot is discussed in Section 6.4.2.
6.2 Creating a Plot

The **Gallery** menu contains the plot types available in KaleidaGraph. You can create a plot using any of the open data windows. If a selection is made in the data you are plotting, only the selected data is used in making the plot.

To create a plot:

1. Open the data to be plotted.
2. Make any selections in the data windows to plot a subset of the data.
3. Choose a plot type from the **Gallery** menu. A dialog similar to Figure 6-21 is displayed.

4. Click the appropriate buttons to select the columns to be plotted. You can clear all of the buttons at once by clicking the check mark icon in this dialog.

5. Click **New Plot** to create the plot.

At this point, the plot is linked to the original data window. If another plot is opened or created, the data for the previous plot becomes embedded in the plot. If the plot is saved, a copy of the data is embedded in the plot and saved as part of the plot file. Once data is embedded in a plot, it can be extracted by choosing **Plot > Extract Data** or clicking the Extract button (اظهار) in the plot window.
6.2.1 Plotting from Multiple Data Windows

Unless you are creating a Pie chart or one of the plots in the Bar submenu, you can plot data from multiple data windows. This is accomplished by making variable selections for each data set to be used.

The Variable Selection dialog contains a pop-up menu listing the names of all open data windows. Using this menu, you can select up to 20 independent and 20 dependent variables to be plotted. If a text column is used as the independent variable, you may not select any other independent variables and you can only plot from that particular data window.

To create a plot from multiple data sets:

1. Open the data to be plotted. To plot subsections of any data sets, select the appropriate rows in each data window.
2. Choose a plot type from the Gallery menu. A Variable Selection dialog appears.
3. Make the independent and dependent variable selections for the active data window.
4. Click the data window’s name in this dialog to display a pop-up menu containing the name of each data window. A check mark in front of the name indicates that variables are already selected from that data window. If the data window contains a data selection, its name is underlined.

The dialog in the background of Figure 6-22 displays the variables selected from the first data set and the pop-up menu used to switch between data windows.

5. Select the name of a different data window and make the variable selections. Continue doing this until all of the variables to be plotted are selected. The dialog in the foreground of Figure 6-22 shows the selection made from the second data set.

6. Click New Plot to create a plot based on the selections.
6.2.2 Plotting Multiple X-Y Pairs from the Same Data Window

The Linear, X-Y Probability, and Polar plots allow you to plot multiple independent variables from the same data window. If the independent variable is a text column, you may only have one independent variable.

For the plot types mentioned above, the Variable Selection dialog contains a pop-up menu listing the independent variables (X–X9). Using this pop-up menu, you can plot up to nine independent and 20 dependent variables from one data window.

To create a plot from one data window, with different X variables:

1. Open the data to be plotted.
2. Choose a plot type from the Gallery menu. A Variable Selection dialog appears.
3. Make the first set of X and Y variable selections.
4. Click the X column’s shadow box to display a pop-up menu containing the list of X variables (X–X9). If one of the variables already contains a selection, it is preceded by a check mark. The dialog in the background of Figure 6-23 displays the pop-up menu used to select a different independent variable.
5. Select a different X variable and choose what is to be plotted against it. Continue doing this until all of the selections are made. The dialog in the foreground of Figure 6-23 shows the selections for the second independent variable.
6. Click New Plot to create a plot based on the selections.
6.3 Plotting a Function

KaleidaGraph provides a Function plot that can be used to plot any mathematical function. The function you enter is evaluated between the specified limits and is displayed as a plot.

When defining your function, use \( x \) for the independent variable. The operators and math functions found in Formula Entry can be used in defining your function. Constants and other shorthand references can be defined in the library. You can also use any of the definitions included in the Curve Fits folder, however you will need to edit the \( X \text{ min} \), \( X \text{ max} \), and \( \text{Points} \) fields after loading one of these files. The table below lists some example definitions:

<table>
<thead>
<tr>
<th>Example Function Definitions</th>
</tr>
</thead>
<tbody>
<tr>
<td>( 5 * x^2 )</td>
</tr>
<tr>
<td>( \text{gaussfit}(1, 5, 1, 10) )</td>
</tr>
<tr>
<td>( m1 + m2 * \exp(-m3 * x); m1 = 5; m2 = 1; m3 = 0.5 )</td>
</tr>
<tr>
<td>( a * \exp(-b * x) * \cos(c * x + d); a = 4; b = 0.7; c = 2.2; d = 15 )</td>
</tr>
</tbody>
</table>

To create a Function plot:

1. Choose **Gallery > Function** to display the Function Plot dialog, shown in Figure 6-24.

![Figure 6-24 Function Plot dialog](image)

2. Enter the function you want to plot. The **File** button can be used to load a saved function definition.

3. If necessary, change the values for the minimum, maximum, and number of points.

4. Click **New Plot** to plot the function.

Once the Function plot is created, it behaves like a Line plot. You have full control over the line style, markers, and all other components of the plot. If you want to see the data generated by the function, choose **Plot > Extract Data** or click the Extract button (\( \mathbb{F} \)) in the plot window.
If you routinely create the same types of plots in KaleidaGraph, it helps to set some defaults or templates so that most of the work can be done automatically. KaleidaGraph provides several features that can be used to generate similar plots.

### 6.4.1 Using Style Files

One way to generate similar plots is through the use of Style files. KaleidaGraph stores most of your dialog settings and program defaults in the Style file. The Style file also stores layouts for each of the various plot types, in addition to any defaults you may have set for colors and text labels.

Each of the plots in the Gallery menu can have its own layout. The layout remembers the default style for the legend, the position of the axis titles, plot title, axes, and legend, and the size of the axes, frame, and legend.

To define the layout for a plot:

1. Open an existing plot or create a plot of the type you want to define.
2. Modify the position and size of the titles, plot, and legend.
3. Choose Plot > Define Layout. The dialog in Figure 6-25 is displayed, asking if you want to save the layout for this plot type.

```
Figure 6-25  Define Layout dialog
```

4. Click OK to save the layout.

Defining the layout of a plot only saves the position of the titles and legend. To change the defaults for text labels, you must use the Text Options command (Plot menu).

You need to save the Style file when quitting for these changes to be remembered the next time you start KaleidaGraph. To create individual Style files for different projects, choose File > Export > Style. This way you can save any number of different Style files which can be opened at a later time using the Open command.
6.4.2 Using Template Plots

The Template plot is used to generate the same type of plot, using different data. It allows you to take any graph and use it as a base for plotting new data. This works for new graphs and graphs that were saved.

The new data is autoscaled unless the limits are fixed in the Axis Options dialog. The legend reflects the new variables being plotted, but all other text labels and objects remain the same. Any curve fits or error bars in the original plot are applied and recalculated on the new plot.

Once a Template plot has been created, it can be modified like any other plot. If you need the ability to generate multiple plots at once, use the Plot Script feature. This topic is covered in Section 6.4.3.

To use a plot as a template for creating other plots:

1. Open or create the data to be plotted.
2. Open or create the plot you want to use as a base for creating other plots.
3. Choose Gallery > Template to display a Variable Selection dialog. Figure 6-26 shows the dialog when the original plot is a Scatter plot.

![Variable Selection dialog]

Figure 6-26 Variable Selection dialog

4. Click the appropriate buttons to select the variables to be plotted.
5. Click New Plot to generate a plot based on your selections.

Note: It is not necessary to use the Template plot if you are only modifying the original data used to create the plot. Instead, you can extract the data from the plot, modify it, and update the plot. This process is covered in Section 7.12.
6.4.3 Using Plot Scripts

Another way to generate similar plots is the Plot Script command (Windows menu). This feature enables you to choose any plot type or an existing plot and use it as a template for creating multiple plots at once.

The script feature is intended for the user who has a Template plot and wants to plot different data sets and view the resulting curves. Even if you only need to generate a simple plot, but you generate it all of the time with different data, you will find plot scripts very useful.

The advantage of a script over a Template plot is that a script can generate multiple plots. Also, you can control legend descriptions and plot titles using a script. In a Template plot, the legend descriptions come from the column names of the plotted variables and the plot title remains unchanged.

For more information on plot scripts, refer to Section 12.1.

6.4.4 Using Formula Scripts

The last feature that allows you to generate similar plots is a formula script. This feature has a command, #SCRIPT, which has all of the same options as the Plot Script window. You can create a plot script from scratch or you can use a command to open one that is saved.

The advantage of using a formula script is that you can open and modify data windows as part of the script. You can also execute more than one plot script inside of a formula script.

The disadvantage of using this feature is that you cannot select a specific plot to be used as the template. It must either be a Gallery plot type or a plot that is opened as part of a saved plot script.

For more information on formula scripts, refer to Section 12.2.
KaleidaGraph provides complete control over the appearance of your plots. This includes the legend, axes, ticks, grid lines, and labels, in addition to how the data is represented on the plot.

This chapter explains how to:

- Edit the legend and legend text.
- Change the axis limits and scaling, as well as removing, exchanging, and linking axes.
- Control the display and number of tick marks.
- Control the display of grid lines.
- Control the display of axis labels.
- Change the marker, fill pattern, line style, line width, and variable color.
- Change the frame, grid, interior, and background colors of a plot.
- Resize the plot.
- Change the data in a plot.
- Customize Bar, Polar, and Pie plots.

### 7.1 Hiding, Displaying, and Closing Plots

The **Windows** menu contains four commands that can be used to hide and display plot windows. These commands operate on either a single window or all of the plot windows at once.

#### 7.1.1 Changing the Active Window

To make a plot window active, click anywhere in the desired plot window or choose **Windows > Show Plot** and select its name.

#### 7.1.2 Hiding Plot Windows

To hide a plot window, choose **Windows > Hide Window** and select its name. You can hide all open plots by choosing **Windows > Hide All Plots**.
7.1.3 Displaying Plot Windows

You can display a hidden plot window with the **Show Plot** command (**Windows** menu). The names of hidden plot windows appear in italic. Select the name of the desired plot window and it is brought to the front. The **Show All Plots** command can be used to display all of the plot windows at once.

7.1.4 Closing Plot Windows

You can use the **Close All Plots** command (**Windows** menu) to close all of the open plot windows at once. Individual plot windows can be closed by choosing **File > Close** or clicking the close box of each window. A dialog may be displayed, asking if you want to save the plot before closing.

**Note:** If you do not want to save the plot, this dialog can be avoided by pressing **Shift** while either clicking the close box or choosing **File > Close/NoSave**.

You can have a maximum of 32 plots open at one time in KaleidaGraph. If you have 32 plots open and try to create another plot, either the oldest plot is automatically disposed or the dialog in Figure 7-1 appears. The **General** tab of the Preferences dialog contains an option that controls the automatic disposal of plots. If **Automatically dispose of old plots** is selected, the oldest plot is discarded. If this check box is cleared, the dialog is displayed.

![Maximum Open Plots dialog](image)

Figure 7-1 Maximum Open Plots dialog

7.2 Changing the View of the Plot Window

KaleidaGraph provides several magnification levels for changing the view of the plot window. To change the magnification of the plot, click the Zoom drop-down menu in the lower-left corner of the plot window and choose the desired zoom level. The available zoom percentages are: 25, 50, 75, 100, 125, 150, 200, 300, and 400%.

7.3 Displaying Rulers and Grids in the Plot Window

To turn the rulers and grids on and off in the plot window:

1. With the plot window active, choose **Plot > Ruler & Grids**.
2. Click the appropriate check boxes to display the rulers, grids, or both.
3. Select the proper units that you want to use.
4. Click **OK** to return to the plot window.
7.4 Modifying the Legend

The legend consists of a frame, the plot symbols, and the labels used to identify each variable in the plot. By default, the labels are taken from the column names in the data window. The legend displays the variables in the order they are selected for plotting.

7.4.1 Editing the Legend Frame and Color

Changing Foreground and Background Color

The Color icon on the toolbox consists of two sections: a foreground section (upper left) for setting the foreground color and a background section (lower right) for setting the background color. When you select a fill or pen pattern, the foreground color is applied to the black portion of the pattern and the background color is applied to the white portion of the pattern.

To change the foreground or background color of the legend:

1. Click the legend to select it.
2. Click the foreground or background section of the Color icon. One of the following color palettes appears with the current color choices.
3. Select a different color from the palette.

Changing Fill and Pen Patterns

The Pattern icon on the toolbox consists of two sections: an inner section for setting the fill pattern and an outer section for setting the pen pattern. The fill pattern controls the interior of the legend; the pen pattern controls the legend frame.

You can change the fill or pen pattern by selecting a different pattern from the pop-up menu that appears when you click the appropriate portion of the Pattern icon. Black portions of the pattern represent the foreground color and white portions represent the background color.
To change the fill or pen pattern of the legend:

1. Click the legend to select it.
2. Click the interior or outer portion of the Pattern icon. One of the following pop-up menus appears with the pattern choices.

![Fill Pattern choices](image1)

![Pen Pattern choices](image2)

3. Select a different pattern from the pop-up menu.

**Changing Line Style and Width**

The Style icon on the toolbox controls the line style and width of the legend frame. The left portion of the icon controls the line style; the right portion controls the line width.

To change the line style or width of the legend frame:

1. Click the legend to select it.
2. Click the line style or line width portion of the Style icon. One of the following pop-up menus appears with the available choices.

![Line style pop-up menu](image3)

![Line width pop-up menu](image4)

3. Select a different line style or width from the pop-up menu. To completely remove the frame around the legend, choose **None** from the Line Style pop-up menu.

**Setting Legend Frame Defaults**

To make the current legend style the default, choose **Plot > Define Layout**. Choosing this command only remembers the settings for this particular type of plot because each plot type in the **Gallery** menu can have its own layout.

This information is saved as part of the Style file. You must save the Style file for the layout to be remembered the next time you start KaleidaGraph.
7.4.2 Editing Legend Text

Editing Legend Text Attributes as a Group
The attributes of the legend text can be changed as a group by double-clicking any of the labels in the legend with the Selection Arrow. A variation of the Edit String dialog, shown in Figure 7-8, appears which can only be used to modify the attributes of the text labels. This dialog does not allow you to edit any of the text labels. Refer to the online Help for more information on the commands available in this dialog.

![Edit String dialog](image)

Figure 7-8  Variation of Edit String dialog

Editing Individual Items in the Legend
The labels in the legend can be edited using the Text tool. Double-clicking a text label displays the Edit String dialog. Edit the legend text as needed and click **OK** to return to the plot.

The labels in the legend can be moved to different locations using the Text tool. This is accomplished by dragging a label to a new position with the Text tool. To delete an item in the legend, use the Eraser.

Changing Legend Text Color Independent of Variable Color
By default, the color of the legend text is linked to the variable color set in the Variable Settings dialog. To make these different colors, choose **Plot > Text Options** and clear the **Link Text To Variable Color** check box. The text and variable colors can now be set independently.
7.5 Modifying Axes

This section explains how to control the appearance of the axes. The Axis Options dialog, shown in Figure 7-9, contains all of the options related to the display of the axes. Many of these settings are also available directly from the toolbox. Section B.2 explains how to modify the axes using the toolbox.

![Axis Options dialog]

Figure 7-9 Axis Options dialog
7.5.1 Setting the Axis Limits

The axis limits are based on the data used to create the plot. KaleidaGraph automatically calculates the minimum and maximum values and the placement of tick marks along the axes.

You can specify your own limits in the Axis Options dialog. The **Minimum** and **Maximum** fields determine the lowest and highest values on the selected axis. The **Anchor Tick** field indicates the value from which all major tick marks on a linear axis are calculated. The Anchor Tick field has no affect on axes with logarithmic scales.

To set the axis limits:

1. With the plot window active, choose **Plot > Axis Options**.
2. Click the appropriate axis tab at the top of the dialog.
3. Click **Limits** if it is not already selected. The Axis Options dialog changes to display the options available for controlling axis limits.
4. Enter values for **Minimum**, **Maximum**, and **Anchor Tick**. To return to the original values calculated by KaleidaGraph, click the **Auto** check boxes.
5. Click **OK** to return to the plot.

7.5.2 Selecting Linear or Log Scaling

The numeric axes in KaleidaGraph can have either linear or logarithmic scaling. When **Linear** scaling is selected, the axis is divided into equal sections. When **Log** scaling is used, each increment of the axis is a power of 10. Partial decades are allowed when using the log scale.

To change the scaling of an axis:

1. With the plot window active, choose **Plot > Axis Options**.
2. Click the appropriate axis tab at the top of the dialog.
3. Click **Limits** if it is not already selected. The Axis Options dialog changes to display the options available for controlling axis limits.
4. Choose **Linear** or **Log** from the **Scale** pop-up menu.

   **Note:** The **Minimum** value in the Axis Options dialog must be greater than zero to use log scaling. If you try to use non-positive limits, a message appears and the axis scaling reverts to linear.
5. Click **OK** to return to the plot.
7.5.3 Changing the Position of an Axis

By default, KaleidaGraph places the axes at the edge of the plot area. However, you have complete control over where to place each of the axes on the plot. The axes can be positioned away from the plot to create offset axes, at a specific value on the X or Y axis, or at a percentage of the length of the X or Y axis.

Changing the Position via the Axis Options Command

You can use the Axis Options command (Plot menu) to control the position for each of the axes in a plot.

To change the position of an axis:

1. Choose Plot > Axis Options to display the Axis Options dialog.
2. Click the appropriate axis tab at the top of the dialog.
3. Click Position. The Axis Options dialog changes to display the options available for controlling the axis position.
4. Specify where you want this axis positioned:
   - Choose Bottom (X), Left (Y), Top (X2), or Right (Y2) to return the axis to its default location.
   - Choose % From Bottom (X), % From Left (Y), % From Top (X2), or % From Right (Y2) and enter the axis length percentage to offset the axis from the default location. Enter a positive value to move the axis towards the center of the plot; enter a negative value to move the axis away from the center of the plot.
   - Choose At Y = or At X = to place the axis at a specific value along the axis. If the value is outside the limits or occurs within a break, the axis will be placed at the nearest point along the axis.
5. Click OK to return to the plot.

Changing the Position with the Selection Arrow

The Selection Arrow can be used to manually change the position of an axis.

To change the position of an axis:

1. Double-click one of the axes with the Selection Arrow. The first click selects the plot frame, the second click selects the individual axis. A dotted box will be drawn around the selected axis.
2. Drag the axis to a new position. You can also use the arrow keys to move the axis.

Note: The axes can only be moved in one direction. The X and X2 axes can only move vertically, and the Y and Y2 axes can only move horizontally.
7.5.4 Inserting an Axis Break

Most of the plots in KaleidaGraph allow you place a break in the axis. Breaks are normally used when you have large gaps in the values that you are plotting.

KaleidaGraph provides options to control the data range of the break, the placement of the break, the symbol used to identify the break, and the scaling and tick marks displayed after the break.

To insert a break in an axis:

1. With the plot window active, choose Plot > Axis Options.
2. Click the appropriate axis tab at the top of the dialog.
3. Click Breaks. The Axis Options dialog changes to display the options available for inserting an axis break.
4. Enter the range of values you want excluded in the Omit and To fields. As soon as you make any changes, the Show Axis Break check box is automatically selected.
5. To control the position of the break, enter a value in the Position field. The position represents a percentage of the axis length, starting at the origin. The default is to place the break in the middle of the axis.
6. To control the width of the break, edit the Width field.
7. To select a different symbol for the axis break, use the Gap Style pop-up menu. The length of these symbols is set with the Length field.
8. To change the scaling or tick marks on the other side of the axis break, use the Post Break Interval, Major Ticks, and Minor Ticks pop-up menus.
9. Click OK to return to the plot.

Note: Once an axis break is inserted, the Data Selection and Zoom Selection tools become disabled.

7.5.5 Removing an Axis Break

To remove an axis break:

1. With the plot window active, choose Plot > Axis Options.
2. Click the appropriate axis tab at the top of the dialog.
3. Click Breaks. The Axis Options dialog changes to display the options available for axis breaks.
4. Clear the Show Axis Break check box.
5. Click OK to return to the plot.

7.5.6 Hiding an Axis

It is possible to hide each of the four axes in a plot using the Turn Off Axis option in the Axis Options dialog.

To hide an axis:

1. With the plot window active, choose Plot > Axis Options.
2. Click the appropriate axis tab at the top of the dialog.
3. Click Position. The Axis Options dialog changes to display the options available for controlling the axis position.
4. Click the Turn Off Axis check box.
5. Click OK to return to the plot.
7.5.7 Exchanging Axes

The **Exchange X and Y Axis** option in the Axis Options dialog can be used to swap the X and Y axes of a plot. When this check box is selected, the X and X2 axes switch position with the Y and Y2 axes.

**Note:** Using this option does not change the independent and dependent variables. It only changes their position in the plot. This option is not available for Double Y, Double X, Double XY, Bar, Polar, and Pie plots.

To exchange the X and Y axes:
1. With the plot window active, choose **Plot > Axis Options**.
2. Click the **X** or **Y** axis tab at the top of the dialog.
3. Click **Position**. The Axis Options dialog changes to display the options available for controlling the axis position.
4. Click the **Exchange X and Y Axis** check box.
5. Click **OK** to return to the plot.

7.5.8 Reversing the Variables on an Axis

You can control whether the variables are plotted in ascending or descending order along an axis. By selecting the **Reverse Axis Direction** check box in the Axis Options dialog, variables are plotted in descending order along the selected axis.

To reverse an axis on the plot:
1. With the plot window active, choose **Plot > Axis Options**.
2. Click the appropriate axis tab at the top of the dialog.
3. Click **Limits** if it is not already selected. The Axis Options dialog changes to display the options available for controlling axis limits.
4. Click the **Reverse Axis Direction** check box.
5. Click **OK** to return to the plot.

7.5.9 Linking a Second Axis

You can control the display of the tick marks and labels on the X2 and Y2 axes using the **Link To** pop-up menu. This pop-up menu is only available when the X2 or Y2 axis tab is selected.

**Note:** The Link To pop-up menu is not available for certain axes in Double Y, Double X, and Double XY plots because they are independent of the main axis.
To link the X2 or Y2 axis:

1. With the plot window active, choose **Plot > Axis Options**.
2. Click the **X2** or **Y2** axis tab at the top of the dialog.
3. Click **Limits** if it is not already selected. The Axis Options dialog changes to display the options available for controlling axis limits.
4. From the **Link To** pop-up menu, select how the axis should be linked. The options include:
   - **No Ticks, No Labels** - The X2 or Y2 axis does not have any ticks or labels.
   - **Axis, No Labels** - The X2 or Y2 axis has the same tick marks as the main axis, but does not have any labels.
   - **Axis, Labels** - The X2 or Y2 axis has the same tick marks and labels as the main axis.
   - **Custom Axis, Custom Labels** - Depending on the scaling of the main axis, the X2 or Y2 axis is linked by either a linear or exponential equation. The equation is entered into one of the dialogs shown in Figure 7-10. The tick marks and labels are calculated and displayed on the X2 or Y2 axis.
5. Click **OK** to return to the plot.

### 7.5.10 Changing Axis Thickness

To change the thickness of the axes:

1. With the plot window active, choose **Plot > Axis Options**.
2. Click the **All** tab at the top of the dialog.
3. Click **Thickness**. The Axis Options dialog changes to display the thickness options available.
4. To increase the thickness of the axes, change the **Axis Thickness** to 200, 300, or 400%.
   
   **Note:** Depending on the value entered, you may not notice the change on the screen; however, there will be a difference when the plot is printed.
5. Click **OK** to return to the plot.
7.6 Modifying Tick Marks and Grid Lines

This section explains how to change the appearance of the tick marks and grid lines. The Axis Options dialog, shown in Figure 7-11, contains all of the options related to the display of tick marks and grid lines. Many of these settings are also available directly from the toolbox. Sections B.2.4 and B.2.5 explain how to modify these items using the toolbox.

![Axis Options dialog](image)

Figure 7-11  Axis Options dialog
7.6.1 Changing the Display of Tick Marks and Grid Lines

The major and minor ticks can be displayed inside, outside, or on both sides of the axis. You can also choose not to display them at all.

Grid lines can be displayed at each of the major and minor tick marks. The lines can be gray (dotted), solid, or not displayed at all. Section 7.9 explains how to change the color of the grid lines.

To control how major and minor ticks and grid lines are displayed:
1. With the plot window active, choose Plot > Axis Options.
2. Click the appropriate axis tab at the top of the dialog.
3. Click Ticks & Grids. The Axis Options dialog changes to display the options available for controlling major and minor tick marks and grid lines.
4. To change how the tick marks are displayed, choose In, Out, Both, or None from the Display Tick pop-up menus.
5. To change how the major and minor grid lines are displayed, choose Gray, Solid, or None from the Display Grid pop-up menus.
6. Click OK to return to the plot.

7.6.2 Changing the Number of Tick Marks

When Linear scaling is selected for an axis, the number of major tick marks is controlled by the Quantity pop-up menu. They can either be calculated automatically or set to a specific number.

To change the number of major ticks:
1. With the plot window active, choose Plot > Axis Options.
2. Click the appropriate axis tab at the top of the dialog.
3. Click Ticks & Grids. The Axis Options dialog changes to display the options available for controlling major and minor tick marks and grid lines.
4. Choose Auto or Fixed # from the Quantity pop-up menu.
5. If Fixed # is selected, enter the desired number of divisions in the field below the pop-up menu.
6. Click OK to return to the plot.

The number of minor tick marks is controlled in the same manner as major ticks. You can either specify a fixed number or let KaleidaGraph calculate the number of minor ticks.
7.6.3 Changing the Tick Mark Interval

When Linear scaling is selected for an axis, KaleidaGraph automatically determines the number of major tick marks. Using the Axis Options command, it is possible to place the tick marks at specific intervals along an axis.

To change the interval between major tick marks:

1. With the plot window active, choose Plot > Axis Options.
2. Click the appropriate axis tab at the top of the dialog.
3. Click Limits if it is not already selected. The Axis Options dialog changes to display the options available for controlling axis limits.
4. Enter a value in the Anchor Tick field. The intervals are calculated from the Anchor Tick value.
5. Click Ticks & Grids.
6. Choose Interval from the Quantity pop-up menu and enter the desired interval in the field below it. For dates, enter the desired number of days for the interval. For time data, use a D:H:M:S.S format for entering the interval.
7. Click OK to return to the plot.

7.6.4 Changing Tick Mark Length

To change the length of the tick marks:

1. With the plot window active, choose Plot > Axis Options.
2. Click the All tab at the top of the dialog.
3. Click Tick Length. The Axis Options dialog changes to display the options available.
4. Edit the Inside Length and Outside Length fields for the major and minor ticks.
5. Click OK to return to the plot.

7.6.5 Changing Tick Mark and Grid Line Thickness

To change the thickness of the tick marks or grid lines:

1. With the plot window active, choose Plot > Axis Options.
2. Click the All tab at the top of the dialog.
3. Click Thickness. The Axis Options dialog changes to display the thickness options available.
4. To increase the thickness of the tick marks, change the Tick Thickness to 200, 300, or 400%.
5. To increase the thickness of the grid lines, change the Grid Thickness to 200, 300, or 400%.

Note: Depending on the values entered, you may not notice the change on the screen; however, there will be a difference when the plot is printed.
6. Click OK to return to the plot.
7.7 Modifying Axis Labels

This section explains how to control the frequency and format of the axis labels. The Axis Options dialog, shown in Figure 7-12, contains all of the options related to the number and format of the axis labels. Many of these settings are also available directly from the toolbox. Section B.2.6 explains how to modify the axis labels using the toolbox.

Note: For information on changing the text attributes of the labels, see Section 8.7.2.

![Figure 7-12 Axis Options dialog](image-url)
7.7.1 Controlling the Frequency of Axis Labels

KaleidaGraph automatically calculates the frequency of axis labels. The frequency depends on the number of major tick marks. You can specify a different frequency or you can choose to remove the axis labels from the plot.

To control the frequency of the axis labels:

1. With the plot window active, choose Plot > Axis Options.
2. Click the appropriate axis tab at the top of the dialog.
3. Click Labels. The Axis Options dialog changes to display the options available for specifying label frequency.
4. Choose Auto, Every Nth, or None from the Placement pop-up menu to specify how often the labels should be displayed. If you select Every Nth, enter a number in the field below the menu.
5. Click OK to return to the plot.

7.7.2 Formatting Axis Labels

The format of the axis labels can also be controlled using the Axis Options dialog. Some of the options available include selecting scientific or engineering notation, specifying the number of significant digits, and adding a prefix or suffix to the axis labels.

Note: If Text data was plotted along the axis, the format of the labels will not change.

To change the format of the axis labels:

1. With the plot window active, choose Plot > Axis Options.
2. Click the appropriate axis tab at the top of the dialog.
3. Click Labels. The Axis Options dialog changes to display the options available for changing the label format.
4. Make your selections in the dialog.
5. Click OK to return to the plot.
7.8 Modifying Lines, Markers, and Fill Patterns

This section explains how to control the display of the data in the plot window. The Variable Settings dialog, shown in Figure 7-13, contains most of the options available for the display of the plot variables. Many of these settings are also available directly from the toolbox. Section B.3 explains how to modify the variable settings using the toolbox.

![Variable Settings dialog](image)

Figure 7-13 Variable Settings dialog

7.8.1 Selecting Variables in the Variable Settings Dialog

Before variables can be modified, they need to be selected in the Variable Settings dialog. Each variable is independently controlled in this dialog.

To select variables for editing in the Variable Settings dialog:

1. With the plot window active, choose Plot > Variable Settings.
2. Select the variables that you want to edit.
   - To select individual variables, press Shift or ⌘ and click the variable name.
   - To select a range of variables, drag with the mouse.
   - To select all of the variables, press ⌘+A.
   - To deselect a variable, press ⌘ and click the variable name.

**Note:** When working with variables that have long names, you can resize this portion of the dialog. Position the pointer over the vertical line to display a double-headed arrow (➡️). Then, drag to resize the dialog.
7.8.2 Changing Marker Type, Size, or Number of Markers

Most of the plots have the ability to display markers on the plot. The exceptions are the Histogram, Stack Bar, Stack Column, and Pie plots. The Variable Settings dialog controls the type, size, and number of markers displayed in the plot.

To change the marker type, size, or number of markers:

1. With the plot window active, choose **Plot > Variable Settings**.
2. Select the variable to be edited. See Section 7.8.1 if you are unsure of how to do this.
3. To change the marker type, click one of the symbols from the **Marker** pop-up menu. The first six markers in the left column are transparent; all of the others are opaque.
4. To change the size of the marker, select a new size from the **Marker Size** pop-up menu.
5. To change the number of markers displayed, make a selection from the **Show Markers** pop-up menu. You can choose whether all, a fixed number, a percentage, every Nth, or none of the markers are displayed on the plot.

**Note:** Scatter plots always show all of the markers. Use a Line plot to show fewer markers.

6. Click **OK** to return to the plot.

7.8.3 Selecting Fill Patterns

All of the plots have the ability to have a fill pattern displayed for the variable. For some plots, like the Line plot, this is only possible if **Bar** is selected as the marker type in the Variable Settings dialog.

**Note:** It is not possible to assign a fill pattern to the markers.

To change the fill pattern:

1. With the plot window active, choose **Plot > Variable Settings**.
2. Select the variable to be edited. See Section 7.8.1 if you are unsure of how to do this.
3. Select one of the patterns from the **Fill Pattern** pop-up menu.
4. Click **OK** to return to the plot.

7.8.4 Changing Appearance of Variable and Curve Fit Lines

Line, Double Y, Double X, Double XY, High/Low, Step, Probability, X-Y Probability, Horizontal Bar, Column, and Function plots can use a line to represent a plotted variable. Curve fits can be applied to all of these plots as well as Scatter plots. The style, width, and color of the variable or curve fit lines can be set using the Variable Settings dialog.

**Note:** Variable and curve fit lines are controlled independently of each other, unless **Link to Variable Settings** is selected in the **Curve Fit Settings** tab of the Variable Settings dialog. Changing the variable color also changes the marker color. The associated legend text is also changed if **Link Text To Variable Color** is selected in the Text Options dialog (**Plot** menu).
To change the line style, width, or color of variable or curve fit lines:

1. With the plot window active, choose **Plot > Variable Settings**.
2. Select the variable to be edited. See Section 7.8.1 if you are unsure of how to do this.
3. If changes are being made to the variable line, proceed to the next step. Otherwise, click the **Curve Fit Settings** tab at the top of the dialog to make changes to the curve fit line.
4. To change the line style, select a different option from the **Line Style** pop-up menu. Choose **None** from this menu to hide the line.
5. To change the line width, select a different option from the **Line Width** pop-up menu.

   **Note:** If you also want to make the markers thicker, follow the instructions in Section 7.8.5.
6. To change the color, select a different color from the **Color** pop-up menu.
7. Click **OK** to return to the plot.

### 7.8.5 Changing Line and Marker Thickness

The Variable Settings dialog contains options for setting the thickness of the variable and curve fit lines, however, these do not affect the thickness of the markers. The **General** portion of the Plot Options dialog contains a **Line Thickness** setting that can be used to increase the thickness of variable and curve fit lines and a **Marker Thickness** setting that can be used to increase the thickness of the markers.

To change the thickness of the markers, variable lines, and curve fit lines:

1. Choose **Plot > Plot Options**.
2. Click **General**.
3. To increase the thickness of variable and curve fit lines, change the **Line Thickness** to 200, 300, or 400%.
4. To increase the thickness of the markers, change the **Marker Thickness** to 200, 300, or 400%.

   **Note:** Depending on the value entered, you may not notice the change on the screen; however, there will be a difference when the plot is printed.
5. Click **OK** to return to the plot.

### 7.9 Changing Plot Color

The Axis Options command controls the axis, grid, interior, and background colors for a plot. These settings are also available directly from the toolbox. Section B.4 explains how to modify the colors using the toolbox.

To change the plot colors:

1. Choose **Plot > Axis Options**.
2. Click the **All** tab at the top of the dialog.
3. Click **Colors**. The Axis Options dialog changes to display the color options available.
4. Select the desired colors from the **Frame**, **Grid**, **Interior**, and **Background** pop-up menus. If **Transparent Interior** or **Transparent Background** is selected, that particular portion of the plot is transparent.
5. Click **OK** to return to the plot.
There are two methods available for changing the size of the plot: the Set Plot Size command and the Selection Arrow. Changing the size of the plot has no affect on the size of the plot window. Once the plot has been resized, you can make these settings the new default by choosing Plot > Define Layout and clicking OK.

### 7.10.1 Set Plot Size Command

You can use the Set Plot Size command (Plot menu) to specify the exact dimensions for the axes and frame, as well as the position of the axis origin.

To set the size of the plot:

1. Choose Plot > Set Plot Size. The dialog in Figure 7-14 appears.

   ![Set Plot Size dialog](image)

   **Figure 7-14 Set Plot Size dialog**

2. Click Axis Size, Frame Size, or both and enter the desired X and Y dimensions.
   - If Axis Size is selected, the frame is scaled proportionally to the new dimensions.
   - If Frame Size is selected, the axis is scaled proportionally to the new dimensions.
   - If both are selected, the axis and frame sizes are set independently. Be careful; this can cause parts of the plot to be placed outside of the plot frame.

   **Note:** Typing the word auto allows a floating dimension, while specifying the size of the other dimension. This allows the plot to remain proportional to its original size.

3. If necessary, click the Axis Origin check box and specify where to place the upper-left corner of the axes.

4. Click OK. The plot is resized based on the new settings.

If the values in the Frame Size field are larger than the Paper dimensions, a dotted line is displayed to represent the printable area of the paper. You can hide these lines by clearing the Show the plot paper boundary check box in the General tab of the Preferences dialog.
7.10.2 Using the Selection Arrow

The Selection Arrow can be used to manually resize the plot or plot frame.

To resize the plot:

1. Click one of the axes with the Selection Arrow. Object handles appear at each corner of the plot.
2. Drag one of the handles to a new position. As you drag, a dialog appears in the upper-left corner of the plot window. This dialog (shown below) contains the current plot dimensions and axis origin (offset).

```
(In.)  X:  Y:
Offset: 1.50 1.50
Axis: 5.00 5.00
Frame: 7.50 7.50
```

**Note:** To resize the plot proportionally about its center, press Option when dragging an object handle. By pressing Shift as you drag, you can constrain the plot to a square.

3. Release the mouse button when the axes are the desired size.

To resize the plot frame:

1. Locate the lower-right corner of the plot frame. You can use the scroll bars or increase the size of the plot window to find it.
2. Using the Selection Arrow, click the Size box (尺) in the lower-right corner.
3. Drag the box to resize the plot frame. As you drag, a dialog appears in the upper-left corner of the plot window to display the current dimensions.
4. Release the mouse button when the plot frame is the desired size. The size of the plot changes proportionally to the new size of the frame.

7.11 Extracting Data from a Plot

When you save a plot with data, the data windows used to create it are archived with the plot. This enables you to save the graph and data in a single file instead of saving them separately. The data is not saved with the plot if either of the following occurs:

- The data windows used to create the plot are closed before the plot is saved.
- The plot is saved by choosing File > Save Graph As and selecting KaleidaGraph Picture from the Format pop-up menu.

The next time the plot is opened, you can make any necessary changes to the plot. If you want to modify the data, it needs to be extracted from the plot. This is accomplished by choosing Plot > Extract Data or clicking the Extract button (¶) in the plot window. Once the data is extracted, it can be modified, saved to disk, or used to create new plots.

**Note:** The Extract Data command is unavailable if the plot does not have archived data associated with it, the plot was just created, or the data has already been extracted.
To extract a data set:

1. Make a plot window the active window.
2. Choose **Plot > Extract Data** or click the Extract button ( ) in the upper-right corner of the plot window. The data used to create the plot is displayed. Figure 7-15 shows an example of an extracted data set.

![Figure 7-15 Extracted data window](image)

The title of the extracted data window begins with the same name as the original data file. Additionally, a date and time stamp is appended to the name, identifying when the data was archived in the plot.

### 7.12 Updating Plotted Data

The **Plot** menu contains two commands that can be used to update the data in a plot: **Auto Link** and **Update Plot**. Both of these commands operate in a similar manner. They cause the current plot to be updated to reflect any changes in its data. Curve fits and error bars are also recalculated based on any changes in the data.

The difference between the two commands is that **Auto Link** revises the plot after each individual change in the data while **Update Plot** only causes an update when you choose the command. Clicking the Update Plot button ( ) in the data window performs the same function as choosing the Update Plot command.

These commands are useful if you have a saved plot and need to add or edit points. You can extract the data from the plot (using either the **Extract Data** command or the Extract button), modify the data, and use the Auto Link or Update Plot commands to revise the plot.
To update plots using the **Auto Link** command:

1. Open or activate the plot to be updated.
2. Choose **Plot > Extract Data** or click the Extract button (烻) to display the data used to create the plot.
3. Turn on **Auto Link** in the **Plot** menu.
4. Modify the data and move to another cell. After each data value is modified, the plot is redrawn to show the changes.

To update plots using the **Update Plot** command:

1. Open or activate the plot to be updated.
2. Choose **Plot > Extract Data** or click the Extract button (烻) to display the data used to create the plot.
3. Make any changes to the extracted data.
4. Choose **Plot > Update Plot** or click the Update Plot button (烻) in the data window to redraw the plot.

**Note:** To update the plot using a subset of the data, select the data, press **Shift** or **Option**, and either choose **Plot > Update Plot** or click the Update Plot button. This particular selection will be remembered until you make a different selection and press **Shift** or **Option** when updating the plot. To go back to using the entire data set, either select all of the data or click a single cell and then press **Shift** or **Option** when updating the plot.

### 7.13 Plotting Additional Data

There may be times when you want to add additional variables to an existing plot. Instead of creating the plot from scratch, you can open a plot and add new data to it.

**Note:** If you just want to add a few points to an existing curve, refer to Section 7.12. The steps below are for adding a new variable to the plot.

To add additional variables to a plot:

1. Open or activate the plot which will have the new data plotted.
2. Choose **Plot > Extract Data** or click the Extract button (烻) to display the data used to create the plot.
3. Open the new data or add it to an existing data window.
4. Switch back to the plot and choose **Gallery > Template**.
5. Select all of the data to be plotted (including the data from the original plot) and click **New Plot**.

A new plot will be created that includes the additional data. Any curve fits and error bars from the original plot will be applied to the new plot.
7.14 Customizing Bar Plots

This section explains some of the special features associated with Bar plots. This includes changing the spacing between bars, displaying value labels, and creating Line/Column plots.

7.14.1 Changing Bar Attributes

The Bar portion of the Plot Options command (Plot menu) contains four options that affect the appearance of the bars. For details on changing the fill pattern in the bars, see Section 7.8.3.

To change the attributes of the bars:

1. Choose Plot > Plot Options.
2. Click Bar to display the options available for Bar and Column plots, shown in Figure 7-16.

![Plot Options dialog](image)

Figure 7-16  Plot Options dialog

3. To change the spacing between the bars, edit the Column Offset percentage. Entering a value of 0% removes all space between the bars; a value of 100% displays the bars as spikes.
4. To remove the frame surrounding each bar, clear the Draw Column Frame check box.
5. To use a baseline of 1.0 for log scales, select the Adjust Log Baseline check box. Otherwise, the minimum axis limit is used for the baseline.
6. To make the frame the same color as the fill pattern, clear the Black Column Frame check box.
7. Click OK to return to the plot.
### 7.14.2 Adding Value Labels

Labels that display the value of each bar can be added to Bar plots. For Horizontal Bar and Column plots, the label is placed at the end of each bar. For Stack Bar and Stack Column plots, labels are placed on each section of the bar.

To add value labels to a Bar plot:

1. Select the plot which will have the value labels added.
2. Turn on **Add Values** in the **Plot** menu. The actual values of each bar are added to the plot.

Figure 7-17 shows a Bar plot that contains value labels. These labels can be moved individually with the Text tool or as a group with the Selection Arrow. The **Value Label Format** command (**Plot** menu) can be used to change the numeric format of the labels.

**Note:** Any time the plot is redrawn, the value labels are placed back at their original position. If you are displaying only a few of the labels, use the Text tool to add them to the plot. You can place them exactly where you want and you do not have to worry about the label moving when the plot is redrawn.

![Figure 7-17  Bar plot with value labels](image)

To change the text attributes of the value labels:

1. Double-click one of the text labels with the Selection Arrow. The Edit String dialog appears.
2. Make any changes to the label attributes. Setting default attributes is covered in Section 8.7.5.
3. Click **OK** to update the value labels.
7.14.3 Adding Lines to Bar and Column Plots

Horizontal Bar and Column plots can have lines added to create Line/Column plots.

To make a Line/Column plot:

1. Create a Horizontal Bar or Column plot, including the variable to be displayed as a line. Figure 7-18 shows a sample Column plot with two variables plotted.

2. Choose Plot > Variable Settings.

3. Select the variable to be displayed as a line.

4. Select a Fill Pattern of Line, as well as the line style, line width, and number of markers to be displayed.

5. Click OK and the plot updates to display a Line/Column plot. Figure 7-19 shows the sample plot after displaying the second variable as a line.
7.15 Customizing Polar Plots

There are two commands in the Plot menu that can be used to change the appearance of Polar plots: **Axis Options** and **Plot Options**. Axis Options controls the display of tick marks, grid lines, and axis labels while Plot Options controls the grid type, reference angle, and direction.

### 7.15.1 Changing the Display of Tick Marks, Grid Lines, and Axis Labels

The angular (Ø or X) and the radial (R or Y) axes can be modified using the Axis Options command. Choosing **Plot > Axis Options** displays the dialog in Figure 7-20. The options for each of the axes are discussed in the following paragraphs.

![Figure 7-20  Axis Options dialog](image)

The angular axis is controlled by the X axis settings in the Axis Options dialog. You can use the options for **Ticks & Grids** and **Labels** to modify this axis. You can also use the **Turn Off Axis** option in the **Position** portion of the dialog to remove the angular axis.

The radial axis is controlled by the Y axis settings in the Axis Options dialog. You can use the options for **Limits**, **Ticks & Grids**, and **Labels** to modify the axis. You can also choose between **Linear** and **Log** scaling, or remove the axis with the **Turn Off Axis** option in the **Position** portion of the dialog.
7.15.2 Setting the Grid Type, Reference Angle, and Direction

Polar plots have several unique options that control their appearance. These options include the grid type, data format, reference angle, and direction. All of these options are controlled by the Polar portion of the Plot Options command (Plot menu).

To change the Polar plot options:

1. Choose Plot > Plot Options. The dialog in Figure 7-21 is displayed.
2. Click Polar to display the options available for Polar plots.
3. Make any changes to the settings in this dialog.
4. Click OK to return to the plot.

Figure 7-22 shows a Polar plot displayed in a Clockwise direction, with a circular grid and a 45° Reference Angle. Figure 7-23 shows a Polar plot displayed on a square grid.
7.16 Customizing Pie Charts

This section explains some of the special features associated with Pie charts. This includes exploding a segment of the chart, removing the frame, and displaying value labels.

7.16.1 Exploding a Pie Chart

A common method of emphasizing one segment of a Pie chart is to drag that segment away from the chart. This is called an exploded Pie chart.

To move a pie segment:

1. Using the Selection Arrow, click twice on the segment to be moved. The first click selects the entire pie. The second click selects the individual segment.
2. Drag the segment away from the rest of the pie. Do not worry about what direction you drag, the segment only moves along its radius. Figure 7-24 shows an example of an exploded Pie chart.

![Figure 7-24 Exploded Pie chart](image)

7.16.2 Removing the Frame Surrounding each Slice

There are two methods available to remove the frame that surrounds each piece of the pie. The first is to clear the Draw Pie Frame check box in the Pie portion of the Plot Options dialog (Plot menu).

The second method is to make the change directly from the toolbox. When the entire Pie is selected, the toolbox displays the icons shown to the right. Click the last icon to display the pop-up menu shown below. Turn on No Frame in the menu to remove the frame.
### 7.16.3 Adding Value Labels

Labels that display the percentage of each slice relative to the entire pie can be added to Pie charts.

To add value labels to a Pie chart:

1. Select the Pie chart which will have the value labels added.
2. Turn on **Add Values** in the **Plot** menu. The percentage values of each pie slice are added to the plot. To display the actual values, select the **Display Pie Values** check box in the **Pie** portion of the Plot Options dialog (**Plot** menu).

Figure 7-25 shows a Pie chart that contains value labels. These labels can be moved individually with the Text tool or as a group with the Selection Arrow. The **Value Label Format** command (**Plot** menu) can be used to change the numeric format of the labels.

**Note:** Any time the plot is redrawn, the value labels are placed back at their original position. If you are displaying only a few of the labels, use the Text tool to add them to the plot. You can place them exactly where you want and do not have to worry about the label moving when the plot is redrawn.

![Figure 7-25 Pie chart with value labels](image)

To change the attributes of the value labels:

1. Double-click one of the text labels with the Selection Arrow. The Edit String dialog appears.
2. Make any changes to the label attributes. Setting default attributes is covered in Section 8.7.5.
3. Click **OK** to update the value labels.
Working with Plot Tools and Objects

Chapter 8

This chapter covers:

- Using the tools and icons displayed on the toolbox.
- Selecting, moving, resizing, and deleting objects.
- Aligning objects.
- Grouping and ungrouping objects.
- Sending objects up, down, to the front, and to the back.
- Creating and editing text labels.
- Creating and editing lines, arrows, rectangles, ovals, polygons, arcs, and Bezier curves.

8.1 The KaleidaGraph Toolbox

The toolbox, shown in Figure 8-1, is displayed whenever a plot or layout window is active. It contains all of the plot tools, as well as a number of icons that can be used to quickly make changes in the plot or layout window. When switching between plot or layout windows, the toolbox remembers the last tool selected for each window.

8.1.1 Plot Tools

Selection Arrow

The Selection Arrow is used to select tools, commands, and objects in the plot or layout window. Sections 8.6.1–8.6.3 discuss editing objects with the Selection Arrow. Resizing the plot with this tool is covered in Section 7.10.2.

The Selection Arrow is the default tool in the toolbox. It is automatically selected whenever a new plot is created. Also, most tool selections revert to the Selection Arrow after being used. This tool is used to select, move, and resize objects in the plot or layout window. Once an object is selected, you can copy, duplicate, or delete it.
Text Tool  
This tool is used to add and modify plot labels. Clicking this tool and holding down the mouse button displays a pop-up menu that can be used to edit selected text labels. Using the Text tool is covered in Section 8.7.

Line/Arrow Tool  
This tool is used to draw lines or arrows. Clicking this tool and holding down the mouse button displays a pop-up menu that contains the lines and arrows that can be drawn. Creating lines and arrows is discussed in Section 8.8.1.

Object Tool  
Clicking the object tool (to the right of the Line/Arrow tool) displays the pop-up menu shown below. This menu contains six drawing tools that can be used to create various shapes. Creating and editing shapes is covered in Section 8.8.

Box Tool  
This tool is used to draw square and rectangular boxes. Creating boxes is discussed in Section 8.8.2.

Rounded Rectangle Tool  
This tool is used to draw squares and rectangles with rounded corners. Creating rectangles with round corners is discussed in Section 8.8.2.

Oval Tool  
This tool is used to draw ovals and circles. Creating ovals and circles is discussed in Section 8.8.2.

Polygon Tool  
This tool is used to draw polygons (multi-sided objects). Creating polygons is discussed in Section 8.8.3.

Arc Tool  
This tool is used to create arcs. Creating arcs is discussed in Section 8.8.2.

Bezier Curve Tool  
This tool is used to draw Bezier curves. Creating Bezier curves is covered in Section 8.8.4.

Table Tool  
This tool is used to create tables of data. The use of this tool is covered in Section 8.2.

Eraser Tool  
The Eraser is used to delete labels and objects from the plot or layout window. Grouped items, such as the legend and axis labels, can also be removed using this tool. The Eraser cannot remove any markers or lines that represent plotted data.
Identify Tool
This tool is used to display the coordinates of points on a plot. The use of this tool is discussed in Section 8.3.

Align Tool
This tool is used to align a group of selected objects. Aligning objects is covered in Section 8.6.9.

Data Selection Tool
This tool is used to select a portion of the data on the plot for further plotting and analysis. The use of this tool is discussed in Section 8.4.

Zoom Selection Tool
This tool is used to quickly change the axis limits. The use of this tool is covered in Section 8.5.

8.1.2 Toolbox Icons
The bottom portion of the toolbox contains icons that vary according to what is currently selected. Clicking any of the icons displays a pop-up menu that can be used to quickly edit an item’s attributes, without having to choose a command or display a dialog.

When a Shape or the Legend Is Selected
The Color icon controls the foreground and background color of the selected object. The Pattern icon controls the fill and pen patterns. The Style icon sets the line style and width for selected objects. For more information on using these icons, see Section 8.9.

When the Plot Frame Is Selected
The Color icon controls the interior and background colors for the plot. The Transparency icon allows you to leave the interior or background transparent. For more information on using these icons, see Section B.4.
When an Axis Is Selected
The Color icon determines the frame and grid colors. The first of the two Axis Options icons allows you to hide the selected axis or exchange the X and Y axes. The second Axis Options icon controls axis scaling, tick mark display, grid line display, and the format of the axis labels. If the X2 or Y2 axis is selected, you can also link the axes. The interior of the icon displays which axis is currently selected. The Color icon is covered in Section B.4; the Axis Options icons are covered in Section B.2.

When a Marker Is Selected in the Legend
The Variable Color icon controls the color of the variable. The two icons in the middle control the variable markers and fill patterns. The Marker icon determines the marker type, size, and number of markers displayed. The Fill Pattern icon controls the fill pattern. The Style icon determines the variable’s line style and width. For more information on using these icons, see Section B.3.
8.2 Using the Table Tool

The Table tool is used to create tables that have up to 16 columns and 64 rows. Clicking in the plot or layout window after selecting this tool displays the dialog in Figure 8-2. Use this dialog to create and edit tables of data within your plots. For information about any of the commands in this dialog, refer to the online Help.

![Edit Table dialog](image)

Figure 8-2 Edit Table dialog

8.2.1 Creating and Editing Tables

Tables can be added to any plot or layout window in KaleidaGraph. Tables can be created by either using the Table tool or by pasting text from the Clipboard. Tables are also created to display the results of General and Polynomial curve fits when Display Equation is turned on in the Plot menu.

To create a table:

1. Select the Table tool from the toolbox.
2. Click anywhere in the plot or layout window to display the Edit Table dialog.
3. Customize the appearance of the table by adding rows, adding columns, or applying style changes. Then, type data into the cells.
4. Click OK to return to the plot or layout window. Figure 8-3 shows a sample table created with the Table tool.
To edit a table:

1. Double-click the table with the Selection Arrow. The Edit Table dialog appears, displaying the contents of the table.
2. Make the necessary changes to the table.
3. Click **OK** to return to the plot or layout window.

### 8.2.2 Setting Defaults for Tables

The Edit Table dialog initially displays four cells. In addition to being part of the table, they are used to set the default layout for generating new tables. They control the layout as follows:

- **cell 1 (upper-left):** This cell controls itself and does not affect the defaults for the rest of the table.
- **cell 2 (upper-right):** This cell controls the default settings for the top row of the table (excluding cell 1).
- **cell 3 (lower-left):** This cell controls the default settings for column one of the table (excluding cell 1).
- **cell 4 (lower-right):** This cell controls the default settings for the body of the table (everything except row one and column one).

Change the attributes (font, size, style, justification, and so on) in each of the four cells. Then, choose **File > Set Defaults** to remember the settings. Your default settings are saved as part of the Style file.
8.3 Using the Identify Tool

Use the Identify tool \( \text{∝} \) to find the coordinates of any point in the plot window. It can also be used to place the coordinates directly on the plot or the Clipboard.

**Note:** If the plot contains an axis break, the Identify tool will not display coordinates within the break or outside the axis limits.

To use the Identify tool:

1. Select the Identify tool from the toolbox.
2. Click anywhere in the plot. The coordinates are displayed in the upper-left corner of the plot window.
3. To leave the coordinates on the plot, press **Option** when releasing the mouse button. A label is placed at the current location. The appearance of the X and Y coordinate labels is based on the settings in the Axis Options dialog (**Plot** menu), with the exception of adding one extra digit of accuracy.
4. To place the coordinates on the Clipboard, press **Shift** when releasing the mouse button. The first time you do this, the Clipboard is cleared and the first set of coordinates is copied. Any additional coordinates are appended to the information already stored on the Clipboard.

**Note:** If you want to place the coordinates from multiple plots on the Clipboard, press \( \text{⌘} + \text{Shift} \) when releasing the mouse button. As soon as you use the **Shift** key without pressing \( \text{⌘} \), the Clipboard is cleared.

8.4 Using the Data Selection Tool

The Data Selection tool \( \text{≡} \) can be used to temporarily include or exclude a portion of data from the plot and curve fits. This fast, visual way of excluding outliers or selecting subsets of data allows you to quickly perform a series of what-if scenarios to help you learn more from the data and possibly even influence future directions of your research.

Using KaleidaGraph’s Data Selection tool you can either:

- Graphically exclude outliers (one or thousands).
- Graphically select (include) subsets of data to plot and fit.

The Data Selection tool operates by enclosing any points to be temporarily included or excluded in a polygon. See Sections 8.4.1 and 8.4.2 for specific directions on how to select the data.

As soon as you close the polygon:

- Any data removed from the plot will have be masked (indicated by a red frame) in the data window.
- The plot will be redrawn automatically.
- Any error bars and curve fits that were applied to the plot will be recalculated and new results, (including parameters and error values) will be displayed.
Once you are finished viewing and learning from this set of results:

- Double-click the Data Selection tool.
- The data you temporarily omitted will automatically return to the plot and will no longer be masked in the data window.
- The plot will be redrawn automatically to include the additional points.
- Any error bars and curve fits that were applied to the plot will be recalculated and new results (including parameters and error values) will be displayed.

Note: This tool cannot be used if the plot contains an axis break. It is also disabled for the following plots: High/Low, Probability, Histogram, Box, Percentile, Dot, Summary Column, Polar, Pie, and all of the plots in the Bar submenu.

### 8.4.1 Graphically Removing Outliers

To exclude a set of data points from the plot:

1. Select the Data Selection tool ( ) from the toolbox.
2. Press the Option key while performing steps 3-6.
3. Position the crosshair at the point where you want to begin forming line segments. Then, click the mouse button to begin. A small square marks the starting point.
4. Move the mouse to the point where you want the first segment of the polygon to end.
5. Move the mouse and click again to create the second segment.
6. Continue moving and clicking the mouse until the desired data is enclosed in a polygon. You can complete the polygon by clicking the hollow square, double-clicking the mouse, pressing Return, or clicking when the crosshair is positioned over the toolbox.

The plot is then redrawn and only the points that lie outside the polygon are replotted. The points that are removed become masked (indicated by a red frame) in the data window. The following figures show an example plot that contains a curve fit before and after removing some outliers.

![Figure 8-4 Removing outliers from a plot](image)

![Figure 8-5 Resulting plot](image)

7. To return to the original plot and unmask the data, double-click the Data Selection tool.
8.4.2 Graphically Selecting a Subset of Data

To select a subset of data points:

1. Select the Data Selection tool ( ) from the toolbox.
2. Position the crosshair at the point where you want to begin forming line segments. Then, click the mouse button to begin. A small square marks the starting point.
3. Move the mouse to the point where you want the first segment of the polygon to end.
4. Move the mouse and click again to create the second segment.
5. Continue moving and clicking the mouse until the desired data is enclosed in a polygon. You can complete the polygon by clicking the hollow square, double-clicking the mouse, pressing Return, or clicking when the crosshair is positioned over the toolbox.

The plot is then redrawn and only the points that lie inside the polygon are replotted. The points that are removed become masked (indicated by a red frame) in the data window. The following figures show an example plot before and after selecting a subset of the original data.

6. To return to the original plot and unmask the data, double-click the Data Selection tool.

8.5 Using the Zoom Selection Tool

Use the Zoom Selection tool ( ) to quickly change the axis limits. This is accomplished by creating a zoom box, which defines the new limits for the plot. This tool produces an effect similar to specifying axis limits in the Axis Options dialog (Plot menu).

This tool cannot be used if the plot contains an axis break. It is also disabled for the following plots: Histogram, Stack Bar, Stack Column, and Pie.
To use the Zoom Selection tool:

1. Select the Zoom Selection tool from the toolbox.
2. Drag over a region of the graph. The upper-left and lower-right corners of the box define the new limits for the plot. For Double Y, Double X, Double XY, Double Y Bar, and Double Y Column plots, you can rescale the X2 and Y2 axes by pressing when creating the zoom box. Figure 8-8 shows a sample plot with new limits being selected.

![Figure 8-8 Using the Zoom Selection tool](image)

3. Release the mouse button when the box extends to the desired limits. The plot is redrawn to the new set of limits. Figure 8-9 shows the plot after being redrawn using the new axis limits.

![Figure 8-9 Resulting plot after using the Zoom Selection tool](image)

**Note:** Double-click the Zoom Selection tool to return to the original plot.

When the plot is zoomed, you can adjust the position by pressing **Option** and clicking on an area of the plot. For Double Y, Double X, Double XY, Double Y Bar, and Double Y Column plots, you can adjust the X2 and Y2 axes by pressing **⌘** + **Option** and clicking. The point you click is placed in the center of the redrawn plot.
8.6 Working with Objects

8.6.1 Selecting and Deselecting Objects

To modify an object, it must first be selected. To select an object, position the pointer over the object and click. Object handles appear around the object.

There are three methods for selecting multiple objects:

- Press Shift and use the Selection Arrow to click the objects one at a time. Figure 8-10 shows an example of selecting objects one at a time.
- Use the Selection Arrow to drag a dotted box around the objects to be selected. Figure 8-11 shows objects being selected in this manner.
- Choose Edit > Select All to select all of the objects.

**Note:** When multiple objects are selected, changes affect each of the selected objects. For example, if you change the fill pattern, it changes in all of the selected objects.

To deselect objects:

- To deselect all selected objects, click a blank portion of the window or press Esc.
- To deselect objects one at a time, press Shift while clicking the object. The object you click is deselected. All other objects remain selected.

8.6.2 Moving Objects

After objects are created in the plot or layout window, it may be necessary to reposition them. The plot, legend, and any text labels can also be moved using the method described below.

To move objects:

1. Select the object to be moved.
2. Position the pointer over the selected object and drag it to a new position. As you drag, an outline of the object is displayed. If you drag to the edge of the window, the window scrolls.
3. Release the mouse button when the object is in the desired location. Figure 8-12 shows an example of an object being moved.

**Note:** You can also move selected objects vertically or horizontally using the arrow keys. If the arrow keys are used, the objects move one pixel in the specified direction (10 pixels if you press Shift at the same time).
8.6.3 Resizing Objects

Any object can be resized in the plot or layout window. This includes the plot axes, legend, and any shapes created with the drawing tools.

**Note:** The legend cannot be resized if it only contains a single item.

To resize an object:

1. Select the object to be resized.
2. Drag any one of the handles until the object reaches the desired size. Figure 8-13 shows an object being resized.

![Figure 8-13 Resizing an object](image)

**Note:** To resize the object proportionally about its center, press Option when dragging the handle. By pressing Shift as you drag, you can constrain the shape to a square or circle.

8.6.4 Duplicating Objects

To duplicate an object:

1. Select the object to be duplicated.
2. Choose Edit > Duplicate. A copy of the object is placed slightly below and to the right of the original. Its handles are visible to indicate that it is selected. An example of a duplicated object appears in Figure 8-14.

![Figure 8-14 Duplicating objects](image)

**Note:** You can also duplicate an object by pressing Option and dragging the object.

8.6.5 Copying Objects

To copy one or more objects:

1. Select the objects to be copied.
2. Choose Edit > Copy Selection. The objects are copied to the Clipboard, replacing the previous contents, if any.

**Note:** If you copy anything associated with the original plot (legend, plot title, axis title, and so on), the entire plot is copied to the Clipboard.
8.6.6 Pasting Objects

To paste objects from the Clipboard:

1. Open the plot or layout window which will receive the object on the Clipboard.
2. Choose Edit > Paste. The object is placed in the active window.

8.6.7 Deleting Objects

To delete an object in the plot or layout window:

1. Select the object to be deleted.
2. Press Delete or choose Cut or Clear from the Edit menu. Cut places the object on the Clipboard; the other methods remove the object from the window.

Note: You can also use the Eraser tool to delete individual objects.

8.6.8 Grouping and Ungrouping Objects

Grouping allows you to combine several objects into a single object. This is useful if you want to move several objects and maintain their relative spacing or if you want to apply the same changes to multiple objects.

To group objects:

1. Select the objects to be grouped. Object handles appear around each object that is selected, as shown in Figure 8-15.
2. Choose Object > Group. Each object’s handles disappear and are replaced by a single set of object handles around the grouped object, as shown in Figure 8-16.

Once you have grouped objects together, you can no longer select or modify the objects individually. The Ungroup command can be used to separate a grouped object into its original components.

To ungroup an object:

1. Select the object to be ungrouped.
2. Choose Object > Ungroup. Object handles appear for each individual object.
8.6.9 Aligning Objects

KaleidaGraph has two ways to align objects: the Align tool from the toolbox and the Align command (Object menu). Selecting either displays the pop-up menu in Figure 8-17. The icons in this menu indicate the type of alignment applied to the objects.

![Alignment pop-up menu](image)

Figure 8-17 Alignment pop-up menu

To align objects:

1. Select the objects to be aligned. Figure 8-18 shows some sample objects that are selected, along with a reference line.
2. Choose **Object > Align** or select the Align tool from the toolbox to display the alignment options.
3. Select one of the icons from the menu. The objects are aligned based on your selection. Figure 8-19 shows the objects after aligning them by their left edges.

![Objects before being aligned](image)

![Objects after being aligned](image)

Figure 8-18 Objects before being aligned

Figure 8-19 Objects after being aligned
8.6.10 Sending Objects Up or Down

Each time you create an object in the plot or layout window, it is placed on top of all other objects in the object stacking order. This order is important because objects near the bottom of the stack may be hidden or difficult to modify.

There are four commands in the Object menu that enable you to change the ordering of objects. These commands are: Up, Bring To Front, Down, and Send To Back. These commands are useful when objects overlap in a plot or layout.

To change the ordering of an object:

1. Select the object to be modified.
2. Choose the appropriate command from the Object menu. The selected object is repositioned in the window.
   - Up - Moves the selected object forward one level in the object order.
   - Bring To Front - Moves the selected object in front of all other objects.
   - Down - Moves the selected object backward one level in the object order.
   - Send To Back - Moves the selected object behind all other objects.

Figure 8-20 shows five stacked objects with the middle object (the oval) selected. The four figures below it show how the original objects appear after choosing each of the four commands.
8.7 Creating and Editing Text Labels

The Text tool $T$ is used to create and edit text labels. Clicking within the plot or layout window after selecting this tool displays the dialog in Figure 8-21.

![Edit String dialog](image)

Figure 8-21 Edit String dialog

8.7.1 Creating a Text Label

Text labels can be created anywhere in the plot or layout window. The initial position of the label is not important because once it is created, you can use the Selection Arrow to reposition it.

To create a text label in the plot or layout window:

1. Select the Text tool from the toolbox.
2. Position the text pointer, $\text{T}$, anywhere in the window and click. The Edit String dialog appears.
3. Type text and modify the attributes using the menus in the dialog. This dialog supports fully-stylized text, so you can use multiple fonts, styles, and colors in a text label. A maximum of 2000 characters can be entered for a single text label. Figure 8-22 shows the Edit String dialog containing a sample text string.

![Sample string in the Edit String dialog](image)

Figure 8-22 Sample string in the Edit String dialog

4. Click **OK** to return to the plot or layout window.
8.7.2 Editing Plot Labels

Legend Text
The legend text can be edited using the Text tool. Double-clicking a text label displays the Edit String dialog. Change the legend text as needed and click OK to return to the plot.

It is also possible to move items in the legend to different locations using the Text tool. This is accomplished by dragging a label to a new position with the Text tool.

Plot and Axis Titles
Plot and axis titles can be edited by double-clicking them with either the Text tool or the Selection Arrow. The Edit String dialog appears, containing the current text string. Change the text as needed and click OK to return to the plot.

Value and Axis Labels
Value and axis labels are unique because they can be edited individually or as a group.

To edit value or axis labels individually:
1. Select the Text tool from the toolbox.
2. Double-click the label to be modified. The label appears in the Edit String dialog.
3. Change the label text and formatting.
4. Click OK to return to the plot.

Note: Be careful when editing value and axis labels in this manner. If the plot is redrawn, the labels revert to their original state.

To edit value or axis labels as a group:
1. Select the Selection Arrow from the toolbox.
2. Double-click one of the labels in the group. The label appears in the Edit String dialog, but the label text cannot be edited because the labels are selected as a group.
3. Make the necessary formatting changes to the label.
4. Click OK to return to the plot. The entire group is redrawn to reflect the changes.

Individual Text Labels
Any text label created with the Text tool can be edited by double-clicking it with either the Text tool or the Selection Arrow. The Edit String dialog appears, containing the current text string. Change the text as needed and click OK to return to the plot.
8.7.3 Adding Subscripts or Superscripts to a Text Label

To add subscripts or superscripts to a label:

1. Using the Text tool, double-click an existing label or click within the plot or layout window to create a new label.
2. Select the text to be converted.
3. Choose Subscript or Superscript from the Style menu.
4. Click OK.

Note: The Edit String dialog does not display characters as subscripts or superscripts. Instead, KaleidaGraph inserts either \d (subscript) or \u (superscript) before the characters and \n (normal) after the characters. These extra characters are only displayed in the Edit String dialog. As soon as you return to the plot, the subscripts or superscripts are displayed correctly.

The Text Options dialog (Plot menu) contains four settings (Superscript Offset, Subscript Offset, Sub/Super Size, and Only use built-in sizes) that affect the appearance of subscripts and superscripts. These settings can be modified to control the offset and size of these characters.

8.7.4 Adding Special Characters to a Text Label

There may be times that you will want to add a special character or symbol to your text label. These characters can be found using a utility that is provided with the operating system.

To view the keyboard layout for a given font:

1. Go to System Preferences > International > Input Menu and enable Keyboard Viewer. Also make sure Show input menu in menu bar (at the bottom) is enabled.
2. Click the International icon (flag) in the menu bar.
3. Choose Show Keyboard Viewer.

You now have access to all of your active fonts and what they look like according to your keyboard layout. Everything changes dynamically as you hold various keys such as shift, control, option, etc.

8.7.5 Setting Defaults for Text Labels

You can set defaults for a number of different text labels in the Text Options dialog (Plot menu). The attributes that you select are saved as part of the Style file. This enables you to set your preferences and have KaleidaGraph remember them the next time you start the program.
To set defaults for text labels:

1. Choose **Plot > Text Options** to display the dialog in Figure 8-23.

![Text Options dialog](image)

**Figure 8-23  Text Options dialog**

2. Click the labels for which you want to set new defaults. The different text labels are described below:
   - **Standard Labels** - Axis titles and any text created with the Text tool.
   - **Legends** - Any text that appears in the legend.
   - **Plot Titles** - The text representing the plot’s title.
   - **Equation Labels** - Text that appears when displaying the equation calculated by a curve fit.
   - **Value Labels** - Text that appears when **Add Values** is turned on or text error bars are applied.
   - **X, Y, X2, or Y2 Axis Labels** - The labels placed at major tick marks to display their value.
   - **Y2 Legend** - Text that appears in the Y2 legend of a Double Y, Double XY, Double Y Bar, or Double Y Column plot.

3. Select your new defaults from the pop-up menus.
4. Click **OK** to return to the plot window. Any labels that had their attributes changed are updated.
5. To make these settings permanent, make sure you save changes to the Style when quitting KaleidaGraph.
8.8 Creating and Editing Shapes

You can create lines, arrows, rectangles, rounded rectangles, ovals, polygons, arcs, and Bezier curves in
the plot or layout window. Once a shape is created, you can use the icons in the toolbox to change the
object’s attributes. This topic is covered in Section 8.9.

8.8.1 Lines and Arrows

To create a line or arrow:

1. Click the Line tool on the toolbox.
2. Click the Line tool again and hold down the mouse button
to display the pop-up menu in Figure 8-24. Choose the first
item in this menu to draw a line or select the type of arrow
you want to create.
3. Position the crosshair at the point where you want to begin
drawing the line. When creating an arrow, the arrowhead is
placed at this position.
4. Drag to draw the line. By pressing Shift as you drag, you
can constrain the line to rotate in 45° increments.
5. Release the mouse button when the line is the desired
length. The line appears with object handles to indicate that
it is selected.

Figure 8-25  Drawing a line

To edit a line or arrow:

1. Select the line or arrow with the Selection Arrow. Object handles appear at the ends of the line.
2. Position the pointer over one of the handles.
3. Drag the handle to adjust the length or angle of the line.
4. You can change the arrowhead type by selecting a different arrow from the pop-up menu. You
can switch the ends of the arrow by choosing Reverse from the menu.
5. When you are finished, click away from the line to deselect it.
To edit an arrowhead:

1. Double-click the arrow (or click once and choose Object > Edit Object) to display the dialog in Figure 8-26.

![Arrow Head dialog](image)

Figure 8-26  Arrow Head dialog

2. Edit the values in the dialog until the arrowhead in the preview window looks the way you want it.

3. Click OK to update the arrow.

**Note:** If you want to modify the default set of arrowheads, use the Edit Arrow Heads command (Object menu).

### 8.8.2 Rectangles, Rounded Rectangles, Ovals, and Arcs

To create a rectangle, rounded rectangle, oval, or arc:

1. Select the Box, Rounded Rectangle, Oval, or Arc tool from the toolbox.
2. Position the crosshair at the point where you want to begin drawing.
3. Drag to draw the shape. Depending on the object being created, you can constrain its shape to a square, circle, or quarter-circle by pressing Shift as you drag.
4. Release the mouse button when the dotted outline of the object is the desired size. The shape appears with object handles to indicate that it is selected.

![Drawing a rectangle](image) ![Drawing a square](image)

Figure 8-27  Drawing a rectangle  Figure 8-28  Drawing a square

To edit a rectangle, rounded rectangle, oval, or arc:

1. Select the shape with the Selection Arrow. Object handles appear at the corners of the area occupied by the shape.
2. Drag any one of the handles until the object reaches the desired size.
3. When you are finished, click away from the shape to deselect it.
8.8.3 Polygons

The Polygon tool is used to create polygons. Polygons consist of multiple line segments connected at the segment end points. They can either be closed (the first and last segments connect) or open (the first and last segments do not connect).

To create a polygon:

1. Select the Polygon tool [Polygon] from the toolbox.
2. Position the crosshair at the point where you want to begin drawing. Then, click the mouse button to begin drawing. A small square marks the starting point.
3. Move the mouse to where you want the first segment of the polygon to end. By pressing **Shift** as you click, you can constrain the segment to rotate in 45° increments.
4. Move the mouse and click again to create the second segment.
5. Continue moving and clicking the mouse until the desired number of segments are created. You can close the polygon by clicking the hollow square. To leave the polygon open, double-click the mouse, press **Return**, or position the crosshair over the toolbox and click.

![Figure 8-29 Creating a polygon](image)

To edit the segment points of the polygon:

1. Double-click the polygon (or click once and choose **Object > Edit Object**). The four object handles disappear and are replaced by handles at each segment point of the polygon.
2. Drag any one of the segment points until the polygon reaches the desired size.
3. When you are finished editing, click outside of the polygon to deselect it.
8.8.4 Bezier Curves

The Bezier curve tool can be used to draw complex objects. Bezier curves are irregularly shaped, multi-sided objects that can have curved line segments. They can either be closed (the first and last segments connect) or open (the first and last segments do not connect).

Each segment in a Bezier curve is defined by four points: two anchor points and two direction points. The anchor points determine where the segments begin and end. The direction points, along with the tangent lines that connect them to the anchor points, determine the size and positioning of the curve segments.

Creating a Bezier Curve

To create a Bezier curve:

1. Select the Bezier curve tool from the toolbox.
2. Position the crosshair at the point where you want to begin drawing and click the mouse.
3. Move the mouse until the crosshair is where you want the first segment to end.
4. Click and hold the mouse button down. If you release the button, a straight line appears between the points. If you hold down the button and drag, a tangent line appears that allows you to drag the curve into the position you want.
5. Release the mouse button when the segment is the desired shape. The tangent line disappears and handles appear at the anchor points.
6. Continue creating more segments and setting the angle and shape of the curve with the tangent lines. The segments are automatically connected.
7. You can close the curve by clicking the hollow square. To leave the curve open, double-click the mouse, press Return, or position the crosshair over the toolbox and click.
**Editing a Bezier Curve**

You can change the position of each anchor point and the shape of each curve. If a segment is straight, there is no tangent line and you can only change its position. Segments can be deleted by selecting an anchor point and pressing **Delete**.

To edit a Bezier curve:

1. Double-click the curve (or click once and choose **Object > Edit Object**). The four object handles disappear and are replaced by handles at each anchor point of the curve.
2. Position the arrow over each anchor point you want to move and drag until the point is in the desired position.
3. Release the mouse button. The tangent line is displayed with round handles at each direction point. You can drag these handles to control the size and shape of the curves.
4. Select either of the direction points and drag to edit the shape of the curve. The curve is reshaped in the direction you move the handle.
5. Continue moving anchor points and reshaping curves until the curve is the desired shape.
6. When you are finished editing, click outside of the curve to deselect it.

![Figure 8-32  Editing a Bezier curve](image)

**8.9 Adding Colors and Patterns to Shapes**

The area beneath the tools on the toolbox contains several icons that are used to set and modify the attributes of an object. These attributes include: foreground color, background color, fill pattern, pen pattern, line style, and line width. Using these icons, you can control the appearance of any object in the plot or layout window.

**8.9.1 Setting Default Attributes for Shapes**

Attributes for objects drawn in the plot or layout window are controlled using the icons shown in Figure 8-33. If no objects are selected in the window, you can set default attributes. These attributes are applied to any new shapes created in KaleidaGraph.

![Figure 8-33  Object attribute icons](image)
To set the default attributes:

1. Verify that no items are selected in the plot or layout window.
2. Make selections for the foreground color, background color, fill pattern, pen pattern, line style, and line width. The following sections explain how to make selections for each.

The attributes that you select are saved as part of the Style file. This enables you to set your preferences and have KaleidaGraph remember them the next time you start the program.

### 8.9.2 Changing Foreground and Background Colors

The Color icon consists of two sections: a foreground section (upper-left) for setting the foreground color and a background section (lower-right) for setting the background color. When you select a fill or pen pattern, the foreground color is applied to the black portion of the pattern and the background color is applied to the white portion of the pattern.

**Note:** To edit the colors that appear in the color palettes, use the **Edit Colors** command (Object menu).

To change the foreground or background color of an object:

1. Select the object to be edited.
2. Click the foreground or background section of the Color icon. One of the following color palettes appears with the current color choices.

   ![Foreground Color palette](image1)
   ![Background Color palette](image2)

3. Select a different color from the palette.
8.9.3 Changing Fill and Pen Patterns

The fill pattern is used to represent the interior of an object. The pen pattern is used to represent object lines. You can change the fill or pen pattern by selecting a different pattern from the pop-up menu that appears when you click the appropriate portion of the Pattern icon. Black portions of the pattern represent the foreground color and white portions represent the background color.

To change the fill or pen pattern of an object:

1. Select the object to be edited.
2. Click the interior or outer portion of the Pattern icon. One of the following pop-up menus appears with the pattern choices.

![Fill pattern choices](image)

Figure 8-36 Fill pattern choices

![Pen pattern choices](image)

Figure 8-37 Pen pattern choices

3. Select a different pattern from the pop-up menu.

8.9.4 Changing Line Styles and Widths

The Style icon controls the line styles and widths used for objects. The left portion of the icon controls the line style; the right portion controls the line width.

To change the line style or line width of an object:

1. Select the object to be edited.
2. Click the line style or line width section of the Style icon. One of the following pop-up menus appears with the available choices.

![Line style menu](image)

Figure 8-38 Line style menu

![Line width menu](image)

Figure 8-39 Line width menu

3. Select a different line style or thickness from the pop-up menu.
This chapter covers:

- The types of curve fits available in KaleidaGraph.
- Applying a Least Squares curve fit.
- Applying a smoothing curve fit.
- Defining and applying a General (user-defined) curve fit.
- Displaying the results of a curve fit.
- Removing a curve fit from a plot.
- Extrapolating curve fits to the axis limits.
- Adding error bars to a plot.

### 9.1 Purpose of Curve Fitting

Curve fitting, also known as regression analysis, is used to find the "best fit" line or curve for a series of data points. Most of the time, the curve fit will produce an equation that can be used to find points anywhere along the curve. In some cases, you may not be concerned about finding an equation. Instead, you may just want to use a curve fit to smooth the data and improve the appearance of your plot. KaleidaGraph provides curve fits that can be used in both of these scenarios.
9.2 Types of Curve Fits

This section provides a brief description and lists the data restrictions for each of the curve fits supported by KaleidaGraph. Refer to Section C.5 for reference information for each of the curve fits.

9.2.1 General

This is the most powerful curve fit in KaleidaGraph. It takes a user-defined equation and uses it to fit a set of plotted data. Any function of \( x \) or \( m_0 \), where either \( x \) or \( m_0 \) is the independent variable, can be defined using up to nine parameters (\( m_1 \sim m_9 \)).

Examples:

\[
\begin{align*}
m_1 & \times m_0 \\
m_1 & + m_2 \times m_0 \\
m_1 & \times \exp(-m_2 \times m_0)
\end{align*}
\]

When a General curve fit is selected, a curve, defined by the equation in the Curve Fit Definition dialog, is fitted to the data using the Levenberg-Marquardt algorithm. There are no data restrictions associated with this curve fit.

For more information on the General curve fit, refer to Sections 9.6–9.7. These sections include details about equation structure, initial guesses, and weighting data.

9.2.2 Linear

This function fits a straight line through your data, of the form \( y = m_0 + m_1 \times x \). There are no data restrictions associated with this curve fit.

**Note:** On a semi-log or log-log plot, this fit appears as a curved line.

9.2.3 Polynomial

This function fits a curve through your data, of the form \( y = m_0 + m_1 \times x + m_2 \times x^2 + m_3 \times x^3 + \ldots + m_9 \times x^9 \). The more complex the curvature of the data, the higher the polynomial order required to fit it. There are no data restrictions associated with this curve fit.

9.2.4 Exponential

This function fits a curve through your data, of the form \( y = m_0 \times e^{m_1 \times x} \). It is generally used to fit data that increases or decreases at a high rate. This curve fit cannot fit negative data or data equal to zero.

**Note:** On a semi-log plot with a linear X axis, the curve appears as a straight line.

9.2.5 Logarithmic

This function fits a curve through your data, of the form \( y = m_0 + m_1 \times \log(x) \). A logarithmic curve fit is generally used with data that spans decades (\( 10^0, 10^1, 10^2 \), and so on). This curve fit cannot be used to fit negative data or data equal to zero.

**Note:** On a semi-log plot with a linear Y axis, the curve appears as a straight line.
9.2.6 Power
This function fits a curve through your data, of the form \( y = m_0 \times x^{m_1} \). This curve fit cannot be used to fit negative data or data equal to zero.

Note: On a log-log plot, the curve appears as a straight line.

9.2.7 Smooth
This function fits a smoothed curve to the data. KaleidaGraph starts by applying a Stineman function to the data. The output of this function then has a geometric weight applied to the current point and ±10% of the data range, to arrive at the smoothed curve.

The only data restriction associated with this curve fit is that the independent (X) variable must be in ascending order in the data window. There is no single expression that represents this curve; therefore, there are no parameters to view or copy.

9.2.8 Weighted
This function fits a curve to the data, using the locally weighted Least Squared error method. The result of this curve fit is to plot a best fit smooth curve through the center of the data. This is an extremely robust fitting technique. Unlike the standard Least Squared error method, this technique is nearly insensitive to outliers. However, this does not come for free. The Weighted curve fit is computationally complex and can take longer to compute for a large data set.

The only data restriction associated with this curve fit is that the independent (X) variable must be in ascending order in the data window. There is no single expression that represents this curve; therefore, there are no parameters to view or copy.

9.2.9 Cubic Spline
Moving left to right along the curve in increasing X, every group of four consecutive data points defines a cubic polynomial equation. A series of these cubic polynomials connected together define a cubic spline curve. Using this curve fit is similar to using a French curve to connect all of the data points.

The only data restriction associated with this curve fit is that the independent (X) variable must be in ascending order in the data window. There is no single expression that represents this curve; therefore, there are no parameters to view or copy.

9.2.10 Interpolate
This function fits a curve that passes through the data points and matches the slopes at those points. The advantage of this curve fit is that it does not produce wild results near an abrupt change of slope, as can happen with the Cubic Spline curve fit.

The only data restriction associated with this curve fit is that the independent (X) variable must be in ascending order in the data window. There is no single expression that represents this curve; therefore, there are no parameters to view or copy.
Since KaleidaGraph provides a number of different curve fit types and over 100 General curve fit equations, choosing a model for a particular data set can be a difficult task. When you are deciding on a curve fit model, it helps to know some of the underlying properties associated with the data to make an educated decision on which model to use.

Depending on your field of study, you may find that certain equations or families of equations are used on a regular basis. For example, Sigmoidal curves are normally used to fit dose response data and Hyperbolic functions are normally used to fit ligand binding data in the field of enzyme kinetics.

If you do not know what type of curve fit to use, you may be able to ask a colleague or do some research to see what curve fits are normally used with the type of data that you have collected. If that proves to be fruitless or if nothing is known about the data, then the selection of the model must be based on the raw data.

You can use a Scatter plot to plot the data and see the general shape of the curve. The following figures provide a glimpse of the general shape associated with some of the more common families of General curve fits that are used in KaleidaGraph. Within each family, KaleidaGraph provides a number of different curve fit equations and it may take some trial and error to find the equation that produces the best results.

**General Shape of Various Curve Fit Families**

- Peak
- Sigmoidal
- Hyperbola
- Exponential Rise
- Exponential Growth
- Exponential Decay
- Power
- Waveform
9.4 Applying a Least Squares Fit

Least Squares is a method of curve fitting that has been popular for a long time. Least Squares minimizes the square of the error between the original data and the values predicted by the equation. While this technique may not be the most statistically robust method of fitting a function to a data set, it has the advantage of being relatively simple (in terms of required computing power) and of being well understood.

The major weakness of the Least Squared method is its sensitivity to outliers in the data. If a data point is widely different from the majority of the data, it can skew the results of the regression. For this reason, the data should always be examined for reasonableness before fitting. The Data Selection tool provides a simple method of removing outliers from a plot. The use of this tool is covered in Section 8.4.

The Curve Fit menu contains several curve fits that use the Least Squares method. These curve fits are: Linear, Polynomial, Exponential, Logarithmic, and Power. For descriptions and any data restrictions associated with these curve fits, see Sections 9.2.2–9.2.6.

The following steps explain how to apply a Least Squares fit, using the Polynomial curve fit as an example. The procedure is basically the same for applying the other Least Square fits.

To apply a Polynomial curve fit:

1. Open the plot window which will have the curve fit applied. Figure 9-1 shows a sample plot.

![Figure 9-1 Sample plot](image)

2. Choose **Curve Fit > Polynomial**. A Curve Fit Selections dialog similar to Figure 9-2 appears. All dependent variables are listed under **Column Names**.

![Figure 9-2 Curve Fit Selections dialog](image)
3. Click the check box for each variable to be fit. A keyboard shortcut (⌘ + A) is available to select all of the variables at once. Each time a variable is selected, a second dialog appears (Figure 9-3). Use this dialog to specify the order of the polynomial to be fit. The maximum value that can be selected is nine.

**Note:** This extra dialog is only displayed when using the Polynomial fit.

![Figure 9-3 Polynomial Order dialog](image)

4. Click **OK** to exit each dialog and apply the curve fit.

After the curve fit is applied, you can display its equation or extrapolate the fit to the axis limits. These are a few of the features covered in Sections 9.8–9.10. Figure 9-4 shows the sample plot after applying a Polynomial curve fit (represented by the dashed line) and displaying the equation.

![Figure 9-4 Sample plot with Polynomial curve fit applied](image)

### 9.5 Applying a Smoothing Fit

The smoothing fits in KaleidaGraph are different from the other two types of fits in that these curve fits do not generate an equation for the resulting curve. This is because there is no single equation that can be used to represent the curve. These curve fits are useful when you just want to improve the appearance of the plot by drawing a smooth curve through the data.

The **Curve Fit** menu contains four commands designed to fit a smooth curve to the data. These curve fits are: Smooth, Weighted, Cubic Spline, and Interpolate. For descriptions and any data restrictions associated with these curve fits, see Sections 9.2.7–9.2.10.

The following steps explain how to apply a smoothing fit, using the Cubic Spline curve fit as an example. The procedure is basically the same for applying the other smoothing fits.

To apply a Cubic Spline curve fit:

1. Open the plot window which will have the curve fit applied. Figure 9-5 shows a sample plot.
2. Choose **Curve Fit > Cubic Spline**. A Curve Fit Selections dialog similar to Figure 9-6 appears. All dependent variables are listed under **Column Names**.

![Curve Fit Selections dialog](image)

3. Click the check box for each variable to be fit. A keyboard shortcut (\(\text{Alt} + \text{A}\)) is available to select all of the variables at once.

   **Note:** When applying a Weighted fit, a second dialog appears each time a variable is selected. Use this dialog to specify the smoothing factor.

4. Click **OK** to apply the curve fit.

   After the curve fit is applied, you can increase the number of curve fit points or hide the original data to only display the curve fit. These are a few of the features covered in Sections 9.8–9.10. Figure 9-7 shows the sample plot after applying a Cubic Spline curve fit (represented by the solid line).

![Sample plot](image)
9.6 General Curve Fit Basics

Nonlinear curve fitting is accommodated in KaleidaGraph through the General curve fit function. Using this function, you can define your own equation or choose one from our library of over 100 curve fit definitions. This is the most powerful fitting option in KaleidaGraph because you can specify virtually any equation to be fitted to the data.

The General curve fit is based on the Levenberg-Marquardt algorithm and is calculated using an iterative procedure. KaleidaGraph starts with the initial guesses for the unknown parameters that were supplied with the equation. It then calculates a Chi Square value that represents the sum of the squared error between the original data and the calculated fit. During each iteration, KaleidaGraph varies the parameter values slightly and re-evaluates Chi Square until it finds the best fit.

This section explains the structure of the curve fit equation, setting initial conditions for the parameters, the Curve Fit Definition dialog, and the use of the commands in the General submenu.

9.6.1 Curve Fit Definition

The curve fit definition is the equation that is fitted to the data. Curve fit definitions are composed of the same items as formulas in Formula Entry: operators, parameters, functions, and constants, in addition to an independent variable. When entering the curve fit definition, follow these guidelines:

- The independent variable in an equation is represented by m0.
- The parameters being calculated by the fit are represented by m1–m9. Parameters should be entered wherever you have an unknown quantity and you want KaleidaGraph to calculate the best value.
- Use an asterisk (*) for multiplication and a caret (^) for raising quantities to a power.
- KaleidaGraph does not distinguish between upper and lower case letters (m0 and M0 are the same).
- Constants and other shorthand references can be defined in the library for use in a curve fit definition. Some definitions in the default library are used to substitute x for m0, and a, b, c, and d for m1, m2, m3, and m4, respectively. Section 13.6 provides an example of defining a curve fit equation in the library.
- To include a column number as part of the curve fit definition, the table function must be used. Section 9.7.5 shows how to use the table function in a General curve fit definition. This method also enables you to fit equations containing multiple independent variables.

The following table lists some equations and how they appear as curve fit definitions in KaleidaGraph.

<table>
<thead>
<tr>
<th>Original Equations</th>
<th>Curve Fit Definitions</th>
</tr>
</thead>
<tbody>
<tr>
<td>a * x + b</td>
<td>m1 * m0 + m2</td>
</tr>
<tr>
<td>a + b * x^c</td>
<td>m1 + m2 * m0^m3</td>
</tr>
<tr>
<td>a + b * exp(–c * x)</td>
<td>m1 + m2 * exp(–m3 * m0)</td>
</tr>
<tr>
<td>a * exp(–b * x) * cos(c * x + d)</td>
<td>m1 * exp(–m2 * m0) * cos(m3 * m0 + m4)</td>
</tr>
</tbody>
</table>
9.6.2 Initial Conditions

Even though KaleidaGraph calculates values for unknown parameters, you must supply an initial value for each parameter. The algorithm used to calculate the final results requires a reasonable guess to point it in the right direction. KaleidaGraph improves upon these values during each iteration of the fit.

**Note:** Since the fit starts with initial guesses and improves upon them with each iteration, the final values may be different for a separate set of initial guesses.

Do not get carried away trying to find good guesses; the initial conditions are just that, guesses. If you are not sure what the guesses should be, keep the initial conditions non-zero, and at the correct order of magnitude that you might expect (be it 0.001, 1, or 1000).

The initial conditions are entered immediately following the curve fit definition. Place a semicolon at the end of the definition and begin entering the initial guesses, separating each with a semicolon. The table below shows the definitions from the previous section with some sample initial guesses.

<table>
<thead>
<tr>
<th>Curve Fit Definitions with Initial Guesses</th>
</tr>
</thead>
<tbody>
<tr>
<td>m1 * m0 + m2; m1 = 0.5; m2 = 23</td>
</tr>
<tr>
<td>m1 + m2 * m0^m3; m1 = -2; m2 = 3; m3 = 2</td>
</tr>
<tr>
<td>m1 + m2 * exp(-m3 * m0); m1 = 5; m2 = 1; m3 = 0.5</td>
</tr>
<tr>
<td>m1 * exp(-m2 * m0) * cos(m3 * m0 + m4); m1 = 4; m2 = 0.7; m3 = 2.2; m4 = 15</td>
</tr>
</tbody>
</table>

9.6.3 Curve Fit Definition Dialog

The Curve Fit Definition dialog, shown in Figure 9-8, is used to enter the equation, initial guesses, and allowable error to be used in the curve fit. You can also choose to specify partial derivatives or to weight the data.

![General Curve Fit Definition](image)

Figure 9-8 Curve Fit Definition dialog

This dialog can be displayed using either of the following methods:

- Choose a curve fit from the **General** submenu (Curve Fit menu). In the dialog that is displayed, click **Define**.

- Choose **Curve Fit > Edit General**. In the dialog that is displayed, select the name of a curve fit and click **Edit**.

For more information on the settings in the Curve Fit Definition dialog, refer to the online Help.
9.6.4 Managing the Curve Fit List

KaleidaGraph maintains a master list of curve fits in the General submenu. This submenu can store up to 16 user-defined equations that can be applied whenever a new plot is created. The following sections explain how to edit and save changes to the curve fits listed in the General submenu.

**Note:** The only way to edit the master list is to create a new plot and use the Edit General command. The master list is not affected if you do either of the following:
- Use a saved plot (or any plot that had its data archived).
- Choose a curve fit from the General submenu and click Define to edit the definition.

Adding a Curve Fit to the Master List

To add a curve fit to the master curve fit list:

1. Create a new plot.
2. Choose Curve Fit > General > Edit General.
3. Select a fit in the current list.
4. Click Add and a New Fit appears below the selected fit in the list. The name of the fit can be changed by selecting it and editing the name in the text field.
5. Click Edit to enter the definition in the Curve Fit Definition dialog.
6. Click OK when you are finished. Now you can use this fit in the active plot or any new plots that are created. Remember to save changes to the Macros file to make the changes permanent.

Rearranging the Master Curve Fit List

To rearrange the curve fit list:

1. Create a new plot.
2. Choose Curve Fit > General > Edit General.
3. Select the curve fit to be repositioned.
4. Click Copy to copy the fit to the trash bin.
5. Click Remove to delete the name from the listing.
6. Select a curve fit in the current list.
7. Select the name of the curve fit that was copied to the trash bin.
8. Click Add and the curve fit appears below the selected fit in the list.

**Note:** When rearranging curve fits, do not leave the Edit General dialog until you are completely finished. As soon as you click OK or Cancel in this dialog, anything in the trash bin is deleted. The only permanent trash bin item is New Fit.
Removing a Curve Fit from the Master List
To remove a curve fit from the master list:
1. Create a new plot.
2. Choose Curve Fit > General > Edit General.
3. Select the curve fit to be deleted.
4. Click Remove to delete the curve fit from the listing.
5. Click OK.

Adding Curve Fits from the Master List to Saved Plots
When a saved plot is opened, the General submenu displays the curve fits that were available when the plot was originally created, regardless of what is currently in the master list. To add curve fits from the master curve fit list to a saved plot:
1. Open a saved plot.
2. Choose Curve Fit > General > Edit General. The curve fits stored in the master list appear below the dotted line in the trash bin.
3. Select the name of the curve fit to be added from the trash bin listing.
4. Select a fit in the current list.
5. Click Add and the curve fit appears below the selected fit in the list.
6. Click OK when you are finished. Now you can use this fit in the saved plot.

Saving Changes to the Curve Fit Menu
The curve fits in the General submenu are saved, by default, in a file called KG Macros. This file is loaded each time you start KaleidaGraph.

To save any changes made to the Curve Fit menu, it is necessary to save the changes to the default Macros file using one of the following methods:

- In the Preferences dialog, click the File Settings tab and select Prompt from the Macros pop-up menu. When exiting KaleidaGraph, a dialog asks whether or not to overwrite the Macros file that was opened at launch.
- In the Preferences dialog, click the File Settings tab and select Always from the Macros pop-up menu. When exiting KaleidaGraph, the Macros file that was opened at launch is automatically overwritten.
- Choose File > Export > Macros and overwrite the default Macros file.

Note: Only changes made to a new plot using the Edit General command are saved as part of the macros file. Any changes made to a saved plot or by choosing a curve fit from the General submenu and clicking Define apply solely to that particular plot.

9.7 Using the General Curve Fit
This section explains how to define and apply a General curve fit equation. Other topics include weighting data, limiting parameters, and defining equations in the library. If you are new to using the General curve fit, refer to Section 9.6 which covers some basic concepts, including equation structure, initial conditions, the Curve Fit Definition dialog, and managing the curve fit list in the General submenu.
### 9.7.1 Using the Predefined Curve Fit Definitions

KaleidaGraph includes over 100 curve fit definitions that are divided into several categories (Polynomial, Logarithmic, Sigmoidal, and so on). These curve fit definitions are provided in the following formats for use in KaleidaGraph:

- Each curve fit definition is stored as a text file in the Curve Fits folder.
- Each category of definitions is stored as a Macros file that can be imported to load the definitions into the General submenu.
- Each category of definitions is stored as a text file for use in the Library.

**Importing Definitions from a Text File**

The Curve Fits folder contains each curve fit definition as a text file. This allows you to import specific curve fit definitions for use in KaleidaGraph.

To load a text file containing a curve fit definition (and have it available for all future plots):

1. Create a new plot.
2. Choose Curve Fit > General > Edit General. The dialog in Figure 9-9 appears.

![Figure 9-9 Edit General dialog](image)

3. Select a fit in the current list.
4. Click Add and a New Fit appears below the selected fit in the list. The name of the fit can be changed by selecting it and editing the name in the text field.
5. Click Edit to display the Curve Fit Definition dialog.
6. Click File in the Curve Fit Definition dialog. A text editor appears.
7. Choose File > Open.
8. Locate and open a curve fit definition from the Curve Fits folder. The definition and initial guesses for the parameters will be displayed in the editor.
9. Choose File > Close to display the curve fit equation in the Curve Fit Definition dialog. Make sure you change the initial guesses, because all of the initial guesses are set equal to 1.0 by default.
10. Click OK until you return to the plot window. Now you can use this fit in the active plot or any new plots that are created. Remember to save changes to the Macros file to make the changes permanent.
Importing Definitions from a Macros File

The **Macros** folder contains a Macros file for each category of curve fit definitions. Importing one of these Macros files loads the curve fit definitions into the **General** submenu.

**Note:** If a plot is already open, you will not see the imported curve fit definitions until a new plot is created.

To load the definitions from a Macros file:

1. Choose **File > Open**.
2. Locate and open the Macros file of interest from the **Macros** folder.
3. Create a new plot. The curve fit definitions stored in the Macros file will be listed under the **General** submenu.
4. You can now apply one of these fits to your data. Make sure you change the initial guesses, because all of the initial guesses are set equal to 1.0 by default.

Importing Definitions into the Library

The **Library** folder contains text files for each category of curve fit definitions. These text files can be loaded into the library for use in the General curve fit.

To load a text file into the library:

1. Choose **Macros > Library** or **Curve Fit > General > Library**.
2. Choose **File > Open**.
3. Locate and open the curve fit category of interest from the Library folder.
4. Browse through the library and make note of the shorthand reference and number of unknowns for the curve fits that you will be using.
5. Choose **File > Close**.

You can now use these library definitions to apply a General curve fit. When entering the definition in the Curve Fit Definition dialog, you can enter the shorthand reference defined in the library with the initial guesses, for example `gaussfit(1,5,1,10)`. KaleidaGraph will perform the necessary substitutions before applying the fit.
9.7.2 Entering a Custom Curve Fit Definition

If you need to use a curve fit equation that is not included with the predefined equations, you can easily enter a custom equation and use it in KaleidaGraph.

**Note:** Custom curve fit equations can also be defined in the library. Refer to Section 13.6 for more information on this topic.

To create a custom curve fit definition (and have it available for all future plots):

1. Create a new plot.
2. Choose **Curve Fit > General > Edit General**.
3. Select a fit in the current list.
4. Click **Add** and a **New Fit** appears below the selected fit in the list. The name of the fit can be changed by selecting it and editing the name in the text field.
5. Click **Edit** to display the Curve Fit Definition dialog.
6. Enter the curve fit equation in the Curve Fit Definition dialog. Make sure you include the initial guesses for each of the unknown parameters. Figure 9-10 shows an example curve fit equation and its initial guesses.

![Figure 9-10 Example curve fit equation](image)

7. Click **OK** until you return to the plot window. Now you can use this fit in the active plot or any new plots that are created. Remember to save changes to the Macros file to make the changes permanent.
9.7.3 Applying a General Curve Fit

To apply a General curve fit:

1. Open the plot window which will have the curve fit applied. Figure 9-11 shows a sample plot.

![Figure 9-11 Sample plot](image)

2. Choose a curve fit from the **General** submenu (**Curve Fit** menu). A Curve Fit Selections dialog similar to Figure 9-12 appears. All dependent variables are listed under **Column Names**.

![Figure 9-12 Curve Fit Selections dialog](image)

3. If the equation has not been entered, click **Define** to enter the equation or shorthand reference to be applied to the data. Figure 9-13 shows the Curve Fit Definition dialog containing a curve fit definition. When you are finished, click **OK**.

**Note:** For information on including this fit in your master curve fit list, refer to Section 9.6.4.
4. Click the check box of each variable to be fit. Typing $+A$ selects all of the variables at once.

5. Click OK to apply the curve fit. A status dialog will show the progress of the curve fit. It is updated after each iteration.

**Note:** Typing $+\text{Period}$ cancels a General curve fit. The current state of the fit is calculated and the resulting curve is drawn.

When the curve fitting process is complete, the curve is drawn on the plot. Once the curve fit is applied, you can display its equation or extrapolate the fit to the axis limits. These are a few of the features covered in Sections 9.8–9.10. Figure 9-14 shows the sample plot after applying a General curve fit (represented by the dashed line) and displaying the equation.

![Data 1](image)

**Figure 9-14 Sample plot with General curve fit applied**
9.7.4 Weighting Data

The General curve fit provides an option to weight the data. When **Weight Data** is selected in the Curve Fit Definition dialog, the data is weighted during the curve fit. These weights are taken from a specified column in the data window. The weights should represent the individual error values of the fitted data.

Each weight is used internally as: 1/(weight^2). Specifying a weight less than 1.0 for a data point increases the internal weight of that point and can make the total error much larger. Weight values larger than 1.0 reduce the internal weights. When **Weight Data** is not selected, a weight value of 1.0 is used for all data points.

When the Weight Data option is selected and you choose a variable to fit, the dialog in Figure 9-15 appears. Use this dialog to select the column containing the weights for your data.

![Weighted Curve Fit](Image)

**Figure 9-15** Selecting column of weights

9.7.5 Fitting Equations with Multiple Independent Variables

Through the use of the **table** function, KaleidaGraph can fit equations containing multiple independent variables. For example, to fit an equation like \( y = a*x + b*x^2 + c \), you would enter the following curve fit definition: \( a*x + b*table(m0, x col, x2 col) + c \). You need to replace \( x col \) and \( x2 col \) with the appropriate column numbers from the data window (for example, table(m0, c0, c2)). The result of using the table function is that for each value of \( x \), the corresponding value from the \( x2 \) column is evaluated as part of the curve fit.

9.7.6 Setting Limits for Curve Fit Parameters

Limits on curve fit parameters can be set in one of two ways. The first method is to use conditional testing on the parameter. The second method is to use the **limit** function from the default library.

Suppose that a General curve fit is being defined to fit a straight line to a set of data. The equation is of the form: \( a+b*x \). In this example, you want to limit the value of \( b \) so that it is not a negative number.

In the Curve Fit Definition dialog, enter either of the following definitions:

\[
a + (b=(b<0) ? 0 : b) \times x; a=1; b=1 \quad \text{or} \quad a + (b=\text{limit}(0, 1000, b)) \times x; a=1; b=1
\]

In the first definition, a conditional test is performed to see if \( b \) is less than zero. If true, \( b \) is set to zero; if false, \( b \) is set equal to itself.

In the second definition, the limit function is used. The limit function requires that a lower and upper boundary be set for the parameter. In this case, zero and 1000 are used to bound the extremes of \( b \).

Whenever a parameter is bound in a General curve fit definition, you must specify partial derivatives. Otherwise, a **Singular Coefficient Matrix error** may occur if the parameter being limited gets pegged at a bounding point for multiple iterations.
9.7.7 The General Curve Fit and the Macro Calculator

Calculations for the General curve fit are performed in the Macro Calculator. After performing a General curve fit, the memory registers in the Macro Calculator store information about the fit. The memory registers and their contents are listed below:

- m0: R value
- m1–m9: The values of the parameters.
- m22: Chi Square value
- m23: % error term
- m24: Chi Square of the last iteration.
- m25: Number of iterations completed.
- m26: Number of parameters in the fit.

Note: Almost all memory registers, alpha registers, and program space are overwritten during the execution of a General curve fit.

9.8 Working with Curve Fit Results

This section explains how to view the results of a curve fit, interpret the values that are reported by KaleidaGraph, and export the curve fit results for further analysis.

9.8.1 Viewing Curve Fit Results

KaleidaGraph provides two methods to view the results of a curve fit. You can either display the equation on the plot or view the coefficients in a dialog.

Displaying the Curve Fit Equation

The curve fit equation can be displayed by turning on Display Equation in the Plot menu. The results from any General, Linear, Polynomial, Exponential, Logarithmic, or Power curve fits are displayed in the plot window. Not only is the resulting equation displayed, but if any updates occur to the curve fit, the equation updates automatically.

Depending on the type of curve fit, the equation is displayed in a table or as a text label. The General and Polynomial curve fits display equations in a table because the equations for these fits can be much longer than the others. The appearance of the equation can be edited by double-clicking it with the Selection Arrow.

The numeric format of the equation can be controlled using the Equation Label Format command (Plot menu). Some of the options available include number format, number of significant digits, and trailing zeros.
**Viewing Coefficients**

The other method of displaying curve fit results is to view the curve fit’s coefficients in a dialog.

To view the coefficients from the curve fit:

1. Reselect the curve fit from the **Curve Fit** menu. A Curve Fit Selections dialog similar to Figure 9-16 appears with a drop-down arrow under **View** for each variable that has a curve fit applied.

   ![Figure 9-16 Curve Fit Selections dialog](image1)

2. Click one of the drop-down arrows and choose **View Results** from the pop-up menu that appears. A dialog similar to Figure 9-17 will be displayed containing the coefficients from the curve fit.

   ![Figure 9-17 Viewing coefficients](image2)

3. To copy the coefficients to the Clipboard, click **Clipboard**. This enables you to paste the results into another window or program.

4. To copy the coefficients to the Calculator, click **Calculator**. This enables you to use the results in a Formula Entry function.

5. Click **OK** until you return to the plot window.
9.8.2 Interpreting Curve Fit Results

This section explains some of the values that are calculated when using the General, Linear, Polynomial, Exponential, Logarithmic, and Power curve fits. The correlation coefficient is calculated for each of these fits, but only the General curve fit displays the parameter errors and Chi Square value.

Correlation Coefficients

A correlation coefficient (R or $R^2$) is displayed with the curve fit’s equation and coefficients. The correlation coefficient indicates how well the calculated curve fits the original data. The equation used to calculate the correlation coefficient is listed in Section C.6.

The $R$ and $R^2$ values typically fall between 0 and 1. It is possible for a curve fit to produce a negative value for $R^2$. This occurs when the resulting curve fits the data worse than a horizontal line passing through the mean of all the Y values. This could be due to selecting the wrong curve fit or fitting data that is extremely noisy.

You can choose to display the Linear Correlation Coefficient (R) or the Coefficient of Determination ($R^2$) as part of the results. The Display $R^2$ instead of R check box in the Curve Fit Options dialog (Curve Fit menu) controls which is displayed.

Parameter Errors

The General curve fit displays a column of errors to the right of the parameter values. The errors represent the standard error values of the parameters. These values should be read as: parameter value ± error.

Chi Square Value

The General curve fit reports a Chi Square value as part of the results. This value is the sum of the squared error between the original data and the calculated curve fit. In general, the lower the Chi Square value, the better the fit. The equation used to calculate Chi Square is listed in Section C.6.

9.8.3 Exporting Curve Fit Results

Once a curve fit has been applied, the results of the fit can be exported for further analysis. The export options include copying the parameter values to the Clipboard or the Calculator, copying the values of the curve fit line into the data window, and copying the residual values into the data window.

Copying the Parameters to the Clipboard or Calculator

To copy the parameter values to the Clipboard or Calculator:

1. Reselect the curve fit from the Curve Fit menu. A Curve Fit Selections dialog similar to Figure 9-18 appears with a drop-down arrow under View for each variable that has a curve fit applied.

![Figure 9-18 Curve Fit Selections dialog](image)
2. To copy the coefficients to the Clipboard, click one of the drop-down arrows and choose **Copy Parameters to Clipboard** from the pop-up menu that appears. This enables you to paste the results into another window or program.

   **Note:** If you paste the results into the plot window, the coefficients in the table do not change if the curve fit is updated. For this reason, we recommend that you use the **Display Equation** command instead.

3. To copy the coefficients to the Calculator, click one of the drop-down arrows and choose **Copy Parameters to Calculator** from the pop-up menu that appears. This enables you to use the results in a Formula Entry function.

4. Click **OK** to return to the plot window.

   **Note:** It is also possible to copy the parameters by choosing **View Results** from the pop-up menu and clicking the **Clipboard** or **Calculator** button.

### Copying the Curve Fit Values to the Data Window

To copy the values of the curve fit line to the data window:

1. Reselete the curve fit from the **Curve Fit** menu. A Curve Fit Selections dialog similar to Figure 9-18 appears with a drop-down arrow under **View** for each variable that has a curve fit applied.

2. Click one of the drop-down arrows and choose **Copy Curve Fit to Data Window** from the pop-up menu that appears.

3. Click **OK** to return to the plot window.

KaleidaGraph will append the results after any existing data in your data window. The first column will be a series of X values. Except for the Weighted curve fit which uses the original X values, the number of X values will be equal to the number of curve fit points specified in the Curve Fit Options dialog (**Curve Fit** menu). The second column will contain the values from the curve fit at each of these locations.

**Note:** If you want to use the original X values or supply your own X values, you need to use Formula Entry to calculate the curve fit values. Section 9.8.4 provides instructions for using the curve fit functions in Formula Entry to obtain values from the curve fit.

### Copying the Residuals to the Data Window

To copy the residual values to the data window:

1. Reselete the curve fit from the **Curve Fit** menu. A Curve Fit Selections dialog similar to Figure 9-18 appears with a drop-down arrow under **View** for each variable that has a curve fit applied.

2. Click one of the drop-down arrows and choose **Copy Residuals to Data Window** from the pop-up menu that appears.

3. Click **OK** to return to the plot window.

KaleidaGraph will append the residual values after any existing data in the data window. These values represent the difference between the original Y values and the values calculated by the curve fit.
9.8.4 Using Formula Entry to Obtain Values from a Curve Fit

The Curve Fits menu in Formula Entry contains commands that can be used to analyze the values along a fitted curve. These commands enable you to find values at any point on the curve, as well as calculate the residual error between the fitted curve and the original data.

Before you can get values from a curve fit, you must first create a plot and apply a curve fit to the data. Otherwise, an error message is displayed when you try to run the formula.

Note: It is possible to get the curve fit values and residual values into the data window without using Formula Entry. See Section 9.8.3 for more information on exporting the results of a curve fit into the data window.

The following sections show how to get values from a curve fit into the data window. Figure 9-19 shows a plot with a Polynomial curve fit applied (represented by the dashed line) which will be used as an example.

![Sample plot with Polynomial fit applied](image)

Figure 9-19  Sample plot with Polynomial fit applied

**Getting Curve Fit Values into the Data Window**

The following steps explain how to use Formula Entry to obtain values from the curve fit at specific X locations. The X positions can be the original column of X values, a new column of values, or a single point along the X axis.

Note: Unless the curve fit is extrapolated to the axis limits (see Section 9.10.3), the results are only accurate if the X values lie within the original range of the data. If the values fall outside the data range, the results are linearly interpolated.
To calculate values from a curve fit:

1. Activate the data window that contains the fitted variables. Figure 9-20 shows a portion of the data used to create the sample plot.

![Figure 9-20 Data used to create sample plot](image)

2. Choose **Windows > Formula Entry**.

3. Enter the formula into the window. Figure 9-21 shows the formula for this example. The formula should be of the form $z = \text{fit}(x, y)$, where:

   - $z$ is the destination column.
   - $x$ is either a single data value or a column containing X values.
   - $y$ is the column that had the curve fit applied.
   - $\text{fit}$ is replaced by the appropriate command from the **Curve Fits** menu of Formula Entry.

![Figure 9-21 Curve fit function entered in Formula Entry](image)

4. Click **Run** to execute the formula. The destination column is filled with the values of the curve fit at the specified X values. Figure 9-22 shows the resulting data window, with the curve fit values in the third column ($C$).

![Figure 9-22 Resulting data window](image)
Note: This method uses the curve fit points originally calculated when the fit was applied. You may want to increase the number of calculated points to make the values from the fit more accurate. See Section 9.10.5 for instructions on increasing the number of curve fit points.

Using the Calculated Equation to Find Values
The most accurate method of getting values from a fit is to use the original equation and the parameters calculated by KaleidaGraph. This is not possible when a Smooth, Weighted, Cubic Spline, or Interpolate curve fit is applied to the data, because these curve fits do not result in an equation.

To calculate values using the curve fit’s equation:

1. Copy the curve fit coefficients to the Calculator. Refer to Section 9.8.3 if you are unsure of how to do this. If you applied a General curve fit, you can skip this step because the parameters are automatically stored in the Calculator.

2. Activate the data window that contains the fitted variables. Figure 9-23 shows the original data with a column containing new X values (column 2).
3. Choose **Windows > Formula Entry**.

4. Enter your formula into the window. Figure 9-24 shows the formula used to obtain values from a curve fit at designated points, where:

   \[ c3 = m0 + m1 \cdot c2 + m2 \cdot c2^2 + m3 \cdot c2^3 + m4 \cdot c2^4 + m5 \cdot c2^5 \]

   c3 is the destination column for the curve fit values.
   c2 is the column containing the new X values.
   m0–m5 are the curve fit coefficients previously copied to the Calculator.

5. Click **Run** to execute the formula. The destination column is filled with the values of the curve fit at the specified X values. Figure 9-25 shows the resulting data window, with the curve fit values in the fourth column (**D**).
Note: This method can similarly be used to calculate the X value when the Y value on the fit is known. You need to rearrange the formula so that it solves for X instead of Y.

### 9.9 Removing a Curve Fit

Curve fits can be removed from a plot in the same way that they are added. After applying a curve fit, a check mark appears next to that type of fit in the Curve Fit menu to indicate that a curve fit is applied.

To remove a curve fit from the plot:

1. From the Curve Fit menu, choose the type of curve fit to be removed. A dialog similar to Figure 9-26 is displayed containing the list of variables. The check box of each fitted variable is selected.

2. Clear any check boxes for the fits to be removed. Clicking **Deselect** clears all of the check boxes at once.

3. Click **OK** to return to the plot and remove the curve fits and any associated equations.
9.10 Other Curve Fit Features

The following sections show how to use some of the options available for curve fits. Some of these options include changing the appearance of the curve fit line and equation, extrapolating to the axis limits, and increasing the number of curve fit points.

9.10.1 Changing the Appearance of the Curve Fit Line

To change the line style, width, or color of the curve fit line:

1. With the plot window active, choose Plot > Variable Settings.
2. Select the variable to be edited.
3. Click the Curve Fit Settings tab to make changes to the curve fit line.
4. To change the line style, select a different option from the Line Style pop-up menu.
5. To change the line width, select a different option from the Line Width pop-up menu.
6. To change the color, select a different color from the Color pop-up menu.
7. Click OK to return to the plot.

Note: If you want the curve fit to use the same color as the variable, select the Link to Variable Color check box in the Curve Fit Settings tab.

9.10.2 Changing the Appearance of the Curve Fit Equation

Changing the Color

When you first apply a curve fit, the color of the curve fit equation matches the color of the curve fit line. For Polynomial and General curve fits, you can double-click the resulting table to change the color of the curve fit results. For the remaining curve fits, you must first choose Plot > Text Options and deselect the Link Text to Variable Color check box. Once this check box is cleared, you can double-click the equation and change the color of the equation.

Changing the Precision or Format of the Parameter Values

The precision of the values in the curve fit equation is controlled using the Equation Label Format command (Plot menu). This command can be used to display more significant digits in the results. It can also be used to display the results in scientific or engineering notation.
9.10.3 Extrapolating to the Axis Limits
Curve fits are normally displayed between the minimum and maximum data values plotted on the independent axis. However, you can choose to extrapolate the curve fits to the axis limits. The extrapolated portion of the fit is based on the calculated equation.

Note: It is not possible to extrapolate the Smoothing fits (Smooth, Weighted, Cubic Spline, and Interpolate) because they cannot be represented by a single equation.

To extrapolate a curve fit:
1. Choose Curve Fit > Curve Fit Options. The dialog in Figure 9-27 appears.
2. Select the Extrapolate Fit to Axis Limits check box.
3. Click OK to return to the plot. After recalculating the curve fits, the plot is redrawn to extend the curve fits to the axis limits.

9.10.4 Forcing a Linear Fit Through the Origin
By default, the slope and intercept are calculated when applying a Linear curve fit. KaleidaGraph provides an option that forces the curve fit to pass through the origin (0,0), so that only the slope of the line is calculated.

To force a Linear curve fit through the origin:
1. Choose Curve Fit > Curve Fit Options.
2. Select the Force Line fit through zero check box.
3. Click OK to return to the plot. Any Linear curve fits will be recalculated with a Y-intercept of zero, however, the R or R² value will be suppressed in the resulting equation.

9.10.5 Increasing the Number of Curve Fit Points
Any time a curve fit is applied (except for the Weighted fit), KaleidaGraph calculates a predetermined number of points along the fit. These points are used to draw the curve fit and calculate values from the fit. You may find it useful to increase the number of curve fit points when using Formula Entry to place values from the fit into the data window. This increases the accuracy of these values.

To increase the number of curve fit points:
1. Choose Curve Fit > Curve Fit Options.
2. Enter a different value in the Curve Fit Points field. A good starting point is to enter the number of points that were plotted. You may want to make this value even higher if there are a number of peaks and valleys in the data.
3. Click OK to return to the plot window and recalculate the fits.

9.10.6 Displaying Only the Curve Fit

There may be times when you are only interested in displaying the curve fit on the plot without the original data points. This can be accomplished using the Variable Settings dialog, provided the plot is not a Scatter plot.

To display only the curve fit:

1. With the plot window active, choose Plot > Variable Settings. The Variable Settings dialog appears.
2. Select the variable to be hidden. See Section 7.8.1 if you are unsure of how to do this.
3. Choose None from both the Show Markers and Line Style pop-up menus. This hides the markers and line used to represent the original data.
4. Click OK to return to the plot. The variable is hidden and only the curve fit is displayed.

9.11 Working with Error Bars

Error bars illustrate the amount of error for the plotted data. Error bars normally appear as lines extending from the data points, with caps on either end to represent the upper and lower values of the spread.

9.11.1 Adding Error Bars

To add error bars to a graph:

1. Select the plot which will have the error bars added.
2. Choose Plot > Error Bars. A dialog similar to Figure 9-28 appears. Each plotted variable is listed, with two check boxes preceding it.

   Note: If you are adding error bars to a Probability, Summary Column, Horizontal Bar, Double Y Bar, Column, or Double Y Column plot, the X Err check boxes are unavailable.

   ![Figure 9-28 Error Bar Variables dialog]

3. Click one of the check boxes for the variable to which you want to add error bars. A dialog similar to Figure 9-29 appears so that you can specify the options for this particular set of error bars.
4. Make your selections, including the color and thickness for the error bars, and click **OK**.

5. Repeat steps 3 and 4 until error bars have been selected for all of the desired variables.

6. Click **Plot** to add error bars to the variables in the plot. The plot is redrawn and the error bars are displayed. Figure 9-30 shows a sample plot containing error bars.

![Error Bar Settings dialog](image)

![Sample plot with error bars](image)
9.11.2 Plotting Error Values from a Data Column

If you do not want to use one of the available error types, you can supply your own set of error values and plot them as error bars.

To plot error values from a data column:

1. In the data window, create a column containing the error values.
2. Select the plot which will have the error bars added.
3. Choose Plot > Error Bars to display the Error Bar Variables dialog.
4. Click one of the check boxes to display the Error Bar Settings dialog.
5. Choose Data Column for the error type and select the name of the data column containing the error values.
6. Click OK. Then, click Plot to add the error bars to the plot.

![Plot with error bars from a data column](image)

Figure 9-31  Plot with error bars from a data column

9.11.3 Adding Text Error Bars

Error bars can also be used to annotate specific markers or columns in the plot with text labels. When a Text data column is used for the error type, the data in the column is displayed as text labels at the corresponding points on the plot. Only data points that have errors associated with them have text labels displayed.

The direction of the labels is the same as the error type selected (horizontal for X Err or vertical for Y Err). If the Center Text check box is selected, the labels are centered on the markers. Otherwise, they are justified and placed on the side of the marker which has the error selected. The text labels can be moved individually with the Text tool or as a group with the Selection Arrow.

**Note:** Text error bars use the same default attributes as value labels. These labels can also include subscripts or superscripts. For more information on adding these features to text labels, see Section 8.7.3.
To add text error bars to a plot:

1. In the data window, place the data to be displayed as labels into a Text column. Figure 9-32 shows a sample data set containing a Text column with error values.

![Sample data set with text errors](image1)

Figure 9-32 Sample data set with text errors

2. Select the plot which will have the error bars added.

3. Choose **Plot > Error Bars** to display the Error Bar Variables dialog.

4. Click one of the check boxes to display the Error Bar Settings dialog, shown in Figure 9-33.

![Error Bar Settings dialog](image2)

Figure 9-33 Error Bar Settings dialog
5. Clear the **Link Error Bars** check box.

6. Choose **None** for one of the portions of the bar. For the other, choose **Data Column** and select the text column containing the labels (in this case **Errors**).

7. To center the labels on the marker, select the **Center Text** check box. Otherwise, the labels are justified.

   **Note:** If the **Link Error Bars** check box is selected and the **Center Text** check box is cleared, text labels are placed on both sides of the marker.

8. Click **OK**. Then, click **Plot** to add the labels to the plot. Figure 9-34 shows a sample plot with text error bars added.

![Figure 9-34  Plot with text error bars added](image)

### 9.11.4 Creating Single-Sided Error Bars

Single-sided error bars are useful when you only want to display the bar on one side of the data point. You can choose a single error type and decide whether to display the positive or negative portion of the bar.

A special case of these error bars results when the errors are taken from a data column. Here the direction of the error bar is controlled by the sign of the data and whether positive or negative error types have been selected. For positive data, bars are displayed in the same direction as the error type. For negative data, the bars are displayed in the opposite direction.

To create single-sided error bars:

1. Select the plot which will have the error bars added.
2. Choose **Plot > Error Bars** to display the Error Bar Variables dialog.
3. Click one of the check boxes to display the Error Bar Settings dialog.
4. Clear the **Link Error Bars** check box.
5. Choose **None** for either the positive or negative error type.
6. Choose the type of error to be displayed for the other portion of the bar.
7. Click **OK**. Then, click **Plot** to add the error bars to the plot. Figure 9-35 shows a sample plot with single-sided error bars added.
Error arcs can be displayed instead of error bars. This is done by selecting the **Draw Error Arc** check box in the Error Bar Settings dialog. An arc is displayed when one of the error types is set to **None**. If both positive and negative errors are selected for X Err and Y Err, an ellipse is displayed.

All four quadrants of the ellipse can be controlled independently. The vertical distance is determined by the Y Err and the horizontal distance is determined by the X Err. This gives you a number of possibilities for displaying error arcs and ellipses.

To add error arcs:

1. Select the plot which will have the error arcs added.
2. Choose **Plot > Error Bars** to display the Error Bar Variables dialog.
3. Click the **X Err** check box for one of the variables to display the Error Bar Settings dialog.
4. Select the **Draw Error Arc** check box.
5. Choose the positive and negative error types. Then, click **OK**. Figure 9-37 shows the dialog containing selections for the X error.
6. Click the **Y Err** check box for that same variable to define the vertical dimension of the arc. Repeat steps 4 and 5 to set up all of the errors of interest. Figure 9-36 shows the Error Bar Settings dialog containing selections for the Y error.
7. Click **Plot** to add the error arcs to the plot. Figure 9-38 shows a sample plot with error arcs added, using the settings for the X and Y Error shown above.

![Figure 9-36 X error selections](image1)

![Figure 9-37 Y error selections](image2)

![Figure 9-38 Plot with error arcs added](image3)
9.11.6 Displaying Only the Cap

You have the option to remove the line that connects the data point with the error cap. This is accomplished by selecting the **Draw Cap Only** check box in the Error Bar Settings dialog.

This option can help remove a number of unnecessary lines from the plot and make it easier to see the data. This feature is useful when the **Standard Deviation** error type is selected. Because all of the error bars are drawn from the mean, the lines connecting the point and the cap are not needed. By removing the lines and adjusting the length of the caps, you can have a dashed or solid error line across the entire plot. See Section 9.11.7 for controlling the cap length.

To display only the error cap:

1. Select the plot which will have the error bars added.
2. Choose **Plot > Error Bars** to display the Error Bar Variables dialog.
3. Click one of the check boxes to display the Error Bar Settings dialog.
4. Select the **Draw Cap Only** check box.
5. Choose the positive and negative error types.
6. Click **OK**. Then, click **Plot** to add error bars to the plot. Figure 9-39 shows a sample plot with only the caps displayed and a Standard Deviation error type.

![Figure 9-39  Plot displaying only the error caps](image.png)
9.11.7 Changing the Cap Length

To change the cap length of error bars:

1. Choose Plot > Plot Options.
2. Click General to display the dialog in Figure 9-40.
3. Edit the value in the Error Bar Length field. A cap is not displayed if zero is entered in this field.
4. Click OK to return to the plot.

9.11.8 Removing Error Bars

You can easily remove error bars from individual variables or from all the variables at once.

To remove error bars:

1. Choose Plot > Error Bars. A dialog similar to Figure 9-41 is displayed.
2. Clear the check boxes of the error bars to be removed. Clicking Deselect clears all of the check boxes at once.
3. Click Plot to return to the plot window. The plot is redrawn without any error bars.
This chapter provides information on the following topics:

- Importing images from other programs into the plot window.
- Printing plots.
- Saving plots.
- The file formats supported by KaleidaGraph.
- Exporting plots for use in another program.

## 10.1 Importing Images from Other Programs

KaleidaGraph is able to insert a variety of images created in other programs. When you import a graphic file, the picture is placed in the active plot or layout window. You cannot edit any parts of the imported picture. However, you can move and resize the image, and modify its frame.

To import an image that was exported as a file:

1. Make the desired plot or layout window the active window.
2. Choose **File > Open**.
3. Locate and open the file to be imported. The imported image appears as an object in the plot or layout window, with four object handles around it.

To paste an image from the Clipboard:

1. Make the desired plot or layout window the active window.
2. Choose **Edit > Paste**. The image appears as an object in the plot or layout window, with four object handles around it.
10.2 Printing Plots

KaleidaGraph supports laser printers, plotters, ink jet printers, and any other device that has the appropriate printer driver installed.

To export a plot to a printer:

1. Make sure the plot window to be printed is active.
2. To change page options, such as page orientation or paper size, use the Page Setup command from the File menu.
4. Review your printing options and click Print.

Note: The options in the Page Setup and Print dialogs vary depending on the printer and operating system.

10.3 Saving Plots

KaleidaGraph can save the plots with or without the data used to create the plot. By default, when you save a plot, a copy of the data is saved as part of the plot file. This allows you to open a saved plot and make changes to the plot and the data associated with it (see Section 7.12).

The advantage of saving the plot without the data is that it saves space on the hard disk, especially if you create plots from large data sets. The drawback is that you cannot make any changes that require the plot to be rebuilt from the original data. This includes resizing axes, scaling to a new set of limits, editing markers, and modifying error bars or curve fits.

Note: If the plot has not been saved and you close the data window by pressing Shift and either clicking the close box or choosing File > Close/NoSave, the plot will be saved without the data.

To save a plot with its data:

1. Make sure the plot to be saved is active.
2. Choose Save Graph or Save Graph As from the File menu.
3. Verify that KaleidaGraph Plot is currently selected in the Format pop-up menu.
4. Specify the location and file name for the file and click Save.

To save a plot without the data:

1. Make sure the plot to be saved is active.
2. Choose File > Save Graph As.
3. Select KaleidaGraph Picture from the Format pop-up menu.
4. Specify the location and file name for the file and click Save.
10.4 File Formats Available in KaleidaGraph

KaleidaGraph can export the plots in a variety of formats. The file formats currently supported are listed below with a description of each:

- **PICT** - PICT images are the most common format used on a Macintosh. If you copy a plot to the Clipboard, it is copied as a PICT image. These vector images have a resolution of 600 dpi when exported with the **High Resolution** option selected.

- **Windows BMP** - The Windows BMP format can be used to take images into other programs. These raster images have a default resolution of 72 dpi.

- **GIF** - The GIF format is often used for web images. These raster images have a default resolution of 72 dpi.

- **JPEG** - The JPEG format is often used for web images. These raster images have a default resolution of 72 dpi.

- **PNG** - The PNG format is often used for web images. These raster images have a default resolution of 72 dpi.

- **TIFF** - The TIFF format is often used for printed publications. These raster images have a resolution of 576 dpi when exported with the **High Resolution** option selected.

**Note:** You can increase the resolution of Windows BMP, GIF, JPEG, and PNG files by setting the **Scale Result by** field to 400% when exporting the image. Once the image is imported into another program, it needs to be reduced by 25%. This process of scaling an image up and then reducing it down builds resolution into the image and gets you closer to 300 dpi for the resulting image.
10.5 Exporting Plots to Another Program

There are two methods available to take a KaleidaGraph plot and insert it into another program. You can copy it to the Clipboard and paste it into the destination program or you can export the plot in a specific file format and then import that image. The following sections provide information on using both of these methods to export plots.

10.5.1 Copying Plots to the Clipboard

The easiest way to export the plot is to use the Copy Graph command (Edit menu). A PICT image is copied to the Clipboard that can be pasted into another program.

The Copy Graph command is available when a plot window is active and does not contain a selection. This command copies the entire plot to the Clipboard. You can then paste the image into another plot window or into a different program.

To copy a plot to the Clipboard:

1. Make sure the plot window to be exported is active.
2. Choose Edit > Copy Graph. One of the following dialogs is displayed.

   ![Copy Graph dialog](image)

   Figure 10-1 Copy Graph dialog

3. Make your selections in the dialog and click OK. Refer to the Help file for information on the options available in this dialog.
4. The entire plot is now on the Clipboard in a PICT format and can be inserted into another program using the Paste or Paste Special command.

   **Note:** Copying the graph by using the Select All command followed by the Copy Selection command will not give you the same resolution as using the Copy Graph command. The Copy Selection command will yield a 72 dpi image whereas the Copy Graph command (with High Resolution or Postscript PICT on) will yield at least 300 dpi when printed.
10.5.2 Exporting Graphics in a Specific File Format

KaleidaGraph is able to save plots in a variety of different formats for inclusion in another program. For information about the specific file formats, refer to Section 10.4.

If one of these files is loaded back into KaleidaGraph, it is treated as a picture. You cannot edit any parts of the picture. However, you can move and resize the image within the plot or layout window.

To export a plot in a specific file format:

1. Make sure the plot window to be exported is active.
2. Choose File > Save Graph As and select the desired file format from the Format pop-up menu.
3. Specify the location and file name for the file and click Save. A dialog similar to Figure 10-2 is displayed to set the size and scaling of the exported file. The options available in the dialog vary depending on which format you are exporting. Most of the raster formats provide a Settings button that can be used to adjust additional options in the exported file, such as color depth.

![Set Graphic Size dialog](image)

Figure 10-2 Set Graphic Size dialog

4. Make your selections in the dialog and click OK to export the file. This file can then be imported into another program.
10.6 Exporting PostScript and PDF Files

Although KaleidaGraph does not have the ability to directly export plots in a PostScript or PDF format, it is possible to generate these files using the Print dialog in OS X.

To export a plot or layout as a PostScript or PDF file:

1. Choose **Print Graphics** or **Print Layout** from the **File** menu.
2. To create a PostScript file, choose **Output Options** from one of the pop-up menus in the Print dialog, click **Save as File**, and change the **Format** to **PostScript**.
3. To create a PDF file, click the **Save As PDF** button.
4. Enter a file name, specify the location, and click **Save**. A PostScript or PDF file will be created in the specified location.
The layout window can be used to place multiple plots on a single page. It can also be used to add text labels, graphics, or tables to a single plot or to multiple plots on a page. The layout window replaces the Show Page feature that was available in earlier versions of KaleidaGraph.

This chapter explains how to:

- Display the layout window.
- Place plots into the layout window.
- Change the size and position of plots in the layout.
- Arrange the plots in the layout window.
- Overlay multiple plots.
- Add a background to the layout.
- Save basic and Group Layout files.
- Export the contents of the layout window.

### 11.1 Displaying the Layout Window

The layout window can be displayed using the **Show Layout (Windows menu)** and **New Layout (File menu)** commands. The Show Layout command lists any layouts that have been opened or created since the program was started. If a default layout has been saved (in the KG Layout settings file), this submenu will always contain an item called **KG Layout**.

The **New Layout** command creates an empty layout window. If any changes were made to the current layout, a dialog asks if you want to save the changes before displaying the new layout window.

When the layout window is active, a **Layout** menu is added to the menu bar. You can use the commands in this menu to place plots in the layout, arrange the plots, and add a background or frame to the layout.
11.2 Placing Plots in the Layout Window

You can place up to 32 different plots in the layout window. Plots are added to the layout window using the **Select Plot** command (Layout menu). Choosing this command displays a submenu that lists the plots that are currently open, from newest to oldest. When you choose a plot from the list, it is placed in the layout window.

The name of the plot appears in the lower-left corner of the plot, as shown in Figure 11-2. This is for identification purposes only; it is not included when you print or export the layout.

As plots are added to the layout window, KaleidaGraph maintains a link between the cell in the layout and the position of the plot in the **Select Plot** submenu. If a particular cell contains the first plot in the list, opening or creating another plot will cause the cell to display this new plot.

Any time you open, create, or close a plot, it is possible for the plots in the layout to change positions because the location of the plots in the **Select Plot** submenu has changed. For this reason, it is best if you open or create all of your plots before arranging them in the layout window.

It is also possible to use empty cells, shown in Figure 11-3, to organize the layout. These can be added to the layout window by choosing **Layout > New Position**. The empty cells can be replaced at a later time by clicking the cell and choosing a plot from the **Select Plot** submenu.
11.3 Setting Plot Size and Position

There are two methods available for setting the size and position of plots in the layout window. The first method is to manually drag the plot to resize it or move it to a new position. The second method is to double-click the plot to specify the size and position via the Plot Size dialog.

11.3.1 Manually Resizing the Plot

The plot size and position can be set directly in the layout window by clicking a plot and dragging. When resizing a plot, the **Axis** and **Frame** buttons in the Plot Size dialog determine whether to resize relative to the axis or the frame.

When a plot is selected, object handles appear in one of two places. When **Axis** is selected in the Plot Size dialog, object handles are displayed at the end of each axis. When **Frame** is selected, object handles are placed at the corners of the plot frame. Figure 11-4 shows a plot with **Axis** selected; Figure 11-5 shows a plot with **Frame** selected (in the Plot Size dialog).

To manually resize the plot, drag one of the object handles. As you drag, a dialog appears in the upper-left corner of the layout window. This dialog (shown below) contains the current plot dimensions and axis origin (offset).

```
<table>
<thead>
<tr>
<th>(in.)</th>
<th>X:</th>
<th>Y:</th>
</tr>
</thead>
<tbody>
<tr>
<td>Offset:</td>
<td>1.50</td>
<td>1.50</td>
</tr>
<tr>
<td>Axis:</td>
<td>5.00</td>
<td>5.00</td>
</tr>
<tr>
<td>Frame:</td>
<td>7.50</td>
<td>7.50</td>
</tr>
</tbody>
</table>
```

The aspect ratio of the plot is maintained as you resize the plot. By pressing **Shift** as you drag, it is possible to resize the plot without maintaining the aspect ratio.
11.3.2 Using the Plot Size Dialog

The size and position of the plots in the layout can also be controlled using the Plot Size dialog. This
dialog, shown in Figure 11-6, is displayed whenever you double-click a plot in the layout window. The
settings in this dialog determine the size and location of the plot, as well as whether or not the aspect
ratio of the plot is maintained.

![Plot Size dialog]

Figure 11-6  Plot Size dialog

The settings in the Plot Size dialog are discussed below:

- **Same as Plot Window** - This setting forces the plot in the layout window to be the same size
  as the original plot. The location of the plot is controlled using the **Origin** settings.

- **Fix Size** - This setting lets you specify the exact size and placement of the plot in the layout.
  - The **Paper** values, listed for X and Y, are the horizontal and vertical dimensions of the
    printable space on a sheet of paper.
  - The **Origin** specifies the distance, from the upper-left corner of the print area to the
    upper-left corner of either the axis or the frame of the plot (depending on which button is
    selected).
  - The **Axis** settings, when selected, indicate the length of the axes. If the Axis values are
    changed, the Frame values change proportionately.
  - The **Frame** settings, when selected, indicate the length of the frame. If the Frame values
    are changed, the Axis values change proportionately.

**Note:** Typing the word **auto** allows a floating dimension, while you specify the size of the other
dimension. This maintains the plot’s aspect ratio. When both X and Y values are entered, without using
**auto** for one of them, the aspect ratio is distorted, resulting in ellipses rather than circles for the markers.

- The **Units** being used must be identified as either inches or centimeters.
11.4 Arranging Plots

The **Arrange Layout** command (Layout menu) provides a fast and easy way to take the plots and organize them in the layout window. The plots are arranged in the order they were added to the layout window, starting at the top of the page and working down from left to right. When you choose **Arrange Layout**, the dialog in Figure 11-7 is displayed.

**Note:** This command can only be used to arrange plots in the layout window. It does not have any affect on any other objects in the layout window.

![Arrange Layout dialog](image)

To arrange the plots in the layout window:

1. Place all of the plots in the layout window.
2. Choose **Layout > Arrange Layout**.
3. Enter the desired number of rows and columns into the Arrange Layout dialog. You can also specify the size of the margin around each of the positions in the layout.
4. Click **OK**. The layout window is divided equally, based on the number of rows and columns entered. The plots are automatically resized and placed into the positions.
Figure 11-8 shows a layout window containing five plots in a random pattern. Figure 11-9 shows the same layout window after dividing the window into three rows and two columns using the **Arrange Layout** command.

![Figure 11-8 Before choosing Arrange Layout](image1)

![Figure 11-9 After choosing Arrange Layout](image2)

### 11.5 Overlapping Plots

You can use the layout window to position two or more plots on top of each other. These plots must have the same frame and axis dimensions. This is useful if you need to display a single plot with more than the maximum number of variables allowed. By creating separate plots, you can overlay them to get the appearance of a single plot.

To overlay two or more plots:

1. Open or create all of the plots that you need to overlay. The plots must be identical in size for them to overlay properly. To ensure that the plots are of equal size, either choose **Plot > Define Layout** after creating the first plot or use the first plot as a template for creating any remaining plots. You can also use the **Set Plot Size** command (**Plot** menu) for each plot to make sure the origin, axis, and frame settings are identical.

2. Remove the text labels from all but one of the plots. The following two plots are used in this example. Figure 11-10 shows a normal plot with all of its labels intact. Figure 11-11 shows a similar plot with everything but the legend deleted.
3. Switch to the layout window.
4. Use the **Select Plot** command (**Layout** menu) to import the plots into the layout window.
5. Provided that all of the plots are identical in size, you can use the Align tool to overlay the plots. This is done by selecting the plots and using the Align tool to align either the edges or centers in both the horizontal and vertical directions. Figure 11-12 shows the result of overlaying the two sample plots.
6. The layout window can then be printed, copied to the Clipboard, or saved in a variety of formats. You can also save this layout for future use.

**11.6 Adding a Background or Border**

A background or border can be added to the layout window or to the plots in the layout window. The following sections explain how to add backgrounds and borders in the layout window.

**11.6.1 Adding to the Layout Window**

A background can be added to the layout window using the **Set Background** command (**Layout** menu). This allows you to select a fill pattern for any part of the page not covered by a plot. It also lets you have a frame around the entire layout.

**Note:** Text labels may or may not have the background displayed behind the text. The **Erase Background** command (in the **Format** menu of the Edit String dialog) controls what happens. When this command is turned on, the background is erased.
To add a background or border to the layout:

1. Choose **Layout > Set Background**. The dialog in Figure 11-13 appears.

![Set Background dialog](image)

2. Make your selections by clicking the appropriate section of each icon. The background is controlled by the Color icon and the Fill Pattern portion of the Pattern icon. The border is controlled by the Style icon and the Pen Pattern portion of the Pattern icon. Section 8.9 explains the use of these icons.

3. Click **OK** to apply the background or border to the layout window. Figure 11-14 shows a layout with a background applied. The text label at the top has **Erase Background** turned on and the text labels below each plot do not.

![Sample layout with background](image)
11.6.2 Adding to a Plot in the Layout

It is possible for each plot in the layout window to have its own background and border. This is accomplished by selecting the plot in the layout and using the Color, Pattern, and Style icons from the bottom of the toolbox.

The background is controlled by the Color icon and the Fill Pattern portion of the Pattern icon. If a background color is specified in the original plot window, these settings do not have any affect on the appearance of the plot. The border is controlled by the Style icon and the Pen Pattern portion of the Pattern icon.

Note: Any background applied to the layout is also applied to any plots which have None selected for the Fill Pattern and do not have a background color selected in the original plot window.

11.7 Exporting the Layout

The contents of the layout window can be exported by copying the layout to the Clipboard, exporting the layout to a file, or printing the layout.

11.7.1 Copying Layouts

To export a layout to the Clipboard:

1. Make sure the layout window to be exported is active.
2. Choose Edit > Copy Layout. A dialog is displayed to set the size and scaling of the exported image.

   Note: If the Copy Selection command is displayed in the Edit menu, something is currently selected in the layout window. Do not use this command because it causes the image to have lower resolution.
3. Make your selections in the dialog and click OK.
4. The entire layout is now on the Clipboard in a PICT format and can be inserted into another program using the Paste or Paste Special command.

11.7.2 Exporting the Layout in a Specific File Format

KaleidaGraph is able to save layouts in a variety of different formats for inclusion in another program. If one of these files is loaded into KaleidaGraph, it is treated as a picture. You cannot edit any parts of the picture. However, you can move and resize the image within the plot or layout window.

Note: For information on saving the layout in a PostScript or PDF format, refer to Section 10.6.

To export a layout for use in another application:

1. Make sure the layout window to be exported is active.
2. Choose File > Save Layout As and select the desired file format from the Format pop-up menu.
3. Specify the location and file name for the file and click Save. A dialog similar to Figure 11-15 is displayed to set the size and scaling of the exported file. The options available in the dialog will vary depending on which format you select. For information about the specific file formats, refer to Section 10.4.
4. Make your selections in the dialog and click **OK** to export the file. This file can then be imported into another program.

### 11.7.3 Printing Layouts

To print a layout:

1. Make sure the layout window to be printed is active.
2. To change page options, such as page orientation or paper size, use the **Page Setup** command from the **File** menu.
3. Choose **File > Print Layout**.
4. Review your printing options and click **Print**.

**Note:** The options in the Page Setup and Print dialogs vary depending on the printer and operating system.
11.8 Opening and Saving Layout Files

11.8.1 Types of Layout Files
KaleidaGraph can save two types of Layout files: basic Layout files and Group Layout files. The only difference between the two types of files is how they handle the plots within the layout window.

A basic Layout file stores the following information: size and position of the cells, the contents and location of any text labels or objects, and the background settings. The plots are not saved as part of the Layout file; however, the cells are assigned position numbers based on the order of the plots in the Select Plot submenu. For example, if a cell contains the second plot in the Select Plot submenu, the next time you open this layout file, the second plot in the Select Plot submenu will automatically be loaded into this cell.

Group Layout files provide the added benefit of saving a copy of each plot embedded within the Layout file. This allows you to organize your plots, save a Group Layout file, and open a single file at a later date to make changes to any of the original plots.

11.8.2 Opening Saved Layout Files
You can use the Open command (File menu) to open any Layout files that have been saved previously. The type of Layout file that you open (basic or group layout file) determines how it is handled.

If you open a basic Layout file, KaleidaGraph will load any open plots into the layout window, using the same procedure that was used when the layout was originally created. Each of the cells are assigned position numbers based on the order of the plots in the Select Plot submenu. To see the position numbers for each of the cells, open the layout file before opening or creating any plots. Any cells that show Position #0 are empty cells and will not automatically have plots loaded into them.

If you open a Group Layout file, KaleidaGraph will display the layout window and the plots that were saved as part of the layout file. Each of the plots is opened at the same time, although the individual plot windows are hidden by default. You can either click the Extract button ( графический элемент) in the upper-right corner of the layout window or use the Show Plot command (Windows menu) to display the original plots.

11.8.3 Saving the Layout File
Once you have created a layout, you can save the layout for future use. You have the choice of saving a basic Layout file (which does not include the plots) or a Group Layout file (which saves a copy of each plot as part of the layout file).

To save a layout:

1. With the desired layout as the active window, choose File > Save Layout As.
2. To save a basic Layout file, verify that KaleidaGraph Layout is currently selected in the Format pop-up menu. This will save the size and position of the cells, the contents and location of any text labels or objects, and the background settings. It will not save any of the plots as part of the Layout file.
3. To save a Group Layout file, verify that KaleidaGraph Group Layout is currently selected in the Format pop-up menu. This will save the plot files as part of the Layout file.
4. Give the file an appropriate name and click Save.
11.8.4 Modifying Plots in a Group Layout File

When you open a Group Layout file, the plots used in the layout are opened at the same time, although the individual plot windows are hidden by default. The following methods can be used to display the individual plot windows for further editing:

- Click the Extract button ( ) in the upper-right corner of the layout window. The plots used in the layout will be brought to the front.
- Use the Show Plot command (Windows menu) to bring an individual plot to the front.

11.9 Other Layout Window Features

11.9.1 Changing the View of the Layout Window

KaleidaGraph provides several magnification levels for changing the view of the layout window. To change the magnification of the layout, click the Zoom drop-down menu in the lower-left corner of the layout window and choose the desired zoom level. The available zoom percentages are: 25, 50, 75, 100, 125, 150, 200, 300, and 400%.

11.9.2 Displaying Rulers and Grids in the Layout Window

To turn the rulers and grids on and off in the layout window:

1. With the layout window active, choose Plot > Ruler & Grids.
2. Click the appropriate check boxes to display the rulers, grids, or both.
3. Select the proper units that you want to use.
4. Click OK to return to the layout window.

11.9.3 Switching Between Layouts

KaleidaGraph provides a Show Layout command in the Windows menu which can be used to switch between the default KG Layout and any other layouts that have been opened or created since the program was started. The active layout is listed first in the submenu. Older layouts are listed below the dotted line.

11.9.4 Deleting Items from the Layout

You can delete any unwanted items from the layout window in one of two ways. You can either select the item and press Delete or select the Eraser from the toolbox and click the unwanted item. These methods work for plots or any other objects you want to delete.

11.9.5 Refreshing the Layout

The layout window utilizes the Auto Refresh command from the Plot menu. When this command is turned on, the plots are updated whenever a change is made in the layout window. When Auto Refresh is turned off, the plots are not updated and are replaced by placeholders in the layout. The plots are not redrawn until the Auto Refresh command is turned on again.

Turning this command off allows you to make several changes in the layout window without having to wait for the window to update after each change. This is particularly useful when arranging several plots on a page or when working with large data sets.
KaleidaGraph provides two different mechanisms for automating the process of creating a plot. Plot scripts can be used to create multiple plots at once that have the same appearance. Formula scripts take it one step further and provide commands that enable you to automate the process of opening and closing data windows, creating plots, and exporting plots to a printer or the Clipboard.

This chapter covers:
- Creating a plot script.
- Setting the title and legend information in a plot script.
- Exporting plots automatically via a plot script.
- Entering and executing a formula script.
- The formula script commands, including some example scripts.

### 12.1 Using Plot Scripts

Another way to generate similar plots is the **Plot Script** command (Windows menu). This feature enables you to choose any plot type or an existing plot and use it as a template for creating multiple plots at once.

#### 12.1.1 When to Use Scripts

The script feature is intended for the user who has a Template plot and wants to plot different data sets and view the resulting curves. Even if you only need to generate a simple plot, but you generate it all of the time with different data, you will find plot scripts very useful.

The advantage of a script over a Template plot is that a script can generate multiple plots. Also, you can control legend descriptions and plot titles using a script. In a Template plot, the legend descriptions come from the column names of the plotted variables and the plot title remains unchanged.
12.1.2 Creating a Plot Script

The Plot Script command is similar to the Template plot but provides you with more options for creating plots. Using plot scripts, you can create multiple plots at once, automatically print or save the plots, and set the plot title or legend for each plot.

Choosing **Windows > Plot Script** displays the dialog in Figure 12-1. This dialog is used to make your selections for the current script. The script selections include: plot type, variable selections, plot titles, legend text, auto print, and auto save options.

![Figure 12-1 Plot Script window](image)

To create a plot script:

1. Choose **Windows > Plot Script** to display the Plot Script window.
2. If groups are already listed in this window, click **Clear All** to remove the groups and start a new script.
3. Using the **Graphic Template** pop-up menu, choose either a Gallery plot type or an existing plot to use as a template.
   
   **Note:** Only one graphic template can be used in a script.
4. Click **Add**. A Variable Selection dialog similar to Figure 12-2 is displayed.
5. Select the variables to be plotted.

6. Click **OK**. Group 1 will be created in the Plot Script window, as shown in Figure 12-3. Continue using the **Add** button to create new groups. Each group generates a separate plot.

7. When you are finished creating groups, click **Run** to execute the script.

**Note:** If you exceed the maximum number of open plot windows while executing a script, the situation is handled based on the current state of the **Automatically dispose of old plots** option in the **General** tab of the Preferences dialog. When this check box is selected, the oldest plot is discarded, without asking for your approval.
12.1.3 Setting Titles and Legends

By default, the titles are the same as the template and the legend comes from the column names of the plotted variables. You can set the plot titles and legends for each plot being created using the *Set Titles* and *Set Legends* buttons in the Plot Script window. Clicking either of these buttons displays a text editor.

Each line in the editor corresponds to a different plot. Plot titles are entered on separate lines, followed by a return. If you choose to set the titles, you must set them for all of the plots. If a specific plot is not to have a title, create a blank line in the editor by pressing *Return*. Each title appears to the right of the corresponding data group in the Plot Script window.

*Note:* Multi-line titles can be created using the `\r` characters. Any text that follows `\r` will be placed on a separate line.

To set the plot titles for a script:

1. Click *Set Titles*.
2. Enter plot titles as displayed in Figure 12-4.
3. Choose *File > Close*. The titles are listed to the right of the groups, as shown in Figure 12-5.
The legend information for each plot is also placed on separate lines, followed by a return. To indicate that the labels belong to the same plot, each legend label should be separated with either a comma or a tab. For Double Y, Double XY, Double Y Bar, or Double Y Column plots, enter the labels for the Y1 legend followed by the Y2 labels (on the same line). All labels prior to a return belong to the same plot. Only use the Return key to separate legend titles associated with different plots.

**Note:** Multi-line legend labels can be created using the \r characters. Any text that follows \r will be placed on a separate line.

To set the legends for a script:

1. Click **Set Legends**.
2. Enter legend titles as displayed in Figure 12-6.

![Edit Script Legends dialog](image)

Figure 12-6  Edit Script Legends dialog

3. Choose **File > Close**.

### 12.1.4 Using Pattern Recognition to Create New Groups

The Plot Script window includes a pattern recognition feature. Once you add a third data group, KaleidaGraph tries to identify a pattern in the way you are setting up the groups. If KaleidaGraph’s selections are correct, you can replicate the pattern throughout the data window by clicking **Repeat** instead of **OK**. KaleidaGraph continues the selection pattern across all of the columns in your data window, and creates the groups automatically.

**Note:** The pattern recognition feature only works across the columns of a data window or across the columns of a set of data windows. KaleidaGraph cannot identify a plotting pattern that jumps from one data window to another.
12.1.5 Pointing Groups to Different Data Windows

The **Data Windows** pop-up menu can be used to select a different data window for each individual set of variable selections. This pop-up menu contains up to 20 **X Set** menu items (X–X20). A set is defined as an X variable and its associated Y variables (such as: X, Y1, Y2). The number of **X Set** menu items depends on the number of independent variables selected for the current group.

The sets are listed in the pop-up menu in the order they were created. Selecting one of the sets displays a submenu containing a list of the open data windows. They are listed in the order they are stacked on the screen, from front to back. The data window currently associated with a particular set is preceded by a check mark. Figure 12-7 shows the Plot Script window with the **Data Windows** pop-up menu and the **X Set** submenu.

![Figure 12-7 Selecting different data windows](image)

To change the data window associated with a particular set:

1. Click the group to be edited.
2. Click the **Data Windows** pop-up menu, select an **X Set**, and choose a different data window. The selected data window is now used for that particular set of variable selections.

**Note:** The only other way to change the data window referenced by a set is to use the **Change** button after selecting each individual group. This method must be used to select different columns for plotting.
12.1.6 Exporting Plots Automatically

You can automatically export script-generated plots to the printer or to disk using the Auto Print and Auto Save options.

To automatically print plots:

1. Click the Auto Print check box.
2. Choose either Print Graphics or Print Layout from the pop-up menu immediately below Auto Print.
3. Execute the script by clicking Run. The plots are automatically printed.

To automatically save plots:

1. Click the Auto Save check box.
2. Choose the type of graphic file to be created from the pop-up menu immediately below Auto Save.
3. Enter a prefix to be used for the saved plot files. By default, the naming convention uses the word Prefix followed by an underscore (_) and a number.
4. Click Run to execute the script. KaleidaGraph displays a dialog allowing you to specify a location for the saved plots.

12.1.7 Saving and Loading Scripts

Once you have created a script, you can save it to disk by choosing File > Save Script As.

If you used an existing plot for the Graphic Template, a plot file is created with the plot script document. The plot will use the same name as the script, but with a .qpc file name extension. Any future use of the script causes the plot file to open. Once a script and its template have been saved, the plot must remain in the same folder as the script and it cannot be renamed. Otherwise, the script no longer recognizes the plot document.

A default Script file is automatically opened each time KaleidaGraph is started. This way you can save your plot script and have it opened the next time you use the program.

Custom Script files can be opened at any time from within KaleidaGraph by choosing File > Open. The Plot Script window changes to reflect the contents of the new Script file.
12.2 Formula Scripting

KaleidaGraph supports an internal set of scripting commands in the Posted Note of Formula Entry. Using these commands, you can automate the process of opening and closing data windows, creating plots, and exporting plots to a printer or the Clipboard. Scripts are particularly useful if you repeatedly open the same types of text files, perform the same set of data manipulations, and generate the same types of plots.

12.2.1 Creating a Formula Script

Formula scripts are similar to the multi-line formulas that were discussed in Section 5.6. The main difference is that there are a number of additional commands that are supported by KaleidaGraph. These commands enable you to open data files, create plots, print plots, and export the plots in a variety of formats.

All of the formula script commands are discussed in Section 12.2.2. In addition, the #FORMULA command supports all of the functions that are available in the Formula Entry window, except for the execute command.

To enter and execute a formula script:

1. Verify that a data window is already open. The script cannot execute unless a data window is available.
2. Choose Windows > Formula Entry.
3. Click the Posted Note button ( ) to display the text editor.
4. Enter the formula script into the Posted Note.
5. When you are finished entering the script, choose File > Close to leave the Posted Note. You will return to Formula Entry, which displays the message shown in Figure 12-8.

![Figure 12-8  Formula Entry after exiting the Posted Note](image)

6. Click Run to execute the script in the Posted Note.

You can save the scripts using the Save As command from the File menu in the Posted Note window. Once the script has been saved, it can be reopened by choosing File > Open in the Posted Note window. Alternately, you can use the execute function in Formula Entry to load and execute a saved formula script.
### 12.2.2 Formula Script Commands

#### Definitions

- **BOOLEAN** yes/no/true/false
- **STRING** "255 character string surrounded by quotes"

The path to a file starts at the hard disk, with subdirectories separated by a colon (:).

The equal sign (=) is optional in this syntax. Anywhere the equal sign is used, the command is also valid without it.

The commands are case sensitive. The examples for each command show how it should be entered in the Posted Note window.

Comments can be added between formula script commands with the use of a semicolon. Any lines that begin with a semicolon are treated as comments. Place comment lines before or after individual formula script procedures. A syntax error message is displayed if the comment is included within the formula script command definition.

#### List of Commands

**#CLEAR** - This command deletes the specified selection in the active data window. The cells below the selection shift up to fill the void. You may optionally delete the column titles in addition to the data. The syntax for this command follows:

```
#CLEAR
[title = BOOLEAN]   [Start_Row   End_Row   Start_Column   End_Column]
#END
```

The numbers should be separated by any white space characters. As a special case, if Start Row has a value of –1, the entire window is selected. The active cell in the data window is moved to the location specified by Start Row, Start Column. The selection addresses for both row and column positions begin at zero and are counted from the upper-left corner of the data window (position 0,0). The default action is to not delete titles.

Example: Delete the data in rows 0–50 of columns 10–20.

```
#CLEAR
  title = false 0  50  10  20
#END
```

**#CLEARDATA** - This command clears the specified selection in the active data window. The syntax for this command follows:

```
#CLEARDATA
  [Start_Row   End_Row   Start_Column   End_Column]
#END
```

The numbers should be separated by any white space characters. As a special case, if Start Row has a value of –1, the entire window is selected. The active cell in the data window is moved to the location specified by Start Row, Start Column. The selection addresses for both row and column positions begin at zero and are counted from the upper-left corner of the data window (position 0,0).
Example: Clear the data in rows 50-100 of columns 15–25.

```
#CLEARDATA
50  100  15  25
#END
```

**#CLOSE** - This command closes the active window, without saving its contents. The syntax for this command follows:

```
#CLOSE
```

**#CLOSE/ALL** - This command closes all visible windows, without saving their contents. The syntax for this command follows:

```
#CLOSE/ALL
```

**#CLOSE/OPT** - This command closes the specified plot or data window. You have the option of saving the window before closing it. Only plot and data windows should be taken into account when determining the position number of the window. The syntax for this command follows:

```
#CLOSE/OPT
  window = #  (the position of the window from front to back, where the frontmost window is position 1)
  save = BOOLEAN
  wintype = plot/data  (optional)
#END
```

Example: Save and close the frontmost data window.

```
#CLOSE/OPT
  window = 1
  save = true
  wintype = data
#END
```

**#COPY** - This command copies the selection in the active data window to the Clipboard. You may optionally specify a selection as part of the command options. If no selection is specified, the current selection in the window is used. You may also specify whether to copy column titles in addition to any data. The syntax for this command follows:

```
#COPY
  [title = BOOLEAN]  [Start_Row   End_Row   Start_Column   End_Column]
#END
```

The numbers should be separated by any white space characters. As a special case, if Start Row has a value of -1, the entire window is selected. The active cell in the data window is moved to the location specified by Start Row, Start Column. The selection addresses for both row and column positions begin at zero and are counted from the upper-left corner of the data window (position 0,0). The default action is to not return titles.

Example: Copy the selection in rows 5–15, columns 1–3 (no titles).

```
#COPY
  5  15  1  3
#END
```
Example: Copy the selection in rows 0–10, columns 1–2 (with titles).

```
#COPY
  title = true 0 10 1 2
#END
```

**#CUT** - This command cuts the selection in the active data window. The cells below the selection shift up to fill the void. You may optionally specify a selection as part of the command options. If no selection is specified, the current selection in the window is used. You may also specify whether to include the column titles with the data. The syntax for this command follows:

```
#CUT
  [title = BOOLEAN] Start_Row End_Row Start_Column End_Column
#END
```

The numbers should be separated by any white space characters. As a special case, if Start Row has a value of -1, the entire window is selected. The active cell in the data window is moved to the location specified by Start Row, Start Column. The selection addresses for both row and column positions begin at zero and are counted from the upper-left corner of the data window (position 0,0). The default action is to not include titles.

Example: Cut the data in rows 100–500 of columns 0–20, without including the titles.

```
#CUT
  title = false 100 500 0 20
#END
```

**#DATA** - This command places tab-separated data in a new data window. The first row should contain titles. The syntax for this command follows:

```
#DATA
  (First row contains tab-separated titles.)
  (The remaining rows contain tab-separated data.)
#END
```

Example: Use the first row for titles and place the remaining data in a new data window.

```
#DATA
  Time    Test#1    Test#2
  1.0   38.6   39.7
  1.5   41.2   40.9
  2.0   42.7   42.3
#END
```

**#DATA/NOTITLE** - This command places tab-separated data in a new data window. The first row should contain data. The syntax for this command follows:

```
#DATA/NOTITLE
  (All rows contain tab-separated data.)
#END
```

Example: Place the data in a new data window.

```
#DATA/NOTITLE
  1.0   38.6   39.7
  1.5   41.2   40.9
  2.0   42.7   42.3
#END
```
**#DATAFILE** - This command loads the data file named in the string. If the file is a text file, it is loaded using the specified parameters. The syntax for this command follows:

```
#DATAFILE
file = STRING    (This string should be either a simple name or a fully or partially qualified path to the file. The Open dialog is displayed if the path or file name is incorrect, or if "*.*" is used for the string.)
delimiter = tab/space/special/STRING    (if STRING is used, only the first character of the string is important)
skip = #    (the number of lines to be skipped at the beginning of the file)
read_titles = BOOLEAN
del_number = #    (0 -> del == 1, 1 -> del >= 1, 2 -> del >= 2, 3 -> del >= 3)
title_format = STRING    (only used when delimiter = special)
data_format = STRING    (only used when delimiter = special)
#END
```

Example: Display the Open dialog to open any data file.
```
#DATAFILE
file = "*.*"
#END
```

Example: Open a comma-delimited text file.
```
#DATAFILE
file = "Macintosh HD:Data:Data1.txt"
delimiter = ","
#END
```

Example: Open a text file using the special format.
```
#DATAFILE
file = "Macintosh HD:Data:Test #1"
delimiter = special
skip = 0
read_titles = TRUE
title_format = "3(a)"
data_format = "A f3 2(A v)"
#END
```

**#FORMULA** - This command executes a list of standard formulas. A semicolon should be placed at the end of each formula. It is valid to omit the #FORMULA and #END statements if you wish. The syntax for this command follows:

```
#FORMULA
(List of standard formulas.)
#END
```

Example: Calculate the average of two columns and give the output column a title.
```
#FORMULA
c3 = (c1 + c2) /2;
name("Average", c3);
#END
```
#MERGEFILE - This command loads the data file named in the string, starting at the specified row and column position. The file is loaded using the specified parameters. The syntax for this command follows:

```
#MERGEFILE
file = STRING  (This string should be either a simple name or a fully or partially qualified path to the file. The Open dialog is displayed if the path or file name is incorrect, or if "*.*" is used for the string.)
delimiter = tab/space/special/STRING  (if STRING is used, only the first character of the string is important)
skip = #  (the number of lines to be skipped at the beginning of the file)
read_titles = BOOLEAN
del_number = #  (0 -> del == 1, 1 -> del >= 1, 2 -> del >= 2, 3 -> del >= 3)
title_format = STRING  (only used when delimiter = special)
data_format = STRING  (only used when delimiter = special)
position = # #  (row number and column number separated by a tab)
```

Example: Display the Open dialog to merge any data file.
```
#MERGEFILE
file = "*.*"
#END
```

Example: Merge a comma-delimited text file.
```
#MERGEFILE
file = "Macintosh HD:Data:Data1.txt"
delimiter = ",",
#END
```
#OPEN - This command opens the specified file. It can be used to open any file that KaleidaGraph recognizes. The syntax for this command follows:

```plaintext
#OPEN
file = STRING    (This string should be either a simple name or a fully or partially qualified path to the file. The Open dialog is displayed if the path or file name is incorrect, or if "*." is used for the string.)
#END
```

Example: Open a saved Style file.
```
#OPEN
file = "Macintosh HD:KaleidaGraph:KG Style"
#END
```

Example: Open a saved Layout file.
```
#OPEN
file = "Macintosh HD:KaleidaGraph:Layouts:Layout1"
#END
```

#PAGE_PRINT - This command prints one or more plot windows using the current settings in the layout window. The syntax for this command follows:

```plaintext
#PAGE_PRINT
```
**#PASTE** - This command pastes text or binary data from the Clipboard into the active data window. You may optionally specify a selection as part of the command options. If no selection is specified, the current selection in the window is used. You may also specify whether to paste column titles in addition to any text data. The syntax for this command follows:

```
#PASTE
[title = BOOLEAN] [Start_Row   End_Row   Start_Column   End_Column]
#END
```

The numbers should be separated by any white space characters. As a special case, if Start Row has a value of -1, the entire window is selected. The active cell in the data window is moved to the location specified by Start Row, Start Column. The selection addresses for both row and column positions begin at zero and are counted from the upper-left corner of the data window (position 0,0). The default action is to not return titles.

Example: Replace rows 0–10, columns 1–2 with the data on the Clipboard (with titles).
```
#PASTE
title = true 0  10  1  2
#END
```

**#PICT** - This command exports the active plot or layout window as a PICT image via the Clipboard. The syntax for this command follows:

```
#PICT
```

**#PICT/OPT** - This command exports the active plot or layout window to a file or the Clipboard, using the specified parameters. The hires_pict parameter is only available for PICT and TIFF files. The post_pict parameter is only available for PICT files. The syntax for this command follows:

```
#PICT/OPT
type = pict/bmp/gif/jpeg/png/tiff
scale = #    (ranging from 1 to 1000)
hires_pict = BOOLEAN (Same as selecting High Resolution when exporting PICT or TIFF images)
post_pict = BOOLEAN    (Only use when type=pict.)
min_whitespace = BOOLEAN
file = STRING
#END
```

Example: Export the active plot as a high resolution PICT file at 75%.
```
#PICT/OPT
type = pict
scale = 75
hires_pict = TRUE
file = "Macintosh HD:PICT Folder:Test file"
#END
```

**#PLOT_PRINT** - This command prints the active plot window. The syntax for this command follows:

```
#PLOT_PRINT
```
**#SAVE** - This command saves the specified plot or data window. Only plot and data windows should be taken into account when determining the position number of the window. The syntax for this command follows:

```
#SAVE
  window = #  (the position of the window from front to back, where the frontmost window is position 1)
  wintype = plot/data  (optional)
  file = STRING
#END
```

Example: Save the second plot window from the front.

```
#SAVE
  window = 2
  wintype = plot
  file = "Macintosh HD:Plot Folder:Test file"
#END
```

**#SCRIPT** - This command can be used to either load a specific script file or create a script from scratch. The y2 options in the script are only used for Double Y, Double XY, Double Y Bar, and Double Y Column plots. The x2 options in the script are only used for Double X and Double XY plots. The only way to use a template plot, apply curve fits, or apply error bars is to open a saved plot script file. The syntax for this command follows:

```
#SCRIPT
  file = STRING  (Load the script file. This file should be in the same folder as the last script file that was opened or specified by a fully qualified path. The Open dialog is displayed if the path or file name is incorrect, or if "*.*" is used for the string.)
  x/y/x2/y2 axis title STRING  (These commands are valid for the x, y, x2, and y2 axes.)
  x/y/x2/y2 axis limits # #  (Limits for dates or times can be entered as a STRING.)
  x/y/x2/y2 axis auto
  auto_print = boolean
  print_mode = single/layout
  auto_save = boolean
  save_mode = with_data/without_data/pict(bitmap)/metafile/bmp/gif/jpeg/png/tiff
  prefix = STRING  (There is a 30 character limit for the string)
  plot_type = line/scatter/double_y/double_x/double_xy/hilo/step/probability/xy_probability/histogram/box/percetile/dot/summary_column/bar/stack_bar/double_ybar/column/stack_column/double_ycolumn/polar/pie
  begin_group  (select variables, plot title, and legend text for the group)
  title = STRING  (one title per group)
  legend = STRING
  legend = STRING
  x = #  (select X column number)
  y = #  (select Y column number)
  y2 = #  (only for Double Y, Double XY, Double Y Bar, and Double Y Column plots)
  x2 = #  (only for Double X or Double XY plots)
  window = #  (Specify a data window for plotting. The default is the frontmost data window (window 1). The last window specified is remembered until a new script is encountered or a new window number is specified.)
  end_group
  (Add as many groups as you need to the script. Each group creates a new plot.)
#END
Example: Display the Open dialog to load and execute a plot script.

```script
file = "*.*"
```

Example: Create and save a Scatter plot from two data windows.

```script
auto_save = TRUE
save_mode = with_data
prefix = "1/31_Group"
plot_type = scatter
begin_group
title = "Lot 10938"
x = 0
y = 1
y = 2
window = 2
x = 0
y = 1
y = 2
end_group
```

Example: Create a Line plot from two sets of X-Y data in the same data window.

```script
plot_type = line
begin_group
x = 0
y = 1
x = 2
y = 3
end_group
```

Example: Create two Double Y plots from a single data window.

```script
plot_type = double_y
begin_group
x = 0
y = 1
y2 = 2
end_group
begin_group
x = 3
y = 4
y2 = 5
end_group
```
**#SELECTION** - This command sets the selection in the active data window. The syntax for this command follows:

```
#SELECTION
Start_Row   End_Row   Start_Column   End_Column
#END
```

The numbers should be separated by any white space characters. As a special case, if Start Row has a value of –1, the entire window is selected. The active cell in the data window is moved to the location specified by Start Row, Start Column. The selection addresses for both row and column positions begin at zero and are counted from the upper-left corner of the data window (position 0,0).

Example: In the active data window, select rows 5–15, in columns 1–3.

```
#SELECTION
  5  15  1  3
#END
```

Example: Select the entire data window.

```
#SELECTION
  -1
#END
```

**#SET_DIRECTORY** - This command sets the default directory. The syntax for this command follows:

```
#SET_DIRECTORY
    directory = STRING    (STRING is a fully or partially qualified path to the desired directory. Note: The path should end in a colon if the last item is not a file.)
#END
```

Example: Move up one directory.

```
#SET_DIRECTORY
    directory = "::"
#END
```

Example: Change the current directory to the Data folder.

```
#SET_DIRECTORY
    directory = "Macintosh HD:KaleidaGraph 4.0:Examples:Data:"
#END
```

Example: Set the default directory to be the program directory.

```
#SET_DIRECTORY
    directory = ""
#END
```
12.2.3 Example Formula Scripts

The examples in this section follow the same basic format. An overview describes the goal of the script. Then the example script is listed, just as it would appear if it were being entered directly into the Posted Note of the Formula Entry window. Following the script is an explanation of each step in the script.

**Note:** The Scripts folder (Examples folder) contains these three example formula scripts. The paths in the scripts have been modified to be correct for your particular platform.

**Basic Example**

This example script performs the following functions:

- Selects a portion of the data window.
- Executes four Formula Entry functions, two of which generate columns of data.
- Copies the data and the titles to the Clipboard.
- Pastes the information into another part of the data window.

The example script is listed below, followed by a description of how it operates.

```plaintext
#SELECTION
0 99 0 1
#END

#FORMULA
C0 = index() + 1;
C1 = log(C0);
nname("Series", C0);
nname("log(x)", C1);
#END

#COPY
title = true -1
#END

#PASTE
title = true 10 110 2 2
#END
```

The #SELECTION command selects rows 0 through 99 in the first two data columns. The #FORMULA command executes formulas which operate only on the selected data cells. The formulas create a data series from 1 to 100 in the first column, calculate the log of each value in the second column, and name the two columns.

The #COPY command copies the entire data window, including titles, because the starting row is set to -1. Finally, the #PASTE command pastes the information on the Clipboard into the data window, starting at row 10 in the third data column.
**Intermediate Example**

This example script performs the following functions:

- Imports a tab-delimited text file.
- Executes two Formula Entry functions.
- Creates a Scatter plot of the raw data.
- Exports the plot to the printer.

The example script is listed below, followed by a description of how it operates.

```plaintext
#DATAFILE
directory = "Macintosh HD:KaleidaGraph 4.0:Examples:Data:example.txt"
delimiter = tab
skip = 0
read_titles = TRUE
del_number = 1
#END

#FORMULA
c3 = (c1 + c2) /2;
name("Average", c3);
#END

#SCRIPT
auto_print = true
print_mode = single
plot_type = scatter
begin_group
title = "Sample Script Plot"
legend = "Mean of Test Data"
x = 0
y = 3
end_group
#END
```

The #DATAFILE opens the specified text file. The text file is imported as a tab-delimited file which has a single tab between data values, skipping zero lines, and reading the first line as titles. The #FORMULA command executes two Formula Entry commands which calculate the average of two columns and place a title in the output column.

The #SCRIPT command generates a Scatter plot from the calculated data. The plot title and legend information are set directly via the title and legend options within the script. After the plot is created, it is automatically exported to the printer.
Advanced Example  
This example script performs the following functions:

- Sets the program directory as the default directory.
- Opens a data file.
- Makes a selection in the data window.
- Plots the selected data as a Stack Column plot.
- Exports the plot as a TIFF file, scaling the image by 50%.

The example script is listed below, followed by a description of how it operates.

```
#SET_DIRECTORY
directory = ""
#END

#DATAFILE
file = ":Examples:Data:Housing Starts.QDA"
#END

#SELECTION
0 5 0 3
#END

#SCRIPT
y axis title "Range"
y axis limits 0 450
plot_type = stack_column
begin_group
x = 0
y = 1
y = 2
y = 3
end_group
#END

#PICT/OPT
type = tiff
scale = 50
file = "Example.tif"
#END
```

The #SET_DIRECTORY command sets the program directory to be the default path. The #DATAFILE command opens the Housing Starts data file. The path to this file begins in the same directory as the program. Since the path to this file does not start at the root directory, the path begins with a colon (:).

The #SELECTION command selects the first six rows in the data set. The #SCRIPT command creates a Stack Column plot of the selected data. The title and limits for the Y axis are defined within this command. The plot is then exported as a TIFF file with 50% reduction using the #PICT/OPT command. The TIFF file is given the specified name and is saved in the same directory as the program.
KaleidaGraph provides a library that can be used to define variables, constants, and functions for use in Formula Entry, a Function plot, or a General curve fit. Using the library, you can create shorthand references to values and functions that you use on a regular basis.

This chapter explains how to:
- Use the proper syntax when defining functions in the library.
- Define variables, constants, mathematical functions, and curve fit functions in the library.
- Load a saved library file.
- Save the current library as a text file and as part of a Macros file.
- Create a new library.

### 13.1 Overview of the Library

The library is displayed by choosing either Macros > Library or Curve Fit > General > Library. The current library is displayed in a text editor. You can use the editor to modify the current library, open a saved library, or create a new library.

The default library provided with KaleidaGraph contains a number of definitions for variables, constants, math functions, and curve fit equations. The definitions are grouped together to make it easier to locate a particular function, but this is not a requirement. You can place the definitions in any order you choose.

One of the main reasons for using the library is to form aliases or shorthand references for functions, variables, and constants. This is particularly useful for defining sections of a formula that exceed the 256 character limit in the Formula Entry, Function plot, and General curve fit windows.

KaleidaGraph searches the current library for any substitutions and makes them before proceeding. You may want to enclose the definition with parentheses to maintain the proper syntax after the substitution takes place.

Any definitions that you add to the library appear automatically in the Library menu. This menu is available in the Formula Entry window as well as in the Posted Note window for Formula Entry.
13.2 Library Syntax

The syntax used in the library is similar to what is used when creating multi-line formulas in Formula Entry. Each function should begin on a new line and terminate with a semicolon.

When creating names for your functions, keep the following in mind:

- Do not assign the function a name that is used elsewhere in the program (column numbers, memory registers, Formula Entry commands, and so on).
- Use at least two characters in the function name.
- Do not use any spaces, dashes, or underscores in the function name.
- The library is not case sensitive. If two functions named S1() and s1() are defined, KaleidaGraph will substitute the last one that it finds in the library.

Comments can be included anywhere in the library through the use of a semicolon. Anything after the semicolon to the first occurrence of a carriage return is treated as a comment.

Note: A special case occurs if the semicolon is preceded by a backslash (\). In this case, the information after the semicolon is treated as a continuation of the function. This syntax is normally used to set up initial conditions when defining a curve fit equation in the library, but it can also be used to string multiple formulas together. Sections 13.5 and 13.6 include example definitions that make use of the backslash.

13.3 Defining Variables in the Library

Variable definitions can be used anytime you want to make use of the memory registers in a function or curve fit equation. The five variable definitions in the default library enable you to use x, a, b, c, and d in place of m0, m1, m2, m3, and m4, respectively. Additional variables can be defined by following this syntax:

```
variable1 = memory_register;
variable2 = memory_register;
```

To add a variable definition to the library:

1. Choose Macros > Library or Curve Fit > General > Library to display the contents of the library.
2. Locate the section of the library that includes the current variable definitions. The definition can be placed anywhere in the library, but it makes it easier to find if the definitions are grouped together.
3. Enter the variable definition on a new line, making sure to terminate the definition with a semicolon.
4. Choose File > Close to leave the library. The definition is now available for use in Formula Entry, a Function plot, or a General curve fit.

Some example variable definitions are shown below:

```
Ymin = m1;
Ymax = m2;
IC50 = m3;
Slope = m4;
```
13.4 Defining Constants in the Library

Constant definitions can be created for any value that is used on a regular basis. The default library includes one constant definition, \( e = \exp(1) \). Additional constants can be defined by following this syntax:

\[
\begin{align*}
\text{constant1} &= \text{value}; \\
\text{constant2} &= \text{value};
\end{align*}
\]

To add a constant definition to the library:

1. Choose Macros > Library or Curve Fit > General > Library to display the contents of the library.
2. Locate the section of the library that includes the current constant definitions. The definition can be placed anywhere in the library, but it makes it easier to find if the definitions are grouped together.
3. Enter the constant definition on a new line, making sure to terminate the definition with a semicolon.
4. Choose File > Close to leave the library. The definition is now available for use in Formula Entry, a Function plot, or a General curve fit.

Some example constant definitions are shown below:

\[
\begin{align*}
\text{DtSYR} &= .004805; \\
\text{LSYR} &= .01027; \\
\text{XSYR} &= .318; \\
\text{Wa} &= 55.5;
\end{align*}
\]

13.5 Defining Mathematical Functions in the Library

Any individual or multi-line formula that you run in the Formula Entry window can be defined in the library. The default library contains a number of mathematical and miscellaneous functions that perform various operations on the data window. Each of these definitions follows the same basic structure:

\[
\text{functionname(var1, var2, ...) = definition;}
\]

- **functionname** is the name assigned to the definition in the library.
- **var1, var2, and so on** represent any variables that are used in the formula. The variables can represent column numbers or memory registers. The names of the variables do not have to be defined elsewhere before using them.
- **definition** is the formula that is being defined. If you are entering multiple formulas for the definition, each of the definitions except for the last one should have a backslash (\) prior to the semicolon.
To add a definition for a mathematical function to the library:

1. Choose **Macros > Library** or **Curve Fit > General > Library** to display the contents of the library.
2. Locate the section of the library that includes the current mathematical functions. The definition can be placed anywhere in the library, but it makes it easier to find if the definitions are grouped together.
3. Enter the mathematical function on a new line, making sure to terminate the definition with a semicolon.
4. Choose **File > Close** to leave the library. The definition is now available for use in Formula Entry.

Some example mathematical functions are shown below:

\[
colseries(x, a, b) = (x = a + b \times \text{index}());
\]
\[
\text{residual}(x, y) = (\text{gen}(x, y) - y);
\]
\[
\text{pisinc5x}(x, y) = (x = (\pi/99 \times \text{index}()) - \pi/2); y = ((x) == 0.0) ? 1 : (\sin(5 \times x)/(x));
\]

Figure 13-1 shows how to call one of the example definitions from within Formula Entry.
13.6 Defining Curve Fit Functions in the Library

Any valid curve fit function can be defined in the library. The default library contains a number of curve fit functions for use in the General curve fit. Each of these definitions follows the same basic structure:

\[
\text{fitname}(a0, b0, \ldots) = \text{definition};
\]
\[
a = a0; \quad b = b0;
\]

- \textit{fitname} is the name assigned to the curve fit definition in the library.
- \textit{a0}, \textit{b0}, and so on represent any unknown parameters that are used in the curve fit.
- \textit{definition} is the curve fit function that is being defined.
- the second line of the definition \((a=a0; b=b0;\)) allows the initial guesses for the parameters to be included when using the shorthand reference.

13.6.1 Creating a Basic General Curve Fit Definition

This example defines the equation \((a*x)/(b+a*x)\) in the library.

To add the definition to the library:

1. Choose \textbf{Macros > Library} or \textbf{Curve Fit > General > Library} to display the contents of the library.
2. Locate the section of the library that includes the current curve fit definitions. The definition can be placed anywhere in the library, but it makes it easier to find if the definitions are grouped together.
3. Enter the following definition on a new line:

\[
sample1(a0,b0) = (a*x)/(b+a*x); \quad a = a0; \quad b = b0;
\]

4. Once the definition is entered, choose \textbf{File > Close} to leave the library. The definition is now available for use in the Curve Fit Definition dialog or in a Function plot.

Figure 13-2 shows how to call the library definition from within the Curve Fit Definition dialog. Because of the two commands \((a=a0; b=b0;)\) that follow the main definition in the library, initial guesses can be entered directly into the curve fit definition.
13.6.2 Creating a Complex General Curve Fit Definition

Now that a basic curve fit definition has been defined, let’s create a more complex curve fit definition. This example creates a definition for the following equation:

\[ a \cdot \exp\left(-\left(x-b\right)^2/(c^2)\right) + d \cdot \exp\left(-\left(x-f\right)^2/(g^2)\right) + h \cdot \exp\left(-\left(x-i\right)^2/(j^2)\right) \]

To add this definition to the library:

1. Open the library again so that the definition can be added. The following commands should be added to the existing Variable Definitions. These commands are necessary to define a formula that uses all of the parameters available (m1–m9).

\[
\begin{align*}
  f & = m5 \\
  g & = m6 \\
  h & = m7 \\
  i & = m8 \\
  j & = m9 \\
\end{align*}
\]

2. Add the following commands to the existing Curve Fit Definitions.

\[
\begin{align*}
  \text{form1}() & = a \cdot \exp\left(-\left(x-b\right)^2/(c^2)\right); \\
  \text{form2}() & = d \cdot \exp\left(-\left(x-f\right)^2/(g^2)\right); \\
  \text{form3}() & = h \cdot \exp\left(-\left(x-i\right)^2/(j^2)\right); \\
  \text{sample2}(a0, b0, c0, d0, f0, g0, h0, i0, j0) & = \text{form1}() + \text{form2}() + \text{form3}(); \\
  a & = a0; b = b0; c = c0; d = d0; f = f0; g = g0; h = h0; i = i0; j = j0; \\
\end{align*}
\]

Notice the original equation has been split into three smaller parts and all three parts are tied together into one formula. This makes it possible to use curve fit definitions that are longer than the 256 character limit in the Curve Fit Definition dialog.

Figure 13-3 shows how to call the library definition from within the Curve Fit Definition dialog. The name of the definition is entered, followed by all of the initial guesses.

![Figure 13-3  Curve Fit Definition dialog](image-url)
13.7 Loading a Saved Library File

KaleidaGraph provides several library files within the Library folder (Examples folder). Most of these contain curve fit definitions, although the default library (Library.txt) that ships with KaleidaGraph is also included in this folder should you ever need to reload the original library.

To load a saved library:
1. Choose Macros > Library or Curve Fit > General > Library.
2. Choose File > Open.
3. Locate and open the library file to be imported. This library will replace the current library.
4. Choose File > Close to leave the library.

13.8 Saving the Current Library

There are two ways to save the current library. The library can be exported as a text file which can be reloaded at a later time. The library can also be exported as part of the Macros file.

To save the current library as a text file:
1. Choose Macros > Library or Curve Fit > General > Library to display the contents of the library.
2. Choose File > Save As.
3. Give the file an appropriate name and click Save.
4. Choose File > Close to leave the library.

To save the current library as part of a Macros file, save the Macros file by choosing File > Export > Macros.

13.9 Creating a New Library

To create a new library:
1. Choose Macros > Library or Curve Fit > General > Library.
2. To save a copy of the current library, use the Save As command (File menu).
3. Choose File > New to start a new library.
4. Enter your new definitions, making sure to terminate each one with a semicolon.
5. When completed, save the new library to disk.
6. Choose File > Close to leave the library. If you want to load a different library, load it before closing the window.
KaleidaGraph’s Settings Files

Appendix A

KaleidaGraph maintains four settings files to save the modifications made to the program. These files are opened each time you start KaleidaGraph, provided they are in the correct location and have the correct file name. If a settings file has a different name or is located in a different directory, the file is skipped.

A.1 Style Files

Style files contain the settings for most of KaleidaGraph’s dialogs. Any changes made to the original defaults, such as text attributes, plot layout, and dialog settings, are saved in the Style file.

A default Style file is automatically opened each time KaleidaGraph is started. This way you can save the settings and have them opened the next time you use the program.

The default settings file is named KG Style. This file must be in the KaleidaGraph Preferences folder or in the same folder as KaleidaGraph for it to be opened. The KaleidaGraph Preferences folder is located in the Preferences folder (in the user’s Library folder).

Custom Style files can be created by choosing File > Export > Style. These files can be opened by choosing Open or Import > Style from the File menu. All of the settings change to reflect the contents of the new Style file.

A.2 Macros Files

Macros files contain the macros in the Macros menu, the contents of the library, any formulas assigned to the function buttons in Formula Entry, the settings in the Text File Input Format dialog, the keyboard shortcuts, and the curve fits in the General submenu.

A default Macros file is automatically opened each time KaleidaGraph is started. This way you can save the settings and have them opened the next time you use the program.

The default settings file is named KG Macros. This file must be in the KaleidaGraph Preferences folder or in the same folder as KaleidaGraph for it to be opened. The KaleidaGraph Preferences folder is located in the Preferences folder (in the user’s Library folder).

Custom Macros files can be created by choosing File > Export > Macros. These files can be opened by choosing Open, Import > New Macros, or Import > Append Macros from the File menu. All of the affected menus and options change to reflect the contents of the new Macros file.
A.3 Layout Files

KaleidaGraph can save two types of Layout files: basic Layout files and Group Layout files. The only difference between the two types of files is how they handle the plots within the layout window.

A basic Layout file stores the following information: size and position of the cells, the contents and location of any text labels or objects, and the background settings. The plots are not saved as part of the layout file.

Group Layout files provide the added benefit of saving a copy of each plot embedded within the Layout file. This allows you to organize your plots, save a Group Layout file, and open a single file at a later date to make changes to any of the original plots.

A default Layout file is automatically opened each time KaleidaGraph is started. This way you can save a layout and have it opened the next time you use the program. You can access the default layout by choosing **Windows > Show Layout > KG Layout**.

The default settings file is named **KG Layout**. This file must be in the **KaleidaGraph Preferences** folder or in the same folder as KaleidaGraph for it to be opened. The **KaleidaGraph Preferences** folder is located in the **Preferences** folder (in the user’s **Library** folder).

Custom Layout files can be created by choosing **File > Save Layout As** when a layout window is active. These files can be opened by choosing **File > Open**. The layout opens into a new window, displaying any items that were saved as part of the layout.

A.4 Script Files

Script files contain the settings and group selections from the Plot Script window.

If one has been created, a default Script file is automatically opened each time KaleidaGraph is started. This way you can save the plot script and have it opened the next time you use the program.

The default settings file is named **KG Script**. This file must be in the **KaleidaGraph Preferences** folder or in the same folder as KaleidaGraph for it to be opened. The **KaleidaGraph Preferences** folder is located in the **Preferences** folder (in the user’s **Library** folder).

Custom Script files can be created by choosing **File > Save Script As** when the Plot Script window is active. These files can be opened by choosing **File > Open**. The Plot Script window changes to reflect the contents of the new Script file.
Toolbox Shortcuts

B.1 Shortcuts for Selecting Plot Tools

This chapter lists the shortcuts available for selecting plot tools and making changes to plot elements directly from the toolbox. The online Help contains information about the other kinds of shortcuts available in KaleidaGraph.

The table below lists the keyboard shortcuts available for selecting the various plot tools.

<table>
<thead>
<tr>
<th>To:</th>
<th>Press:</th>
</tr>
</thead>
<tbody>
<tr>
<td>Select the Selection Arrow</td>
<td>Spacebar</td>
</tr>
<tr>
<td>Select the Text tool</td>
<td>T</td>
</tr>
<tr>
<td>Select the Line/Arrow tool</td>
<td>L</td>
</tr>
<tr>
<td>Select the Box tool</td>
<td>1</td>
</tr>
<tr>
<td>Select the Rounded-Rectangle tool</td>
<td>2</td>
</tr>
<tr>
<td>Select the Oval tool</td>
<td>3</td>
</tr>
<tr>
<td>Select the Polygon tool</td>
<td>4</td>
</tr>
<tr>
<td>Select the Arc tool</td>
<td>5</td>
</tr>
<tr>
<td>Select the Bezier curve tool</td>
<td>6</td>
</tr>
<tr>
<td>Activate whatever Object tool is selected in the pop-up menu</td>
<td>O</td>
</tr>
<tr>
<td>Select the Table tool</td>
<td>A</td>
</tr>
<tr>
<td>Select the Eraser tool</td>
<td>E</td>
</tr>
<tr>
<td>Select the Identify tool</td>
<td>I</td>
</tr>
<tr>
<td>Select the Data Selection tool</td>
<td>S</td>
</tr>
<tr>
<td>Select the Zoom Selection tool</td>
<td>Z</td>
</tr>
<tr>
<td>Activate the last tool selected</td>
<td></td>
</tr>
</tbody>
</table>
B.2 Changing Axis Options from the Toolbox

Before using the toolbox to change the axis options, an axis must be selected by clicking twice on the desired axis. The bottom portion of the toolbox will display the icons shown to the right.

B.2.1 Exchanging and Removing Axes

To exchange or remove axes:

1. Select the desired axis.
2. Click the first Axis Options icon to display the pop-up menu shown below.

   ![Swap X & Y](image)
   ![No Axis](image)

3. Turn on **Swap X & Y** to exchange the X and Y axes or **No Axis** to remove the selected axis and its tick marks.

B.2.2 Axis Scaling, Reversing, and Auto Limits

To change scaling, reverse an axis, or return to auto limits:

1. Select the desired axis.
2. Click the second Axis Options icon to display the pop-up menu shown below.

   ![Log](image)
   ![Linear](image)
   ![Reverse](image)
   ![AutoScale](image)
   ![Major](image)
   ![Minor](image)
   ![Format](image)

3. Choose **Log** or **Linear** to change the axis scaling, turn on **Reverse** to reverse the axis, or turn on **AutoScale** to return to the limits originally calculated by KaleidaGraph. The rest of the options are discussed in Sections B.2.4–B.2.6.

B.2.3 Linking Axes

To link the X2 or Y2 axes:

1. Select the X2 or Y2 axis.
2. Click the second of the two Axis Options icons to display the pop-up menu shown below.

   ![Log](image)
   ![Linear](image)
   ![Reverse](image)
   ![AutoScale](image)
   ![Major](image)
   ![Minor](image)
   ![Format](image)
   ![Link](image)
3. Choose **Link** to display the submenu shown below.

| No Ticks, No Labels | X Axis, No Labels | X Axis, X Labels | ✓ Custom Axis, Custom Labels |

4. Choose the type of link to be used for the selected axis.

### B.2.4 Tick Marks

To change the display of tick marks or let KaleidaGraph calculate the number of ticks:

1. Select the appropriate axis.
2. Click the second of the two Axis Options icons to display the pop-up menu shown below.

3. Choose **Major** or **Minor** to display a submenu that contains the tick mark options. The submenus for Major and Minor are identical.

4. Use the **Inside** and **Outside** commands to change how the ticks are displayed. Turn on **Auto** to have KaleidaGraph calculate the number of tick marks displayed on the selected axis.

### B.2.5 Grid Lines

To change how the grid lines are displayed:

1. Select the appropriate axis.
2. Click the second of the two Axis Options icons to display the pop-up menu shown below.
3. Choose **Major** or **Minor** to display a submenu that contains the grid line options. The submenus for Major and Minor are identical.

![Grid Options](image)

4. Turn on **Grid** to display a gray (dotted) line or **Solid** to display a solid line. If both items are turned off, grid lines are not displayed.

### B.2.6 Axis Labels

To change the display of the axis labels:

1. Select the desired axis.
2. Click the second of the two Axis Options icons to display the pop-up menu shown below.

![Axis Options](image)

3. Choose **# Format** to display a submenu that contains the display options. The options in the submenu depend on the format of the data plotted along the selected axis. The following three figures show the submenus that appear for Numeric (Float, Double, or Integer), Date, and Time formats.

![Numeric Formats](image)

![Date Formats](image)

![Time Formats](image)

Using these options, you can change the format of the axis labels as well as display trailing zeros, commas, a prefix, or a suffix. Changes are based on the settings for the current axis in the Axis Options dialog (**Plot** menu).

4. Make the desired changes to the submenu.
B.3 Changing Variable Settings from the Toolbox

Before using the toolbox to change the variable settings, a plot symbol must be selected in the legend by clicking twice on the symbol. The bottom portion of the toolbox will display the Variable Settings icons shown to the right.

B.3.1 Variable Color

To change the variable color from the toolbox:

1. Select a plot symbol in the legend.
2. Click the Variable Color icon to display a color palette containing the current color choices.
3. Select a different color from the palette.

B.3.2 Marker Type, Size, or Number of Markers

To change the marker type, size, or number of markers displayed:

1. Select a plot symbol in the legend.
2. Click the Marker icon to display the pop-up menu shown below.
3. Select a different marker type, size, or number from the pop-up menu.

B.3.3 Fill Pattern

To change the fill pattern of the variable:

1. Select a plot symbol in the legend.
2. Click the Fill Pattern icon to display the pop-up menu shown below.
3. Select a different fill pattern from the pop-up menu.
B.3.4 Variable Line Style or Width

To change the variable’s line style or width:

1. Select a plot symbol in the legend.
2. To change the line style, click the left portion of the Style icon and select a different line style. The active line style is enclosed in a dotted box.
3. To change the line width, click the right portion of the Style icon and select a different line width. The active line width is enclosed in a dotted box.

---

B.4 Changing Plot Color from the Toolbox

Before using the toolbox to change the plot colors, either the plot frame or an axis must be selected. If the frame is selected, you can edit the interior and background colors. If an axis is selected, you can change the frame and grid colors.

B.4.1 Interior and Background Colors

To change the interior or background colors from the toolbox:

1. Click any of the axes once to select the plot’s frame. The bottom portion of the toolbox will display the icons shown to the right.

   The Color icon controls the interior and background color. It consists of two sections: an interior color icon (upper-left) for setting the plot’s interior color, and a background icon (lower-right) for setting the background color.

2. Click one of the icons in the palette to display a color palette containing the color choices.

3. Select a different color from the palette.
To make the interior or background of the plot transparent:

1. Click any of the axes once to select the plot’s frame. The bottom portion of the toolbox will display two icons.
2. Click the bottom icon to display the following pop-up menu.

   ![No Interior
   ![No Background

3. Turn on either of the commands in this pop-up menu to make that portion of the plot transparent.

**B.4.2 Frame and Grid Colors**

To change the frame or grid colors from the toolbox:

1. Select one of the plot’s axes. The bottom portion of the toolbox will display the icons shown to the right.

   The first icon controls the frame and grid color. It consists of two sections: a frame color icon (upper-left) for setting the plot’s frame color, and a grid icon (lower-right) for setting the grid color.

2. Click one of the icons in the palette to display a color palette containing the color choices.

3. Select a different color from the palette.

**B.5 Changing Text Attributes from the Toolbox**

Holding down the mouse button after clicking the Text tool displays the pop-up menu shown below. You can use this pop-up menu to change the attributes of selected text objects directly from the toolbox. If a selection is not present in the plot window, the default attributes can be set for any text labels created with the Text tool.
To change the attributes of a text label directly from the toolbox:

1. Select the label(s) to be modified.
   - Individual labels are selected by clicking the label once with either the Text tool or Selection Arrow.
   - Legend text is selected by clicking the label once with the Text tool.
   - Axis or value labels are selected as a group by clicking any of the labels in the group with the Selection Arrow. They may also be selected individually by clicking with the Text tool.
   - Multiple text labels can be selected by pressing **Shift** and clicking each label with the Selection Arrow.
   - All of the text labels can be selected at once by choosing **Edit > Select All**. Everything in the plot is selected, but changes made using the Text tool only affect text objects.

2. Click the Text tool and hold down the mouse button to display the pop-up menu.
3. Choose any of the commands in the pop-up menu. Choosing any of the commands except **Erase Background** displays a submenu that contains the options for that item.
4. Continue making selections from the pop-up menu until all of the labels are set up as desired.

To set the default attributes:

1. Verify that a selection is not present in the plot window.
2. Click the Text tool and hold down the mouse button to display the pop-up menu.
3. Choose any of the commands in the pop-up menu. Choosing any of the commands except **Erase Background** displays a submenu that contains the options for that item.
4. Make the desired changes in the pop-up menu.

Any text objects that you create with the Text tool have these attributes. The attributes that you set are saved as part of the Style file. You can also use the **Text Options** command (**Plot** menu) to set the defaults for standard text labels.
This chapter provides information on the methods and equations used in different areas of the program.

C.1 Box Plot Definition

Each box encloses 50% of the data with the median value of the variable displayed as a line. The top and bottom of the box mark the limits of ± 25% of the variable population. The lines extending from the top and bottom of each box mark the minimum and maximum values within the data set that fall within an acceptable range. Any value outside of this range, called an outlier, is displayed as an individual point.

**Note:** Outliers are used in the calculations for the Box plot. Removing outliers changes the entire plot. You do not have any control over the marker used to represent outliers.

- **Median** - The data value located halfway between the smallest and largest values.
- **Upper Quartile (UQ)** - The data value located halfway between the median and the largest data value.
- **Lower Quartile (LQ)** - The data value located halfway between the median and the smallest data value.
- **Interquartile Distance (IQD)** - The distance between the Upper and Lower Quartiles (UQ - LQ).
- **Outliers** - Points whose value is either:
  - greater than UQ + 1.5 * IQD  
  - or  
  - less than LQ - 1.5 * IQD
C.2 Statistics Equations

- **Number of data points**: $n = \text{number of data points}$
- **Current data value**: $x_i = \text{current data value (from 1 to n)}$
- **Mean**: $\bar{x} = \frac{1}{n} \sum_{i=1}^{n} x_i$
- **RMS (Root Mean Square)**: $\left[ \frac{1}{n} \sum_{i=1}^{n} x_i^2 \right]^{1/2}$
- **Standard Deviation**: $\sqrt{\frac{\sum_{i=1}^{n} x_i^2 - n(\bar{x})^2}{n-1}}$
- **Standard Error**: $\frac{\text{Standard Deviation}}{\sqrt{n}}$
- **Variance**: $\frac{\sum_{i=1}^{n} x_i^2 - n(\bar{x})^2}{n-1}$
- **Skewness**: $\frac{1}{n} \sum_{i=1}^{n} (x_i - \bar{x})^3 \left( \frac{1}{n} \sum_{i=1}^{n} (x_i - \bar{x})^2 \right)^{3/2}$
- **Kurtosis**: $\frac{1}{n} \sum_{i=1}^{n} (x_i - \bar{x})^4 \left( \frac{1}{n} \sum_{i=1}^{n} (x_i - \bar{x})^2 \right)^{2} - 3$
C.3 Student t-Test Equations

\( \bar{x} \) = mean of the data \quad N = number of data points \quad x_i \) and \( y_i \) = current data value (from 1 to N)

**t value (single sample)**

\[
t = \frac{\bar{x} - \text{Test Value}}{\text{Standard Error}(x)}
\]

**t value (paired data)**

\[
t = \frac{\bar{x}_A - \bar{x}_B}{s_D}
\]

\[
s_D = \sqrt{\frac{\text{Var}(x_A) + \text{Var}(x_B) - 2 \text{Cov}(x_A, x_B)}{N}}
\]

\[
\text{Cov}(x_A, x_B) = \frac{1}{N - 1} \sum_{i=1}^{N} (x_{A,i} - \bar{x}_A)(x_{B,i} - \bar{x}_B)
\]

**t value (unpaired data with equal variance)**

\[
t = \frac{\bar{x}_A - \bar{x}_B}{s_D}
\]

\[
s_D = \sqrt{\frac{\sum_{i \in A} (x_i - \bar{x}_A)^2 + \sum_{i \in B} (x_i - \bar{x}_B)^2}{N_A + N_B - 2} \left( \frac{1}{N_A} + \frac{1}{N_B} \right)}
\]

**t value (unpaired data with unequal variance)**

\[
t = \frac{\bar{x}_A - \bar{x}_B}{\sqrt{\text{Var}(x_A)/N_A + \text{Var}(x_B)/N_B}}
\]

**Correlation**

\[
\frac{\sum_i (x_i - \bar{x})(y_i - \bar{y})}{\sqrt{\sum_i (x_i - \bar{x})^2 \sum_i (y_i - \bar{y})^2}}
\]

**F value**

Larger Variance

Smaller Variance
C.4 Statistical References

**Wilcoxon Signed Rank, Wilcoxon-Mann-Whitney, Kruskal-Wallis, and Friedman Tests**


**One Way ANOVA, Two Way ANOVA, Tukey HSD, Student-Newman-Keuls, and Scheffe Tests**


**Wilcoxon Matched Pairs and Dunnett Tests**

**One Way Repeated Measures ANOVA, Two Way Repeated Measures ANOVA, Bonferroni, and Holm Tests**

**Fisher’s LSD Test**
**C.5 Curve Fit References**

**General Curve Fit**

**Linear, Polynomial, Exponential, Logarithmic, and Power Curve Fits**

**Smooth Curve Fit**

**Weighted Curve Fit**

**Cubic Spline Curve Fit**

**Interpolate Curve Fit**
C.6 Pearson’s R and Chi Square Equations

Pearson’s R (Least Squares curve fits)

\[ R = \frac{N \sum x_i y_i - \sum x_i \sum y_i}{\sqrt{N \sum x_i^2 - (\sum x_i)^2} \sqrt{N \sum y_i^2 - (\sum y_i)^2}} \]

Pearson’s R (General curve fit)

\[ R = \sqrt{1 - \frac{\chi^2}{\sum \sigma_i (y_i - \bar{y})^2}} \]

Chi Square

\[ \chi^2 = \sum \left( \frac{y_i - f(x_i)}{\sigma_i} \right)^2 \]
Glossary

**active window:** The frontmost window in the program. The active window’s title bar is highlighted.

**Align tool:** A tool used to align a group of selected objects in the plot or layout window.

**analysis of variance (ANOVA):** A statistical test that compares the means of two or more groups for a statistically significant difference. KaleidaGraph provides four ANOVA tests: one way, two way, one way repeated measures, and two way repeated measures.

**anchor point:** An endpoint on a segment of a Bezier curve. Anchor points contain direction points and tangent lines. The position of the anchor points and their direction points determine the shape of the curve segment.

**anchor tick:** The anchor tick specifies the value from which all other major tick marks are calculated. When placing major ticks at a specific interval, the interval is counted from the value of the anchor tick. This tick does not have to be at the edge of the axis; it can be placed anywhere.

**AppleScript:** A system-level scripting language available on the Macintosh. It is used to automate processes within programs that support AppleScript.

**Apple Event:** A system-level command sent between programs. The command tells the destination program to perform a specific operation.

**Arc tool:** A tool used to draw arcs in the plot or layout window.

**axis:** One of the horizontal or vertical lines in a plot along which values or categories are plotted.

**axis labels:** Labels that display the values associated with the major tick marks on the plot.

**axis titles:** Titles that are used to identify which variable is plotted along an axis. The titles are taken from the column names being plotted. If multiple variables are plotted on the same axis, the title comes from the first column being plotted.

**background color:** The color KaleidaGraph uses to represent white pixels in fill and pen patterns.

**Bezier curve:** A curve made up of one or more segments. Each segment is defined by four points: two anchor points, which determine the endpoints, and two direction points, which determine its shape.

**Boolean:** A value that results from evaluating an expression. The value can be either true (non-zero) or false (zero).

**Box tool:** A tool used to draw squares and rectangles in the plot or layout window.

**cell:** The basic unit of a data window where values are entered and stored.

**Clipboard:** A window that contains the last selection that was cut or copied. The contents remain until the next time you cut or copy a selection.
**column**: In the data window, a vertical line of cells. A maximum of 1000 columns are available. In a column plot, columns are the vertical bars that represent the data values.

**column title**: The name identifying a column in the data window.

**column numbers**: Column numbers range from 0 to 999 and need to be preceded by a c when used in a formula (c0, c1, and so on). To display the column numbers, click the Expand/Collapse button in the data window. Please note that when a selection is made in the data window, the first column in the selection becomes column 0.

**Command key**: This key ( ) enables you to use keyboard shortcuts to choose commands.

**comments**: Notes added to a macro or function to make it easier to follow.

**curve fitting**: The process of applying one of 10 different types of fits to a variable in the plot window. The fits can be used to find an equation for the data, to smooth the curve between the points, or to see how closely the data compares to a specific equation.

**Data Selection tool**: A tool used to select a portion of the data on a plot for further plotting and analysis.

**data window**: A worksheet used to enter and store data for plotting and analysis.

**default settings**: Settings that KaleidaGraph uses unless you specify different settings. You can save the current settings as default settings by choosing File > Export > Style.

**degrees of freedom**: This is a measure of the sample size, which affects the power of the statistical test.

**delimiter**: A character used to separate data within a text file; for example, tabs, spaces, or commas.

**Eraser tool**: A tool used to delete text and other objects (such as lines, boxes, and pictures) from the plot or layout window.

**error bars**: Vertical or horizontal lines on a plot that illustrate the statistical error of the data.

**extract**: To retrieve the original data from a plot which was saved with data. You can use either the Extract Data command or the Extract button ( ) to display the plot’s data.

**Extract button**: This button ( ) is located in the upper-right corner of the plot and layout windows. In the plot window, clicking this button displays data windows referenced by the plot. In the layout window, clicking this button displays the plots associated with the current layout.

**fill pattern**: A pattern chosen from the pattern palette to fill a selected object.

**foreground color**: The color KaleidaGraph uses to represent black pixels in fill and pen patterns.

**format**: How the data in a column is displayed. Each column has its own format, which controls the way its values are displayed and used in a plot.

**formula**: A sequence of values, column references, memory references, functions, or operators that generate data from existing data.

**Formula Entry**: A window that is used to enter and execute algebraic formulas which operate on the active data window.
**formula script**: A program written in the Posted Note of the Formula Entry window. Formula scripts can automate the process of opening data, creating plots, and exporting plots to disk or to a printer.

**frame**: The line surrounding a bar, column, pie wedge, legend, or object in the plot or layout window.

**Gaussian equation**: An equation of the form \( m1 + m2 \cdot \exp(- (m0 - m3) \cdot (m0 - m3) / (m4 \cdot m4)) \). A good starting value for \( m1 \) is the value that the tails of the curve approach for large values of \( |x| \). The maximum of the curve can be used for \( m2 \). The mean of the data is a good guess for \( m3 \). The bell-width is a good guess for \( m4 \).

**grid lines**: Horizontal or vertical lines that may be displayed at the major and minor tick marks.

**group**: To combine two or more objects so that they act as a single object.

**Group Layout file**: A special version of the Layout file that saves a copy of each plot embedded within the Layout file.

**handles**: Points at the corners of an object’s boundary which can be used to modify the size and shape of the object.

**Home button**: A button in the data window that can be used to return the window to its origin (row 0, column 0).

**Identify tool**: A tool used to find coordinates of points on a plot.

**indexed data**: A type of data format where a factor column contains the group names, and one or more columns contain the corresponding data values for each group.

**insertion point**: The blinking vertical line that appears whenever you click within a cell or a text dialog.

**justification**: The method used to align text and labels. Text labels can be left, center, or right justified.

**layer**: A separate part of the plot window used to organize objects. You can create plots with several layers, with each layer containing different objects.

**Layout file**: A settings file that contains the cell positions and background, as well as any text or graphic objects in the active layout window. If a Group Layout file is exported, the plots in the layout are embedded in the Layout file.

**Layout window**: A window used to place multiple plots on a single page. Text, tables, and other objects may be placed anywhere in the layout window. The page may be copied to the Clipboard, saved in a variety of formats, or printed.

**legend**: The portion of the plot that contains symbols and labels used to identify each variable in a plot.

**library**: Used to create and store shorthand references for functions, curve fits, constants, and variables.

**Line/Arrow tool**: A tool used to add lines or arrows to the plot or layout window.

**macro**: An RPN program that performs a series of calculations on the active data window.

**Macro Calculator**: An RPN calculator which can be used to write and execute macros that operate on the active data window.
Macros file: A settings file that contains the macros in the Macros menu, the contents of the library, any formulas assigned to the function buttons in Formula Entry, the settings in the Text File Input Format dialog, the keyboard shortcuts, and the curve fits in the General submenu.

major ticks: Marks that display the major divisions along an axis.

marker: A symbol which represents a single data point in the plot window.

minor ticks: Minor ticks display the divisions between the major tick marks.

nonparametric tests: Statistical tests that do not require the data be normally distributed. These tests operate on the ranks of the values. Examples of nonparametric tests include the Wilcoxon, Kruskal-Wallis, and Friedman tests.

object handles: Small squares that appear when an object is selected. The object can be resized by dragging these handles.

Oval tool: A tool used to draw circles and ovals in the plot or layout window.

overlay: To place multiple plots on top of each other in the layout window to get the appearance of a single plot.

P value: This value is a probability, with a value that ranges from zero to one. It is used to determine if there is a statistically significant difference in the groups being analyzed. If this value is below a certain level (usually 0.05), the conclusion is that there is a difference between the groups.

parametric tests: Statistical tests that assume the samples are drawn from populations that are normally distributed. Examples of parametric tests include the t-test and analysis of variance (ANOVA).

pen pattern: A pattern given to the line segments of an object.

PICT: A Macintosh file format used by graphics programs to transfer documents to different programs.

plot script: A series of data selections from any number of data windows that are used to create multiple plots at once. A plot script is created in the Plot Script window.

plot title: The name of the graph. By default, its name is taken from the name of the data window.

plot window: Any window that contains a plot. Plots are created by choosing a plot type from the Gallery menu. When the plot window is active, certain menus are displayed that only affect the plot window.

Polygon tool: A tool used to draw an object with any number of sides in the plot or layout window.

post hoc tests: Post hoc tests (also known as multiple comparisons) are used to isolate the differences between groups when performing a one way or one way repeated measures ANOVA. KaleidaGraph provides the following post hoc tests: Tukey HSD, Student-Newman-Keuls, Bonferroni, Holm, Scheffe, Fisher’s LSD, and Dunnett.

Posted Note: A text editor available in both the data and Formula Entry windows. In the data window, it is used to enter information about the current data set. In Formula Entry, it can be used to write a multi-line formula or a script to automate the plotting process.

raw data: A type of data format where the data values for each group are placed in separate data columns.
**residual**: The difference between an actual data value and a mean or other estimated value.

**Rounded Rectangle tool**: A tool used to draw squares and rectangles which have rounded corners.

**row**: A horizontal line of cells. A maximum of 1 million rows can be displayed in the data window.

**row numbers**: The column of numbers that appear on the left side of every data window.

**Script file**: A settings file that contains the settings and group selections from the Plot Script window.

**Selection Arrow**: A tool used to select, move, and resize objects. This tool is also used to select an object’s properties from pop-up menus.

**shift-click**: To click the mouse button while pressing **Shift**. This technique is used to select multiple objects or deselect individual objects.

**sort key**: A column that contains the values you want to sort by. You can specify three sort keys at a time for each sort.

**Style file**: A settings file that contains the settings for most of KaleidaGraph’s dialogs. Any changes made to the original defaults, such as text attributes, plot layout, and dialog settings, are saved in the Style file.

**Table tool**: A tool used to create tables of data within the plot or layout window.

**template**: Any plot that is used as a base for creating new plots. The new plot has the same characteristics as the template.

**Text tool**: A tool used to create and edit labels in the plot or layout window.

**tick marks**: The lines which indicate the major or minor increments along an axis.

**toolbox**: The floating window which displays the tools available to create and edit items in the plot or layout window.

**ungroup**: To separate a grouped object into its original components.

**Update Plot button**: This button ( ) is located in the toolbar portion of the data window. Click this button to force an immediate update of the plot, using the entire data set, regardless of any selections in the data window. To update the plot using a subset of the data, select the data, press **Shift** or **Option**, and click this button.

**X axis**: The horizontal axis in a plot, which usually represents the independent variable.

**Y axis**: The vertical axis in a plot, which usually represents the dependent variable.

**Zoom Selection tool**: A tool that can be used to quickly change the axis limits.
Index

Symbols

! 87
- 87
!= 88
#CLEAR command 231
#CLEARDATA command 231
#CLOSE command 232
#CLOSE/ALL command 232
#CLOSE/OPT command 232
#COPY command 232
#CUT command 233
#DATA command 233
#DATA/NOTITLE command 233
#DATAFILE command 234
#FORMULA command 234
#MERGEFILE command 235
#OPEN command 236
#PAGE_PRINT command 236
#PASTE command 237
#PICT command 237
#PICT/OPT command 237
#PLOT_PRINT command 237
#SAVE command 238
#SCRIPT command 238
#SELECTION command 240
#SET_DIRECTORY command 240
% 87
&& 88
( ) 87
* 87
+ 87
/ 87
< 87
<= 88
= 88
== 88
> 88
>= 88
?: 88
[ ] 83, 88
^ 87
|| 88

A
abs() function 89

active window, changing 25, 111
Add Rows command 28
Add Values command 135, 140
adding
background or border to a layout 217
comments to a formula script 231
comments to formulas 87
curve fits to Curve Fit menu 176
curve fits to saved plots 177
data to saved plot 133
empty cells to a layout 212
error bars 195–203
lines to Bar/Column plots 136
plots to a layout 212
rows and columns 28
special characters to text 158
subscripts and superscripts to text 158
value labels 135, 140
Adjust Log Baseline check box 134
Align command 154
Align tool
description 143
using 154
aligning objects 154
Allow cell resizing by dragging check box 31
Alpha pop-up menu 76
alternate font 44
analyzing data
one sample 58–60
repeated measurements 69–75
two or more groups 61–68
Anchor Tick field 117, 124
angular axis 137
annotating markers 197
ANOVA
one way 65
one way repeated measures 72
reference 266	
two way 67
two way repeated measures 73
ANOVA command 66, 67, 73–74
Append Columns command 28
applying
Cubic Spline curve fit 172–173
General curve fit 181–182
Polynomial curve fit 171–172
Arc tool
  description 142
  using 161
arcs
  creating 161
  editing 161
  error arcs 200
Arrange Layout command 215
arranging plots 215
arrowheads, editing 161
arrows
  creating 160
  editing 160
Ascending Sort command 46
ASCII files, importing 38–44
aspect ratio 213
assigning formulas to function buttons 82
Auto button 31
Auto Link command 132
Auto Print check box 229
Auto Refresh command 222
Auto Save check box 229
Automatically dispose of old plots check box 112, 225
automating 110, 223–229, 230–243
axes
  editing 116–121
  exchanging 120, 256
  linking 120, 256
  moving 118
axis
  angular 137
  break 119
  hiding 119, 256
  limits 117, 149
  linking a second axis 120
  position 118
  radial 137
  removing 256
  resizing 130–131
  reversing 120, 256
  scaling 256
  thickness 121
axis labels
  description 19
  editing 125–126, 157
  formatting 126, 258
  frequency 126
  removing 126
  reversing 120, 256
axis limits
  setting 117
  Zoom Selection tool 149
Axis Options command 116–126, 129
Axis settings
  Plot Size dialog 214
  Set Plot Size dialog 130
Axis Thickness field 121
axis titles
  description 19
  editing 157
B
background
  adding to a layout 217
  color
    data window 32
    editing plot color 129, 261
    legend 113
    objects 165
Background Color setting 32
Bar charts 99–102, 134–136
Bezier curve tool
  description 142
  using 163–164
Bezier curves
  creating 163
  description 163
  editing 164
Bin Data command 54
Binary Mode command 45
binning data 54–57
Black Column Frame check box 134
Bonferroni test 77, 266
border 217
Box plot
  definition 263
  description 97
Box tool
  description 142
  using 132–133
break
  axis 119
  variable line 37
Bring To Front command 155
buttons
  Expand/Collapse button 33, 81, 270
  Extract button 19, 107, 131–133, 222
  Home button 26
  Posted Note button 33, 86, 230
  Update Plot button 132–133
C
calculating
  curve fit values 188–192
Index

statistics 53, 83–84
with date and time data 85
canceling
  General curve fit 182
cell() function 81, 89
cells
  entering data into 35
  moving between 26
  referencing in formulas 81
  selecting 27
Center Text check box 197
changing
  axis limits 117, 149
  axis position 118
  axis scaling 117, 256
  axis thickness 121
  cap length 203
  color of legend text 115
  column width 31
  data format 45
  data window background color 32
  data window font and style 32
  display of tick marks 123
  fill and pen patterns 113, 166
  foreground and background color 113, 165
  grid line thickness 124
  line styles and widths 114, 166
  magnification 112, 222
  marker thickness 129
  number of tick marks 123
  plot color 129, 260
  plot lines, markers, and fill patterns 127
  row height 31
  tick mark interval 124
  tick mark length 124
  tick mark thickness 124
Chi Square 186
Chi Square equation 268
choosing
  post hoc test 76
  statistical test 57
circles
  creating 161
  editing 161
Clear command 46, 153
Clear Data command 46
clearing data 46
Clipboard 45, 147, 152, 208, 219
Close All Data command 26
Close All Plots command 112
Close command 26, 112
Close/NoSave command 26, 112, 206
closing
data windows 26
plot windows 112
cmax() function 90
cmin() function 90
Coefficient of Determination 186
color
  background 129, 165, 260
  curve fit 128, 193
  curve fit equation 193
  error bars 196
  foreground 165
  grid line 129, 261
  interior 129, 260
  legend text 115
  plot frame 129, 261
  variable 128, 259
Color icon 113, 143–144, 165, 218
Color pop-up menu 193
column
  numbers 33
  width 31
Column Formatting command 30–32, 36–37, 45
Column Formatting palette 30–32, 36–37, 45
Column Offset field 134
Column plot
  adding lines 136
  adding value labels 135
  changing column offset 134
  customizing 134–136
  description 101
  removing column frame 134
Column tab 32
Column Width setting 31
columns
  adding 28
  changing width 31
  deleting 29
  editing titles 44
  formatting 30–32
  inserting 29
  referencing in formulas 81
  selecting 28
  transposing data 47
commands
  Formula Entry 87–92
  formula scripting 231–240
comments
  formula script 231
  formulas 87
  library 246
conditional testing 88
constants, defining in library 247
constraining
parameters 183
shape of objects 152
coordinates 147
Copy command 45
Copy Graph command 208
Copy Layout command 219
Copy Selection command 152
Copy to Clipboard button 53, 55
copying
coordinates 147
curve fit coefficients 187
curve fit values to data window 187
data 45
layouts 219
objects 152
plots to Clipboard 208
residuals to data window 187
corr() function 89
correlation 265
Correlation check box 71
correlation coefficients 186
correlation probability value 71
correlation value 71
cos() function 89
Create Series command 37
creating
arcs 161
arrows 160
Bezier curves 163
circles 161
data series 37–38
formula scripts 230
formulas 81
lines 160
new data window 25
new layout 211
new library 251
ovals 161
plot script 224–225
plots 104
polygons 162
rectangles 161
rounded rectangles 161
rounded squares 161
shapes 160–164
similar plots 108–110
squares 161
tables 145
text labels 156
csum() function 90
Cubic Spline curve fit
applying 172–173
data restrictions 169
description 169
reference 267
curve fit coefficients 185, 186
curve fit definition
constructing 174
defining in the library 249–250
entering custom equation 180
importing 178–179
initial conditions 175
multiple independent variables 183
predefined equations 178–179
Curve Fit Definition dialog 175
curve fit equations
appearance 193
color 193
correlation coefficient display 186
displaying 184
editing 184
format 193
precision 193
Curve Fit menu
adding a new fit 176
rearranging curve fits 176
removing curve fit definitions 177
saving changes 177
Curve Fit Options command 194–195
Curve Fit Points field 194
curve fit results
Chi Square 186
copying fit values to data window 187
copying residuals to data window 187
copying to Calculator 186
copying to Clipboard 186
correlation coefficients 186
displaying the equation 184
editing the equation 184
parameter errors 186
viewing coefficients 185
Curve Fit Settings tab 193
curve fit types
Cubic Spline 169
Exponential 168
General 168
Interpolate 169
Linear 168
Logarithmic 168
Polynomial 168
Power 169
Smooth 169
Weighted 169
curve fits
applying 171–173, 181–182
color 128, 193
defining in the library 249–250
displaying equation 184
displaying only the curve fit 195
editing resulting equation 184
exporting results 186–187
extrapolating 194
forcing fit through the origin 194
getting values from 188–192
increasing curve fit points 194
limiting parameters 183
line style 128, 193
line width 128, 193
multiple independent variables 183
removing 192
viewing coefficients 185
weighting data 183
customizing plots
Bar plots 134–136
Pie charts 139–140
Polar plots 137–138
Cut command 45, 153
cutting data 45

data
adding to saved plot 133
binning 54–57
clearing 46
copying 45
creating a series 37
cutting 45
entering 35–37
entering for statistical tests 58, 61, 69
executing macros 50
extracting from plot 131–132
importing 38
interpolating 85
masking 49–50, 84, 147–149
missing values 37
opening 20
pasting 46
printing 51
saving 51
selecting subset of data 149
sorting 46
statistics 53
transposing 47
unmasking 49–50, 84
updating in a plot 132
Data Selection tool
description 143
removing outliers 148
selecting subset of data 149
using 147–149
data windows
adding rows and columns 28
changing
column widths 31
data format 45
font and style 32
row height 31
closing 26
column numbers 33
copying curve fit values into 187
copying residuals into 187
creating new 25
cutting, copying, pasting, and clearing data 45
deleting rows and columns 29
displaying 25
displaying column titles 44
entering data 35–37
extracting 131
going to a cell 27
hiding 25
importing
Excel files 38
text files 38
inserting rows and columns 29
moving around 26
opening 20
overview 18
printing 51
saving 51
saving in a v3.5 format 21
selecting cells 27–28
setting defaults 32
splitting 33
switching between Overwrite and Insert Mode 27
toolbar 20
dates
entering 36
performing calculations 85
default attributes
data window 32
legend 108, 114
objects 164
plot layout 108, 130
setting 23
tables 146
text labels 158
Text tool 262
Default Date Format setting 36
Defaults button 32
Define Layout command 108, 114, 130
defining
constants in library 247
curve fits in library 249–250
custom General curve fit equation 180
mathematical functions in library 247
plot layouts 108, 130
variables in library 246
Delete Column command 29
Delete Row command 29
deleting
  items in layout window 222
  objects 153
  rows and columns 29
Descending Sort command 46
deselecting objects 151
diff() function 89
Display Equation command 184
Display Pie Values check box 140
Display pop-up menu 99
Display R^2 instead of R check box 186
displaying
column numbers 33
curve fit coefficients 185
curve fit equations 184
data used to create a plot 131
data windows 25
error arcs 200
error bar cap 202
grid lines 123–124
  in layout window 222
  in plot window 112
layout window 211
plot windows 112
point coordinates 147
ruler 112, 222
tick marks 123, 257
Dot plot 98
Double X plot 94
Double XY plot 95
Double Y Bar plot
  adding lines 136
  adding value labels 135
  changing column offset 134
  customizing 134–136
  description 100
  removing column frame 134
Double Y Column plot
  adding lines 136
  adding value labels 135
  changing column offset 134
  customizing 134–136
  description 102
  removing column frame 134
Double Y plot 94
Down command 155
Draw Cap Only check box 202
Draw Column Frame check box 134
Draw Error Arc check box 200
Draw Pie Frame check box 139
drawing shapes 160–164
Dunnett test 78, 266
Duplicate command 152
duplicating objects 152
E
Edit Arrow Heads command 161
Edit Colors command 165
Edit General command 176–178
Edit Object command 161, 164
editing
  arcs 161
  arrowheads 161
  arrows 160
  axes 116–121
  axis labels 125–126, 157
  axis titles 157
  background plot color 129, 261
  Bezier curves 164
  circles 161
  column titles 44
  curve fit color 128, 193
  curve fit equations 184
  curve fit line style 128, 193
  curve fit line width 128, 193
  data format 45
  grid color 129, 261
  grid lines 122–124, 257
  interior plot color 129, 261
  legend frame 113
  legend text 115, 157
  lines 160
  marker size 128, 259
  marker type 128, 259
  master curve fit list 176
  number of markers displayed 128, 259
  object attributes 165–166
  ovals 161
  plot color 129, 260
  plot frame color 129, 261
  plot labels 157
  plot symbol 127–129, 259
  plot titles 157
  plots in group layout 222
  polygons 162
  rectangles 161
  rounded rectangles 161
  rounded squares 161
  shapes 160–164
  squares 161
tables 146
text labels 156–159, 261
tick marks 122–124
value labels 157
variable color 128, 259
variable line style 128, 260
variable line width 128, 260
entering
custom curve fit definition 180
data 35–37
data for statistical tests 58, 61, 69
date and time data 36
formulas 82
numeric data 35
text data 37
EPSF files
importing 205
Equation Label Format command 184, 193
equations
Chi Square 268
General curve fit 268
kurtosis 264
mean 264
R 268
RMS 264
skewness 264
standard deviation 264
standard error 264
statistics 264
t-test 265
variance 264
See also curve fit equations
Erase Background command 217
Eraser tool 142, 153, 222
erf() function 89
erfc() function 89
error arcs 200
Error Bar Length field 203
error bars
adding 195–203
cap length 203
color 196
displaying arcs 200–201
only displaying error cap 202
plotting values from a column 197
removing 203
single-sided 199–200
text 197–199
thickness 196
Error Bars command 195–203
errors, General curve fit results 186
Excel files, importing 38
Exchange X and Y Axis check box 120
exchanging
axes 120, 256
files 21
execute() function 92, 230
executing
formulas 82
macros 50
exp() function 89
Expand/Collapse button 33, 81, 270
exploded Pie chart 139
Exponential curve fit
data restrictions 168
description 168
function 168
reference 267
exporting
data 51
files in a v3.5 format 21
graphics files 209
layout files 221
layouts 219
PDF files 210
plot script files 229
plots
to Clipboard 208
via a plot script 229
with data 206
without data 206
PostScript files 210
text files 51
expr() function 91
Extract button 19, 107, 131–133, 222
Extract Data command 104, 107, 131–133
Extrapolate Fit to Axis Limits check box 194
extrapolating curve fits 194
F
F probability value 64
F Test check box 64
F value 64–67, 72–73, 265
factorial 87
file formats 207
files
exchanging 21
opening 20
sharing 21
fill pattern
legend 113
objects 166
variable 128, 259
filter() function 84
Fisher’s LSD test 78, 266
Fix Size setting 214
font 32
Force Line fit through zero check box 194
foreground color
legend 113
objects 165
formatting
  axis labels 126, 258
  columns 30–32
Formula Entry
  adding comments 87
  assigning formulas to function buttons 82
  calculating statistics 83–84
  calculating values from a curve fit 188–192
  commands 87–92
  creating a formula 81
  creating a formula script 230
  curve fit functions 91–92
  date and time calculations 85
  entering a formula 82
  executing a formula 82
  formula scripts 230–243
  formula structure 81
  interpolating data 85
  masking data 84
  math functions 89–90
  multi-line formulas 86–87
  operators 87–88
  referencing cells 81
  referencing columns 81
  referencing memory registers 81
  special functions 92
  statistics functions 90–91
  unmasking data 84
Formula Entry command 79
formula scripts 110, 230–243
  commands 231–240
  creating 230
  examples 241–243
  saving 230
formulas
  assigning to function buttons 82
  creating 81
  entering 82
  executing 82
  multi-line 86–87
  structure of 81
  using 82
fract() function 89
Frame settings
  Plot Size dialog 214
  Set Plot Size dialog 130
frame thickness 121
Frame Thickness field
  See Axis Thickness field
frequency of axis labels 126
Friedman command 74
Friedman test
  entering data 69
  performing 74
  reference 266
  function buttons 82
  Function plot 103, 107
G
  Gaussian equation 271
  gen() function 91
General curve fit 174–184
  adding a new fit 176
  adding fits to saved plots 177
  affect on Macro Calculator 184
  applying 181–182
  Chi Square 186
  constructing equation 174
  Curve Fit Definition dialog 175
  curve fit equation 174
  defining equations in library 249–250
  description 168
  entering custom curve fit definition 180
  equations 268
  importing definitions 178–179
  importing definitions from a text file 178
  importing library definitions 179
  initial conditions 175
  limiting parameters 183
  master curve fit list 176
  math functions 89
  multivariate fits 183
  operators 87
  parameter errors 186
  predefined equations 178–179
  rearranging a curve fit 176
  reference 267
  removing a curve fit definition 177
  saving changes 177
  statistics functions 90
  weighting data 183
General submenu 176–179
getting Help 22
GIF files
  description 207
  exporting 209
  importing 205
  resolution 207
Go To Cell command 27
graphic files
  exporting 209
  importing 205
grid lines
  description 19
  displaying 123–124
    in layout window 222
Index

in plot window 112
editing 122–124, 257
editing color 129, 261
thickness 124
Grid Thickness field 124
Group command 153
Group Layout files 221–222, 254
grouping objects 153

H
height, row 31
Help 22
Hide All Plots command 111
Hide Window command 25, 111
hiding
axis 119, 256
data windows 25
grids 112, 222
plot windows 111
ruler 112, 222
High Resolution check box 207
High/Low plot 95
Histogram Options command
See Plot Options command
Histogram plot 97
Holm test 77, 266
Home button 26
Horizontal Bar plot
adding lines 136
adding value labels 135
changing column offset 134
customizing 134–136
description 99
removing column frame 134

I
icons
Color 113, 165, 218
Pattern 113, 166, 218
Style 114, 166, 218
toolbox
Axis Options 144
Color 143–144
Fill Pattern 144
Marker 144
Pattern 143
Style 143
Variable Color 144
Identify tool
description 143
using 147
if-else function 88
images
exporting 208–209
importing 205
Import command 20
importing
curve fit definitions 178–179
data files 20
Excel files 38
graphic files 205
missing data 39
plot script files 229
plots 20
plots into layout window 212
text files 38–44
text files using Special format 41–44
increasing number of curve fit points 194
index() function 89
initial conditions 175
inorm() function 89
Insert Column command 29
Insert Mode command 27
Insert Row command 29
inserting
axis break 119
rows and columns 29
Inside Length field 124
installing KaleidaGraph 16
int() function 89
interior color, editing 129, 261
interp() function 91
Interpolate curve fit
data restrictions 169
description 169
reference 267
interpolating data 85
interval 124
invcos() function 89
Invert Mask command 49
invsin() function 89
invttan() function 89

J
JPEG files
description 207
exporting 209
importing 205
resolution 207
justification 32

K
KaleidaGraph
installing 16
quitting 24
settings files 253–254
starting 17
toolbar 20
toolbox 141
uninstalling 16
keyboard shortcuts
  moving in data window 26
  moving objects 151
  plot window 255
toolbox 255
Keyboard Viewer 158
KG Layout file 254
KG Macros file 253
KG Script file 254
KG Style file 253
Kruskal-Wallis command 68
Kruskal-Wallis test
  entering data 61
  performing 67
  reference 266
kurtosis equation 264
kurtosis() function 90

L
labels
  See axis labels or text labels
layering objects 155
layout files
  description 254
  opening 221
  saving 221
  saving in a v3.5 format 21
types 221
layout window
  adding
    background 217
    border 217
    empty cells 212
    plots 212
  arranging plots 215
  changing magnification 222
  copying 219
  creating new layout 211
  deleting items 222
  displaying 211
  exporting 219
  grids 222
  modifying plots 222
  opening saved layout files 221
  overlaying plots 216
  placing plots in the layout 212
  printing 220
  refreshing 222
  ruler 222
  setting plot size and position 213–214
  switching between layouts 222
layout, defining 108, 130
Least Squares curve fitting 171
legend
  background color 113, 165
  description 19
  editing text 115, 157
  fill pattern 113
  foreground color 113, 165
  line style 114
  line width 114
  moving 151
  moving text labels 115, 157
  order of variables 19, 113
  pen pattern 113
  removing frame 114
  resizing 152
  saving default style 108
  text color 115
length of tick marks 124
Levenberg-Marquardt algorithm 168, 174
library
  creating new library 251
  defining
    constants 247
    curve fit definition 249–250
    mathematical functions 247
    variables 246
  importing curve fit definitions 179
  loading saved library 251
  overview 245
  saving 251
  syntax 246
Library command 179, 245–251
limit() function 183
limits
  axis limits 117
  parameters 183
lin() function 91
Line plot 93
line style
  curve fit 128, 193
  legend 114
  objects 166
  variable 128, 260
Line Style pop-up menu 193
Line Thickness field 129
Line tool
  description 142
  using 160–161
line width
curve fit 128, 193
legend 114
objects 166
variable 128, 260
Line Width pop-up menu 193
linear
  interpolation 85, 90
  scaling 117, 256
Linear Correlation Coefficient 186
Linear curve fit
  description 168
  forcing through origin 194
  function 168
  reference 267
lines
  adding to Bar/Column plots 136
  creating 160
  editing 160
Link Error Bars check box 199
Link Text To Variable Color check box 115, 128
Link Text to Variable Color check box 193
Link To pop-up menu 120
Link to Variable Color check box 193
Link to Variable Settings check box 128
linking
  axes 120, 256
ln() function 90
log() function 90
Logarithmic curve fit
  data restrictions 168
  description 168
  function 168
  reference 267
logarithmic scaling 117, 256
logr() function 91
M
Macro Calculator 184
macro files
  description 253
  saving curve fit changes 177
  saving library 251
macro() function 92
macros, using 50–51
magnification level 112, 222
major
  grids 122
  tick marks
    changing display 123, 257
    changing intervals 124
    description 19
    number of 123
making
  notes about the data 33
  selections 27
Mann-Whitney test
  See Wilcoxon-Mann-Whitney test
Marker pop-up menu 128
Marker Size pop-up menu 128
Marker Thickness field 129
markers
  number displayed 128, 259
  opaque 128
  size 128, 259
  thickness 129
  transparent 128
  type 128, 259
Mask command 49
mask() function 84, 92
masking data 49–50, 84, 147–149
master curve fit list 176–177
mathematical functions, defining in library 247
matrix operator 83, 88
Maximum field 117
mean equation 264
mean() function 91
median() function 91
memory registers 81, 184
Metafile images
  exporting 209
  importing 205
Microsoft Excel files, importing 38
Minimum field 117
minor
  grids 122
  tick marks
    changing display 123, 257
    description 19
    number of 123
Missing Data Breaks check box 37
missing data values
  entering 37
  importing 39
mod function 87
moving
  axes 118
  in the data window 26–27
  legend 151
  legend text 115, 157
  objects 151
  pie slices 139
  plot 151
  text labels 151
multi-line formulas 86
multiple data sets 105
  independent variables 183
  X-Y pairs on a plot 106
multiple comparisons
  See post hoc tests
multivariate fits 183

N
name() function 92
New command 25
New Layout command 211
New Position command 212
No Axis check box
  See Turn Off Axis check box
nonlinear curve fit 174
nonparametric tests 58
norm() function 90
notes 33
npts() function 91

O
object attributes
  background color 165
  fill pattern 166
  foreground color 165
  line style 166
  line width 166
  pen pattern 166
  setting defaults 164
objects
  aligning 154
  constraining shape of 152
  copying 152
  creating 160–164
  deleting 153
  deselecting 151
  duplicating 152
  editing 160–164
  grouping 153
  layering 155
  moving 151
  pasting 153
  resizing 152
  selecting 151
  sending up or down 155
  ungrouping 153
obtaining values from a curve fit 188
offset 131, 213
offset axes 118
one way ANOVA
  entering data 61
  performing 65
  post hoc tests 76
  reference 266
one way repeated measures ANOVA
  entering data 69
  performing 72
  post hoc tests 76
  reference 266
Only use built-in sizes check box 158
Open command 20, 221
opening
  data files 20
  Excel files 38
  KaleidaGraph files 20
  layout files 221
  library file 251
  plot script files 229
  plots 20
  text files 38
operators 87
origin 194
Origin settings
  Plot Size dialog 214
  Set Plot Size dialog 130
outliers
  Box plot 263
  removing 148
Outside Length field 124
Oval tool
  description 142
  using 161
ovals
  creating 161
  editing 161
overlaying plots
  from multiple data windows 105
  from one data window 106
  in the Layout window 216–217
Overwrite Mode command 27

P
P value 60, 65–67, 72–73, 74
Page Setup command 206, 220
paired t-test
  entering data 69
  performing 71
parameter
  errors 186
  limits 183
  values 193
parametric tests 58
Paste command 46, 153, 205
pasting
  data 46
objects 153
Pattern icon 113, 143, 166, 218
PDF files, exporting 210
pen pattern
legend 113
objects 166
Percentile plot 98
pi function 90
PICT files
description 207
exporting 209
importing 205
resolution 207
Pie chart
adding value labels 140
customizing 139–140
description 103
exploding 139
plotting negative values 103
removing plot frame 139
Plot Color command
See Axis Options command
Plot Extras command
See Plot Options command
plot frame
editing color 129, 261
resizing 130–131
Plot Options command 96–97, 102, 129, 134, 203
plot script
creating 224–225
exporting plots 229
pattern recognition 227
selecting different data windows 228
setting legends 226–227
setting titles 226–227
when to use 223
Plot Script command 224–229
plot script files
description 254
exporting 229
importing 229
Plot Style command
See Variable Settings command
plot symbol, editing 127–129, 259
plot title
adding special characters 158
adding subscripts and superscripts 158
defining in a plot script 226
description 19
editing 157
setting defaults 158
plot tools 141–143
plot windows
changing magnification 112
closing 112
displaying 112
 grids 112
hiding 111
importing images into 205
overview 18
ruler 112
plots
adding data 133
adding error bars 195–203
adding to layout window 212
changing plot color 129
copying to Clipboard 208
creating 104
creating and editing text 156–159
curve fitting 171–195
defining layout 108, 130
editing in group layout 222
exporting
in a v3.5 format 21
with data 206
without data 206
extracting data 131
finding coordinates 147
modifying
axes 116–121
axis labels 125–126, 258
grid lines 122–124, 257
legend 113–115
lines, markers, and fill patterns 127–129, 259
tick marks 122–124
moving 151
opening 20
overlaying 216
plotting from multiple data sets 105
plotting multiple X-Y pairs 106
printing 206
removing outliers 148
resizing 130–131
saving
in a v3.5 format 21
with data 206
without data 206
selecting subset of data 149
similar 108–110
updating 132–133
plotting
additional data 133
error values from a data column 197
function 107
multiple data sets 105
multiple X variables 106
PNG files
description 207
exporting 209
importing 205
resolution 207
Polar Options command
See Plot Options command
Polar plot
   customizing 137–138
description 102
poly() function 91
Polygon tool
description 142
   using 162
polygons
   creating 162
   editing 162
Polynomial curve fit
   applying 171–172
description 168
   function 168
   reference 267
position
   axis 118
   axis break 119
Post Hoc Test pop-up menu 76
post hoc tests
   Bonferroni test 77
   choosing 76
   Dunnett test 78
   Fisher’s LSD test 78
   Holm test 77
   performing 76
   Scheffe test 78
   Student-Newman-Keuls test 77
   Tukey HSD test 76
Posted Note
data window 33
   Formula Entry window 86–87, 230
Posted Note button 33, 86, 230
Posted Note command 33
PostScript files, exporting 210
pow() function 91
Power curve fit
   data restrictions 169
description 169
   function 169
   reference 267
precision 193
predefined curve fit definitions 178–179
Preferences command 23, 32
preferences, setting 23, 158, 165
Print Data command 51
Print Graphics command 206
Print Layout command 220
printing
   data 51
   layouts 220
   plots 206
   plots via a plot script 229
Probability Options command
   See Plot Options command
Probability plot 96
Promote 2 digit dates less than 40 check box 36

Q
Quit command 24
quitting KaleidaGraph 24

R
R 186
R equation 268
R² 186
radial axis 137
ran() function 90
rearranging the master curve fit list 176
Recent Files command 20
rectangles
   creating 161
   editing 161
refreshing the layout 222
removing
   axis 119, 256
   axis break 119
   axis labels 126
   curve fit 192
   curve fit from master list 177
   error bars 203
   frame in Pie chart 139
   outliers 148
repeated measurements 69
Repeated Measures check box 73–74
Repeating Factor Name field 73–74
residuals 187
resizing
   axis 130–131
   legend 152
   objects 152
   plot 130–131
   plot frame 130–131
resolution 207
Reverse Axis Direction check box 120
RMS equation 264
rms() function 91
Rounded Rectangle tool
description 142
Index

using 161
rounded rectangles
creating 161
editing 161
rounded squares
creating 161
editing 161
row height 31
rows
adding 28
changing height 31
deleting 29
inserting 29
selecting 27
transposing data 47
rsum() function 90
ruler 112, 222
Ruler & Grids command 112, 222
running sum 90

S
Same as Plot Window setting 214
Save Data As command 21, 51
Save Data command 51
Save Graph As command 21, 206, 209
Save Graph command 206
Save Layout As command 21, 219, 221
Save Script As command 229
saving
changes to Curve Fit menu 177
data 51
files in a v3.5 format 21
formula scripts 230
group layout files 221
layout files 221
library file 251
multi-line formulas 87
plot script files 229
plots
via a plot script 229
with data 206
without data 206
text files 51
Scale pop-up menu 117
Scale Result by field 207
scaling 117, 256
Scatter plot 94
Scheffe test 78, 266
scientific notation 36
script() function 92
scripting
formula scripts 230–243
plot scripts 110, 223–229
scripts. See formula scripts or plot scripts
Select All command 28
Select Plot command 212
selecting
all cells 28
columns 28
fill patterns for variables 128, 259
Help topics 22
objects 151
range of cells 27
rows 27
subset of data 149
variables in the Variable Settings dialog 127
Selection Arrow 118, 141
Send To Back command 155
sending objects up or down 155
serial number 17
series 37
Set Background command 217
Set Defaults command 146
Set Legends button 226
Set Plot Size command 130
Set Titles button 226
setting
axis limits 117
data window defaults 32
default attributes for shapes 164
defaults 23
legends in a plot script 226–227
limits on parameters 183
plot size and position in layout window 213
preferences 23
text defaults 158
titles in a plot script 226–227
Settings button 209
settings files 253–254
shapes
background color 165
creating 160–164
default attributes 164
editing 160–164
fill pattern 166
foreground color 165
line style 166
line width 166
pen pattern 166
sharing files 21
shortcuts
plot window 255
shortcut menu 20
toolbox 255
Show All Plots command 112
Show Axis Break check box 119
Show Column Numbers check box 18, 33
Show Data command 25
Show Data Tools command 20
Show Layout command 211, 222
Show Markers pop-up menu 128
Show Page command 211
Show Plot command 111–112, 222
Show the plot paper boundary check box 130
sin() function 90
single sample t-test
  entering data 58
  performing 58
single-sided error bars 199–200
size
  markers 128, 259
  of plots in layout window 213
  plot size 130
skew() function 91
skewness equation 264
Smooth curve fit
  data restrictions 169
  description 169
  reference 267
smooth() function 92
sorting data 46
special characters, adding to text 158
Special format 41–44
spline() function 92
splitting the data window 33
sqrt() function 90
squares
  creating 161
  editing 161
Stack Bar plot
  adding value labels 135
  changing column offset 134
  customizing 134–135
  description 100
  removing column frame 134
Stack Column plot
  adding value labels 135
  changing column offset 134
  customizing 134–135
  description 101
  removing column frame 134
standard deviation equation 264
standard error equation 264
starting KaleidaGraph 17
statistical tests
  choosing 57
  entering data 58, 61, 69
  Friedman test 74
Kruskal-Wallis test 67
  nonparametric tests 58
  one way ANOVA 65
  one way repeated measures ANOVA 72
  paired t-test 71
  parametric tests 58
  post hoc tests 76
  single sample t-test 58
  two way ANOVA 67
  two way repeated measures ANOVA 73
  unpaired t-test 64
  Wilcoxon matched pairs test 72
  Wilcoxon signed rank test 60
  Wilcoxon-Mann-Whitney test 65
statistics
  calculating with Formula Entry 83–84
  equations 264
  transposing 53
  viewing column statistics 53
Statistics command 53
std() function 91
stderr() function 91
Step Options command
  See Plot Options command
Step plot 96
Student t command 59, 64, 71
Student-Newman-Keuls test 77, 266
style files 108, 253
Style icon 114, 166, 218
Sub/Super Size field 158
Subscript command 158
Subscript Offset field 158
subscripts 44, 158
Summary Column plot 99
Superscript command 158
Superscript Offset field 158
superscripts 44, 158
switching between
  layouts 222
  Overwrite and Insert Mode 27
symbols 128
syntax for library definitions 246
system requirements 15
T
t probability value 58, 64, 71
t value 265
Table tool
  description 142
  using 145–146
table() function 85, 90, 183
tables
creating 145
 editing 146
 setting defaults 146

\text{tan()} function 90

Template plot
 description 103
 using 109

Test Value field 59, 60

tests
 See statistical tests

text data, entering 37

text error bars 197–199

Text File Input Format dialog 39

text files
 importing 38–44
 saving 51

text labels
 adding special characters 158
 adding subscripts and superscripts 158
 creating 156
 editing 156–159, 261
 moving 151
 setting defaults 158

Text Mode command 45

Text Options command 159, 193

Text plot 103

Text tool
 description 142
 editing legend 115
 using 156–159

thickness
 axis 121
 error bars 196
 grid line 124
 markers 129
 plot frame 121

tick marks
 changing display 123
 description 19
 editing 122–124
 intervals 124
 length 124
 specifying number of 123
 thickness 124

Tick Thickness field 124

TIFF files
 description 207
 exporting 209
 importing 205
 resolution 207

time data
 entering 36
 performing calculations 85

titles
 adding special characters 158
 adding subscripts and superscripts 158
 defining in a plot script 226
 editing 157
 setting defaults 158

toolbar 20

toolbox 141–144
 transferring files 21

Transpose command 47

Transposed check box 53

transposing
 data 47
 statistics 53

t-test
 equations 265
 paired data 71
 single sample 58
 unpaired data 64

Tukey HSD test 76, 266

Turn Off Axis check box 119, 137

two way ANOVA
 entering data 61
 performing 67
 reference 266

two way repeated measures ANOVA
 entering data 69
 performing 73
 reference 266

U

UnGroup command 153

ungrouping objects 153

uninstalling KaleidaGraph 16

Units setting 214

Unmask command 49

unmask() function 84, 92

unmasking data 49

unpaired t-test
 entering data 61
 performing 64

Up command 155

Update Plot button 132–133

Update Plot command 132–133

updating
 plots 132–133

using
 Align tool 154
 Arc tool 161
 Bezier curve tool 163–164
 Box tool 161
 Data Selection tool 147–149
formula scripts 230–243
Identify tool 147
Line tool 160
macros 50
Oval tool 161
plot scripts 110, 223–229
Polygon tool 162
Rounded Rectangle tool 161
shortcut menu 20
Special format 41
Table tool 145–146
Template plots 109
Text tool 156–159
toolbar 20
Zoom Selection tool 149–150

V
Value Label Format command 135, 140
value labels
   adding 135, 140
   editing 157
var() function 91
variable
   color 128, 259
   defining in library 246
   fill pattern 128, 259
   line style 128, 260
   line width 128, 260
   selecting in the Variable Settings dialog 127
Variable Settings command 127–129, 193
variance equation 264
viewing coefficients 185

W
Weight Data check box 183
Weighted curve fit
   data restrictions 169
   description 169
   reference 267
wgt() function 92
width
   axis break 119
   data column 31
Wilcoxon command 60, 65, 72
Wilcoxon matched pairs test
   entering data 69
   performing 72
   reference 266
Wilcoxon signed rank test
   entering data 58
   performing 60
   reference 266
Wilcoxon-Mann-Whitney test
   entering data 61
   performing 65
   reference 266
Windows BMP files
   description 207
   exporting 209
   importing 205
   resolution 207

X
X Label Format command
   See Axis Options command
X2 Label Format command
   See Axis Options command
X-Y Probability plot 96

Y
Y Label Format command
   See Axis Options command
Y2 Label Format command
   See Axis Options command

Z
Zoom Selection tool
   description 143
   panning 150
   using 149–150
   zoom setting 19, 112, 222